Announcement

Collapse
No announcement yet.

LWO import through code dosnt work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    LWO import through code dosnt work

    Im trying to create a standart plane muzzle to allternate the 3d one so i modeled a plane square and a masked texture to go with it but when i try to import i get this

    "
    Parsing WW3Muzzle1
    Error in WW3Muzzle1.uc (5): Could not open Models\WW3Muzzle1.lwo
    Warning in WW3Muzzle1.uc (5): Could not import Models\WW3Muzzle1.lwo as Muzzle1Mesh
    Compile aborted due to errors.
    Failure - 1 error(s), 2 warning(s)
    "
    Model is in place and double checked everything i tried and making the muzzle as a standart staticmesh, it dosent work and i saww all muzzles in ut2004 are made this way

    here is the cod, thx for advance

    Code:
    class WW3Muzzle1 extends xEmitter;
    
    #exec OBJ LOAD FILE=WW3Textures.utx
    
    #exec STATICMESH IMPORT NAME=Muzzle1Mesh FILE=Models\WW3Muzzle1.lwo COLLISION=0
    
    var int mNumPerFlash;
    
    simulated function Trigger(Actor Other, Pawn EventInstigator)
    {
        mStartParticles += mNumPerFlash;
    }
    
    defaultproperties
    {
         mNumPerFlash=5
         mParticleType=PT_Mesh
         mStartParticles=0
         mMaxParticles=5
         mLifeRange(0)=0.100000
         mLifeRange(1)=0.150000
         mRegenRange(0)=0.000000
         mRegenRange(1)=0.000000
         mSpawnVecB=(Z=0.000000)
         mSpeedRange(0)=0.000000
         mSpeedRange(1)=0.000000
         mPosRelative=True
         mAirResistance=0.000000
         mSizeRange(0)=0.050000
         mSizeRange(1)=0.080000
         mGrowthRate=7.000000
         mRandTextures=True
         mTileAnimation=False
         mNumTileColumns=1
         mNumTileRows=1
         mMeshNodes(0)=StaticMesh'WW3Inventory.Muzzle1Mesh'
         DrawScale=2.200000
         Skins(0)=FinalBlend'WW3Textures.Muzzle1'
         Style=STY_Additive
    }

    #2
    If you can't import it manually, there is probably something wrong with your model/scene format.

    Comment


      #3
      Its 2 plane squares 4 triangles . . and 1 material . . thats about the scene and the format of the model i tried to export it in 3 diffrent versions of lightwave, same result.

      I tried importing it through the editor and it works fine . .

      i have no idea whats wrong any help will be appreciated and maybe there is a better way to make a new muzzle ?

      Comment

      Working...
      X