Announcement

Collapse
No announcement yet.

Vec emitter not being killed at end of round

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Vec emitter not being killed at end of round

    I have a vec that uses an emitter, defined as 'beam'. I have the following code in the vehicle's class:

    Code:
    simulated function Destroyed()
    {
    
         If (Beam != None)
              Beam.Destroy();
         Super.Destroyed();
    }
    The problem is, that once in a while the emitter remains after the end of a round in ONS. I noticed that occasionally this happend to the dust effects of the manta, but I don't recall seeing that recently, so I figured it was fixed in an update. Any idea of why the beam would still be sticking around? Thanks, Greg.

    [Edit] Fixed my retarded spelling errors. .

    #2
    Try destroying it in DestroyAppearance() as well.

    I've also seen that happen to Manta dust effects. Dunno why. Kinda hard to test.

    Comment


      #3
      Try destroying it in DestroyAppearance() as well.
      That's waht I was looking for when I was finishing up my warwing, , and I just couldn't find it. . Thanks. .

      I've also seen that happen to Manta dust effects. Dunno why. Kinda hard to test.
      Then it is something in the game itself, , ,then I won't sweat it too much unless it happens constantly. I thought maybe it was something on my system maybe.. .

      Comment


        #4
        Yeah, that manta dust bug is annoying. The funniest thing is, I've seen it crop up on levels where I substituted out the Manta!!!

        I've also seen "phantom headlights" that only appear from certain angles, but are attributed to no vehicle.

        I was thinking of making a special "cleanup" mutator -- at the end of every round, it would go around and Kill() every Emitter that didn't have a proper owner. Any thoughts on that?

        Comment


          #5
          You'd kill the emitters that the mapper put in?

          Comment

          Working...
          X