Announcement

Collapse
No announcement yet.

Weapon Emmiter: Beam not always visible

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Weapon Emmiter: Beam not always visible

    I have a vec weapon that uses an emitter (not xemitter) for its beam. It is a rather long range weapon, and often it is invisible, unless you turn and look more towards the weapon iteslf. Any idea how to fix this?

    #2
    can you post a pic or two? and what type of emitter are you using (presuming the beam type).

    Comment


      #3
      Yes, it's an emitter with two beam emitters, and a mesh emitter. I can post a picture, , but there's not much to see. If the vec is BEHIND you, and firing past you, no beam is visible, but if you turn towards the source, at some point it suddenly becomes visible. I'm not sure how to show that in a picture.

      Comment


        #4
        Upload a demorec.

        Comment


          #5
          I believe that if you can't see the center of a particle, it doesn't get drawn. Yay.

          Comment


            #6
            That fits the issue perfectly. Any ideas of a workaround? Does that apply to xEmitters also?
            Also, the beam isn't showing up in demos, , is that a network thing? I noticed I had to put the packages in my serverpackages in order for them to show up in the demo.

            Comment


              #7
              Does the particle not showing up if you can't see the center of it apply to xEmitters also?
              Thanks, Greg.

              Comment


                #8
                So changing the CullDistance or equivalent doesn't fix it?

                Comment


                  #9
                  Nope, I can be right beside it, but if the majority of the beam is not within my view, then NONE of it shows up. .

                  Comment

                  Working...
                  X