Announcement

Collapse
No announcement yet.

Gametype not showing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Gametype not showing

    What do you need to make it show under custom gametypes ?
    I followed a tutorial and this is my current minimal code with no functions for now :

    Code:
    class lolmatch extends xDeathMatch config;
    
    DefaultProperties
    {
        MapPrefix="DM"
        BeaconName="DM"
        GameName="Test"
        Description="Its a test"
        Acronym="DM"
    }
    Still it works if I run the game via Game= switch, but nothing new in the menus ...

    #2
    Not sure if you can use a prefix that's already used by another game type.

    Comment


      #3
      Reusing a map prefix is ok, but the beacon name and the acronym should be unique.

      Comment


        #4
        Got this but it doesn't work (even if I try a new prefix). Is there some property I'm missing ?
        Code:
        DefaultProperties
        {
            MapPrefix="DM"
            BeaconName="xyz"
            GameName="Test"
            Description="Its a test"
            Acronym="xyz"
        }

        Comment


          #5
          mh, try the dumpint-command on your package:
          get into the commandline, navigate to your UT2004-System folder (cd C:\UT2004\System for example) and enter: ucc dumpint PackageName.u.

          Comment


            #6
            UT2004 doesn't use INT files for that at all. You only need DumpInt if you want to localize (translate into other languages) your mod. You should, however, make sure UCC Make generates the UCL file for your package. If you're using UMake you may have to edit make.ini in your project directory to include the line "CacheRecordPath=../System/*.ucl". If that doesn't help, try deleting any existing <yourmod>.ucl and run UCC ExportCache.

            Comment


              #7
              thought that UT2004 is still using the int-files for two things besides localization (GameTypes and another).

              Comment


                #8
                UT2004 uses INT files for localization, custom keybind menu options and the menu window that pops up when you type "preferences" in the console. DumpInt only exports localizable properties that have already been set in defaultproperties. Everything else must be set up manually.

                Comment


                  #9
                  Problem solved, turns out I didn't work because I had set up a new profile in UDE and compiling for that, or some silly error on my end, sorry for the trouble

                  Comment

                  Working...
                  X