No announcement yet.

Starting UT2K4 with a custom map inside Mod Architeture

  • Filter
  • Time
  • Show
Clear All
new posts

    Starting UT2K4 with a custom map inside Mod Architeture

    Hey guys, I'll try to explain it in a non confusing way (because it confuses the hell out of me):

    I recently decided to use the Mod Architeture. So I got my maps working pretty inside their map folder inside the mod folder (not without some pain first).

    Except when I try to run the mod's map automatically starting UT2004 with the command line:

    C:\UT2004\System\UT2004.exe -mod=myMod myMap

    Instead of automatically running myMap, it starts myMod and goes to the menus, where I can run myMap. My guess is that Unreal is looking for myMap in its main map folder instead of the mod map folder and therefore not finding it. So I tried the following:

    C:\UT2004\System\UT2004.exe -mod=myMod ../myMod/maps/myMap

    But it also doesn't work. Does somebody know the command line to locate a map that isn't inside Unreal main map folder? Better yet, does somebody know where I can find a list of all UT2004 command lines? I found this:

    but it doesn't have it.


    This question is almost stupid, but ill ask it anyway :P. Did you remember to type Yourmap.ut2 e.g. with the ut2 extension?


      I just tried it with the .ut2 extension and it also doesn't work.


        hi fred, you nearly had it
        C:\UT2004\System\UT2004.exe -mod=myMod myMap should be
        C:\UT2004\System\UT2004.exe myMap -mod=myMod


          THANX Proto, that works!

          I can't believe I didn't try that =)