Announcement

Collapse
No announcement yet.

Odd object error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Odd object error

    I have a couple of items that use the default properties to set up objects within themselves.
    like so:
    Code:
        Begin Object Class=DLCloseButton Name=CloseButton
        End Object
    
        TopButton=CloseButton
    Now four items subclass the class with that int eh default prperties, but only the last one spawned actually gets control (sort of) of everyones object.

    I seems to call some funciotns on one object, and others on another

    Example
    Hovering over the object with the mouse on the 'owner window of all' causes one of the other items button to go to hover mode (and only one)
    however clicking it aets them all off.

    But when the any item state changes the button refelct it corrctly...

    #2
    I think you need to define the class (or the parent, whatever extends object) as instanced.

    class myClass extends Object instanced;

    Comment


      #3
      Are you sure you're not missing any typecasting?

      Comment


        #4
        I had the same problem in my UI when instantiating "buttons." All of them referenced the same object. The only reason only one recieved the hover notifies was because of the linked list setup. Instanced solved the problem for me (and its a very subtle naunce you probably missed ).

        Comment


          #5
          And here I had come up with a very workaround that involved a function spawning them and then setting them up...


          Instanced hmmm... someone should put that in the Wiki subobject page at the end where they ask how to do this...


          And now it is...

          Comment


            #6
            So that was it?

            Comment


              #7
              Well it works

              Comment

              Working...
              X