No announcement yet.

Map load, editor crashes

  • Filter
  • Time
  • Show
Clear All
new posts

    Map load, editor crashes

    I know I have referred to this in another thread but please let me post this to see if there is any help out there because I am in despair.

    I have been working on a map for several weeks, I had backed up the map but unfortunately I saved over it. Now when I tried load my map the editor crashes and gives me this error:

    Build UT2004_Build_[2004-09-07_17.17]

    OS: Windows XP 5.1 (Build: 2600)
    CPU: GenuineIntel Unknown processor @ 3062 MHz with 510MB RAM
    Video: NVIDIA GeForce FX 5200 (4354)

    Bad expr token 3a

    History: SerializeExpr <- (3A) <- SerializeExpr <- (10) <- SerializeExpr <- (05) <- SerializeExpr <- (0D) <- UStruct::Serialize <- (Class myLevel.OnlineCamera1) <- UState::Serialize <- UClass::Serialize <- (Class myLevel.OnlineCamera1) <- LoadObject <- (Class myLevel.OnlineCamera1 15804438==15804438/15893050 15804379 77) <- ULinkerLoad::Preload <- PreLoadObjects <- UObject::EndLoad <- UObject::LoadPackage <- UEditorEngine::Exec_Map <- UEditorEngine::Exec <- (MAP LOAD FILE="C:\UT2004\Maps\AS-Project.ut2") <- UUnrealEdEngine::Exec <- WEditorFrame::OnCommand <- WWindow::WndProc <- WWindow::StaticProc <- MessagePump <- MainLoop

    I know this seems very specific but it was most likely caused by the creation of a new class which I did to get a "security camera" to work on line, using the information given in a tutorial:

    "In the Actor browser, right click on the CameraTextureClient and hit New. Give it a name, and set the Package to mylevel. Hit OK and a new window will pop up. Hit the Compile Changed Scripts button (three sheets of paper), then once it's done, close out that window. In the Command line at the bottom of UEd, type editdefault class=Onlinecamera, or whatever name you gave it. This will pop up the default property window for it. Under None, look for RemoteRole, and change it to ROLE_SimulatedProxy. Close it out, then use this class instead of the normal CameraTextureClient and it will work online. You may have to uncheck Placeable Classes Only in the Actor browser to get it to show up."

    Now I'm sure this works fine for most but I think it might have something to do with the crashes. I saved shortly after doing this and the problem occured.

    Is there any possible way of me somehow editing the map as a .txt file so I can remove the camera or anything like that? Suggestions anyone?

    Thanks for any help you can give and sorry for posting again, if you already answered previously please ignore this.

    Programmers would probably be able to decipher that message easier, have you posted this in the Programming section?


      Ok thanks Angel I'll try that


        Don't feel too bad about it, I lost a month's work last year when I tried copying the flame-shooting emitter from Rustatorium into my map and the mylevel sound effect screwed up. I couldn't open the map again and had to start over. Ever since then I make a backup of my current map every night.


          Try opening the maps labeled autoplay (0-9) in your maps directory. Those are backups of the maps used in UnrealEd. Open them all (as they are not in any particular order) and find the most recent version of your map that still opens. Save it over your broken map (or something similar) and presto! problem should be solved. You may lose a bit of your work, but you will get your map back.


            Oh my god that actually worked I don't believe it and it's literally about 2 minutes out of date, thankyou so much mate. You'll go in the credits along with Angel.


              Isn't that what I told you to do in the other thread? :bulb:
              Originally posted by Angel_Mapper
              Try an AutoSave?
              Originally posted by Angel_Mapper
              You're the first person to have that problem. If you can't go back far enough with the AutoSave files and you haven't made backups, you're screwed.