Announcement

Collapse
No announcement yet.

Somewhat advanced question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Somewhat advanced question

    I have a long-distance mover involved in one of my maps that starts via a scripted trigger. When the map begins in multiplayer, during the practice round the mover movers thirty times as quickly as it is supposed to, attempting to make the entire trip during the 60 seconds.

    Additionally, when the map begins, the mover does not reset, instead it stops completely, or continues to move too quickly. This error only occurs in netplay.

    Does anyone have any suggestions on how I might rectify this issue?

    #2
    If it's not gameplay important then use a ClientMover.

    Comment


      #3
      Its just dragging some other meshes around, but does nothing itself, I'll give this a shot and post my results.

      Comment


        #4
        Unfortunately, that only half corrected the issue. Since the movers were moving eratically before, they've calmed down and are now moving at the proper speed on all machines. However, the clientmover is in different places depending on the user that is looking at it. I need to find a way to keep the movement, and attached meshes/objectives moving at a consistent rate across all players. Any other ideas Angelmapper? This was a big step in the right direction, but I'm not sure where to go from here.

        Comment


          #5
          Trigger it with a NetworkTrigger.

          Comment


            #6
            How would you go about setting up a network trigger to start automatically to begin the mover? I tried starting it with a scripted trigger, but now the other participants don't see the movers moving at all, just a stand-still, while the host see's everything as it should be.

            Comment


              #7
              *bump*

              Comment

              Working...
              X