Announcement

Collapse
No announcement yet.

Editor crashes on saving after rebuilding bot paths

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Editor crashes on saving after rebuilding bot paths

    I've been improving bot paths on my map, added 100 additional of them or so, but after rebuilding the paths I tried to save the map and the editor crashed with the message that it stopped working (no runtime error or crash log). It seems to happen every time I reach a certain number of nodes but I'm not sure. Editor crashes on save only with all paths rebuilt i.e if I rebuild changed paths only it saves fine. Removing a large chunk of nodes also fixes the problem.
    Any ideas?

    #2
    How many of them do you have?
    One thing you could try is copying all the pathnodes into a new map. Then rebuild and see if it still crashes.

    Comment


      #3
      How many of them do you have?
      thousand and a half or so
      I'm now even more confused. The editor crashes when saving as... but works when just saving or pressing the Play Map button (it successfully saves the map as autoplay.ut2 but i can't do that manually)
      Maybe there's something wrong with my hard drive...

      Comment


        #4
        In that case: What file name are you trying to Save As under?

        Comment


          #5
          Originally posted by UnShame View Post
          Maybe there's something wrong with my hard drive...
          That's also quite likely. Run a chkdsk/fsck and try again first.

          Comment


            #6
            I tried different names and different places, the result is always the same.
            Checking file system didn't display any errors.

            Comment


              #7
              How you add your pathnod ??
              by the menu from the right clik mouse or by duplicate from current pathnod in the map ?

              Comment

              Working...
              X