Announcement

Collapse
No announcement yet.

Garbage collection error crashes dedicated servers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Garbage collection error crashes dedicated servers

    I have a project in the works, it's a map, the gametype is Assault.

    It seems to work fine when run offline and it's acceptable on listen servers, map change seems to work as well on listen servers, however, dedicated servers are driving me nuts.

    Sometimes the map loads fine, but that's only the case, if there is no player. Once a player joins, the server crashes and there is a garbage collection error.
    Whenever a mapchange is forced (through vote), it crashes the server (maybe because players join immediately) - yet again the same issue, garbage collection.

    Here is what it says:
    Code:
    Warning: HoldObjective AS-LobbyVR2PMA7.HoldObjective0 (Function UnrealGame.HoldObjective.PostBeginPlay:0035) AS-LobbyVR2PMA7.HoldObjective0 MoverTag not defined!!!
    Log: MasterServerUplink: Resolved ut2004master2.epicgames.com as 199.255.40.171.
    Log: Resolved master0.gamespy.com (69.10.30.248)
    ScriptLog: UdpGameSpyUplink: Master Server is master0.gamespy.com:27900
    ScriptLog: UdpGameSpyUplink: Port 7788 successfully bound.
    Log: MasterServerUplink: Connection to ut2004master2.epicgames.com established.
    Log: Approval APPROVED
    Log: Master server requests heartbeat 0 with code 1752
    Log: Master server requests heartbeat 1 with code 1752
    Log: Master server requests heartbeat 2 with code 1752
    NetComeGo: Open myLevel 12/30/12 22:03:28 79.237.52.172:61228
    Log: Client netspeed is 10000
    ScriptLog: Pre: ?Name=Sly.?Class=Engine.Pawn?Character=Xan?team=1?Sex=M?Voice=BossVoice.BossVoice
    Log: Master server assigned our MatchID: 0
    ScriptLog: New Player Sly. id=cbd22e782e66525f8834b0c2a845de88
    ScriptLog: START MATCH
    ScriptLog: ASGameInfo::BeginRound
    ScriptLog: ResetLevel
    Log: Collecting garbage
    Critical: UObject::GetFullName
    Critical: TestReach
    Critical: UObject::GetFullName
    Critical: TArray<<
    Critical: UModel::Serialize
    Critical: TestReach
    Critical: (Model AS-LobbyVR2PMA7.Model15)
    Critical: ULevel::Serialize
    Critical: TestReach
    Critical: (Level AS-LobbyVR2PMA7.myLevel)
    Critical: UStruct::SerializeBin
    Critical: (Class Engine.GameEngine GLevel[0])
    Critical: UObject::Serialize
    Critical: (GameEngine Package.GameEngine)
    Critical: UGameEngine::Serialize
    Critical: (GameEngine Package.GameEngine)
    Critical: UGameEngine::Serialize
    Critical: (GameEngine Package.GameEngine)
    Critical: TestReach
    Critical: (GameEngine Package.GameEngine)
    Critical: TArray<<
    Critical: UObject::SerializeRootSet
    Critical: UObject::CollectGarbage
    Critical: UObject::StaticExec
    Critical: UEngine::Exec
    Critical: UGameEngine::Exec
    Critical: AActor::execConsoleCommand
    Critical: UObject::ProcessEvent
    Critical: (ASGameInfo AS-LobbyVR2PMA7.ASGameInfo, Function UnrealGame.DeathMatch.PendingMatch.Timer)
    Critical: AActor::Tick
    Critical: TickAllActors
    Critical: ULevel::Tick
    Critical: (NetMode=1)
    Critical: TickLevel
    Critical: UGameEngine::Tick
    Critical: Level PlaceholderTitle
    Critical: UpdateWorld
    Critical: UServerCommandlet::Main
    Exit: Executing UObject::StaticShutdownAfterError
    Exit: Exiting.
    Log: FileManager: Reading 0 GByte 78 MByte 365 KByte 1009 Bytes from HD took 0.454999 seconds (0.347999 reading, 0.107000 seeking).
    Log: FileManager: 0.066000 seconds spent with misc. duties
    Uninitialized: Name subsystem shut down
    Uninitialized: Log file closed, 12/30/12 22:04:09
    I read that this can happen on mapchange with Assault and Onslaught maps for whatever reason.

    I'm trying several tricks to fix the map, it must have to do with it, every other map works just fine and it can't be there is no solution...

    If anybody knows anything, I would be glad to hear a solution. The kind helper(s) will be credited in readme and a texture within the map.

    If nobody knows a solution, does anybody at least have an idea what is considered garbage?
    Could mover possibly be part of it? If that is the case, then I would try to change some stuff and remove some movers.

    The map has a big wide room in it (with distance fog though), could big brushes possibly bug it? Other than that it contains multiple skyzones (those that Angel Mapper uses as well), however, I haven't heard of any issues with her PhaseShift map either concerning dedicated servers and garbage collection.

    Other than that, I have hidden movers in my map and four camera actors (which actually do work except for displaying players, network camera actor).

    My map is not finished yet, it is still considered alpha but for several reasons I was curious how it would run online and I would like to keep it somewhat private until it is done. On demand I might upload it though.

    #2
    I am not sure what's the exact fix but try one of these , I had server crash error as well as map crash error and I did specific things,
    (Map crash)
    Select all actors present in the map and copy paste it in new map.
    (server crash)
    1-> Deleted some unwanted maps from my map folder which I never play , or don't need.
    2-> Removed some unwanted Gametypes from my mapvoting.
    3-> There was a weird portion in my ut2004.ini above favorites like this ,
    "ñ÷Tàôr%Ðòu1Àðf=°îfI*ìlUée` y`ãS…Páe‘@Þr0Üv© ÚeµØr ÿ- QÚ€[P×~-OÕ}> MÐ{TLÎzrKÌxiJÊwaIÇvl,GÃtSFÀroE¾qlD¼po,B· nMAµlT ?°j<>®i-=¬h] ÿ- N²ëLI²ÞoD²Ñc?²Äa:³¸l5³«H0³žo+´’s'´…t µlFµ_rµRa¶Fn ¶9c¶,e ÿ-")
    Ä$r ÿ- žm[˜n-“p> ‰ sT„%tr€)viz.wau2yl,k;|Se@}o`D€l€o,QRƒMLV…T B_ˆ<=d‰-8h‹] ÿ- sàqLvÒyoyāc|¶‰a€¨‘l‚š™H…Œ¡oˆ~©sŒp±t ’TÁF•FÉr˜8Ña›*Ùnžác¡ée ÿ- @d€LCg|oGkycKnuaOrrl WykR[}he_€ddc„aig‡]rk‹ZeoWcs’Stw–Pi{™Lo€In ÿ-")
    u`$f['fW)lS+e` F2SA4e=6r99v4;e0=r ÿ- ØÔ[ ÔÊ-ÑÀ> *Ê*T4Ç£r?ÄšiIÀaS½†l,g¶sSr³io|°`l†¬Vo,š¦ CM¥¢9T ¹œ&<Ø-Í•] ÿ- åûhL×öjoÉñmc»ípa*èslŸãvH‘ßyoƒÚ|suÖ€t YÌ…FKȈr=Ëa/¾Žn!º‘cµ”e ÿ- Ú NLÐ*VoÆ5^c½@ga³Jol *`€R–jˆeŒu‘dƒ€™iy‹¢ro•ªef*²c«»tRµÃiIÀÌo ?ËÔn ÿ-")" but 5-6 times more , removed it.
    4-> Did 1 or 2 more things which I don't remember now .

    Comment


      #3
      Thanks for taking your time to suggest a fix.
      The map doesn't crash at all, it crashes the server (only dedicated ones though).
      1. => Since it even happened on a fresh installation with really only the files that the map uses, I think I can exclude that.
      2. => Same goes for this one.
      3. => "Clean" and new *.ini didsn't seem to work either, sadly, other than that my ut2004.ini seems to be all fine.
      Select all actors present in the map and copy paste it in new map.
      Did that a few times, no effect. Seems like I'll have to do what I was afraid of: Backup the file and remove all movers.

      Comment


        #4
        Solved.
        Apparently a mover was too complex in that map, I didn't have to remove it but set its lighting to static and remove some attached emitters, works just fine now. Was quite some work to get it to look like before though.

        Comment


          #5
          That is nice, BTW what kind of map is it , I am curious .

          Comment


            #6
            Originally posted by Sly. View Post
            Solved.
            Apparently a mover [...]
            I'm so glad you didn't just put there "Solved." and abbandoned the thread, so annoying when you're looking for a fix on google yourself.

            Comment


              #7
              Originally posted by chronox View Post
              That is nice, BTW what kind of map is it , I am curious .
              Right now it is a private project, a lobby for servers, gametype: Assault.
              When a server crashes or is under maintenance, this map can be run so players can keep themselves busy until the issue is fixed, however, it can also be used to satisfy the singleplayer and trial players in the community as it allows for exploration (believe me, it is **** huge), contains features and elements that are rarely seen in maps and offers a few "quests", mostly escaping and trying to hide, you can sum it up as a seek and hide game, prisoners and guards in more than one setting which are right now separated but they will be connected later to create a smooth transition between those locations and create the feeling of a huge world. Surprisingly, players seem to like the concept of the prisoner-guard game and the prisoner-players actually try to escape and guard-players actually try to prevent them from doing so - at least that was the case with my testers! They got the concept quite fast.

              It was started exclusively for the server of a friend. I have to note that I actually intended it to stay within that server, but depending on the opinion of the server owner and admins on publicity of the map, I might also release it for others to use.

              When I played on it, I saw the servercrash map, it was basically a cube and it was boring when the issue took a while to fix (like 20 minutes or more), seeing how cool the download-map in Unreal was when you were waiting to (re)connect to a server when downloading files, I got the idea to create something similar. It was a cell in a prison ship similar to the Vortex Rikers.
              Some of you might recall my complaint about mirrors not working in UT2004, it was an experiment, a first attempt on this map. Bummer I cannot include mirrors as they don't reflect players in first person view, but that seems to be impossible, so whatever... I recycled that cell and made it a proper map.
              Originally posted by Infernus. View Post
              I'm so glad you didn't just put there "Solved." and abbandoned the thread, so annoying when you're looking for a fix on google yourself.
              Well, that's how it should be... I guess?

              Oddly, I have heard of server-issues with emitters that were made with the particle editor, but I never ever used it, I always make mine through the properties window.

              And just a warning to other mappers, if a dedicated server gets a garbage collection error when starting the map (resetting it when match starts!), check attached emitters, especially if they are used to cast dynamic light!

              Comment

              Working...
              X