Announcement

Collapse
No announcement yet.

Saving files as .tga in the GIMP.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Saving files as .tga in the GIMP.

    When I try to save a texture as a .tga file in the GIMP, it saves fine until I import it into UnrealEd. The texture will have this "glitchy" colored line either across the top or bottom of the image, depending upon what I set the image's origin to, a setting that's mandatory and that I can't seem to get past without it giving me trouble. The strange thing is that this "glitchy" line doesn't show up in GIMP, so I'm assuming I'm doing something wrong that's causing UEd to import the file incorrectly. I already tried saving the file as a .pcx file with it having a white background. I also do not know how to make GIMP save a .bmp as indexed 8-bit, as, when I try that, not only does the image lose quality, but UEd will also not import the image at all. Does anyone have any ideas?

    P.S. The image I'm editing is one of the textures shipped with the game. I'm simply trying to modify it so as to replace the bad purple corona(EFlareP from EmitterTextures) that, when you put it in as a corona, there's this purple box surrounding the corona itself that would make no sense whatsoever.

    #2
    I use now only DDS format.
    If it's a texture for a corona, there is a alfa (most of the time).
    Did you touch the alfa (transparent) ?
    When you imported it into unrealEd, did you stick the alfa (and the masked) ?

    Comment


      #3
      I just tried marking those two options on the .tga file and, in the Texture Browser, everything looked fine...until I actually used it in game. That glitchy line appeared and, even after compressing the file to DXT5, it still had trouble. I saved another file that was .dds, and it has the same line across the bottom of the texture. Is this some problem with the GIMP or something?

      Comment


        #4
        humm ! dunno for me.
        Do a link with your texture. Just see if we have the same problem.

        Comment


          #5
          I'm not sure if ModDB will allow me to upload .tga or .dds files. I believe they only take the common types, like .jpg, .pcx, etc. Also, since this texture is actually a modification of one of the textures shipped with the game, I'm not sure if it will accept that, either.

          If worse comes to worst, I may just have to put in regular lights for the purple areas of my next map,(A CTF map, in case you're curious) because I do not like the purple flare texture that came with the game.

          Comment


            #6
            Try DXTBmp Texture Tool (http://www.mwgfx.co.uk/programs/dxtbmp.htm) to export your texture(s) into DXT/TGA/BMP, plus it has the alpha editing/import tool you might get afford.

            Comment


              #7
              Problem solved. Had to save the file as a .bmp to get it to display correctly. Thanks for the help!

              Comment

              Working...
              X