Announcement

Collapse
No announcement yet.

Need Help with Mesh/Texture import

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Need Help with Mesh/Texture import

    Hey everyone!

    Okay, here's the scoop. I'm building my very first game character and I got everything set and in place to try out my "first draft" of my character. I just wanted to see what it would look like in-game.

    I modeled and textured everything in Maya.... and it all looks so loverly. I exported using actorX and then imported the mesh package into UnrealEd and linked the HumanMaleA.ukx package animations since I used the HumanMaleA "bip01" skeletal structure to build my model around. The animations look sweet... I linked them after copying an egypt model's mesh properties then copying them onto mine.

    My problem occurs after (or even before that) I put the textures onto the model. I have a butt-ugly looking mesh problem on the face of my character. It looks like a bunch of "noise" that totally distorts the mesh around the head. It's absolutely puzzling to me.

    This is what it looks like in UnrealED:


    And this is what it should look like (snapshot from Maya)


    I can only surmise two problems and I was wondering if someone would be able to point me into a correct path in solving this problem. Could it be my UV sets are screwy, perhaps my UV-linking caused a problem. Or perhaps it's because of my material settings? I swore I named SKIN00 for the body and then SKIN01 for the face. Something's quirky cause the body part of the mesh has no distortion whatsoever. I'm leaning towards the problem being a material setting or something. Does anyone have any idea what the heck it could be?

    I'm in a bind and would really appreciate any assistance. Sorry for the extreme babbling but I was never any good at being terse in my explanation... especially in regards to my problems.

    Thanks my fellow UT freaks!

    -Merlyn

    #2
    Ooh... one more thing

    Ooh... one more thing...

    Thought thje log file from actorX might be helpful to those fellow techie-geeks who might be able to help solve my problem. Here's the info:

    ----------------------------------------------------------------
    Unreal skeletal exporter - Model information for [merlynMystic.psk]

    Skin faces: 1677
    Skin vertices: 4746
    Skin wedges (vertices with unique U,V): 8448
    Total bone-to-vertex linkups: 5402
    Reference bones: 26
    Unique materials: 2

    = materials =
    * Index: [ 0] name: SKIN01
    Original bitmap: merlyn_face1.jpg Path: C:\Merlyn\images
    - Skin Index: 1
    - render mode flags:
    * Index: [ 1] name: SKIN02
    Original bitmap: merlyn_Body1.jpg Path: C:\Merlyn\images
    - Skin Index: 2
    - render mode flags:


    BONE LIST [26] total bones in reference skeleton.
    number name (parent)
    [ 0 ] [Bip01 ] ( 0 )
    [ 1 ] [Bip01 Pelvis ] ( 0 )
    [ 2 ] [Bip01 Spine ] ( 1 )
    [ 3 ] [Bip01 R Thigh ] ( 2 )
    [ 4 ] [Bip01 R Calf ] ( 3 )
    [ 5 ] [Bip01 R Foot ] ( 4 )
    [ 6 ] [Bip01 R Toe0 ] ( 5 )
    [ 7 ] [Bip01 L Thigh ] ( 2 )
    [ 8 ] [Bip01 L Calf ] ( 7 )
    [ 9 ] [Bip01 L Foot ] ( 8 )
    [ 10 ] [Bip01 L Toe0 ] ( 9 )
    [ 11 ] [Bip01 Spine1 ] ( 2 )
    [ 12 ] [Bip01 Spine2 ] ( 11 )
    [ 13 ] [Bip01 Neck ] ( 12 )
    [ 14 ] [Bip01 L Clavicle ] ( 13 )
    [ 15 ] [Bip01 L UpperArm ] ( 14 )
    [ 16 ] [Bip01 L Forearm ] ( 15 )
    [ 17 ] [Bip01 L Hand ] ( 16 )
    [ 18 ] [Bip01 L Finger0 ] ( 17 )
    [ 19 ] [Bip01 R Clavicle ] ( 13 )
    [ 20 ] [Bip01 R UpperArm ] ( 19 )
    [ 21 ] [Bip01 R Forearm ] ( 20 )
    [ 22 ] [Bip01 R Hand ] ( 21 )
    [ 23 ] [Bone weapon ] ( 22 )
    [ 24 ] [Bip01 R Finger0 ] ( 22 )
    [ 25 ] [Bip01 Head ] ( 13 )

    ----------------------------------------------------------------

    Hopefully that'd help in the diagnosis... The fact that it listed the materials as SKIN01 and SKIN02 instead of SKIN00 and SKIN01 are a bit puzzling to me.

    Thanks again,

    -Merlyn

    Comment


      #3
      Looks like I'm the only one replying to my own posts... isn't that patehtic? :P

      Well, after fiddling around for a bit, I discovered that when I changed the UVsets around I get the problem reversed. Instead of the Face UVset being distorted the body UVset will be distorted. So I'm pretty sure the problem lies in UVSets, UVLinking, Relationship editor. Perhaps someone knows a little bit more about ActorX and the UVset exporting or whatever? I've read in a couple places where they talk about Multiple UVSets not being able to export from Maya using ActorX.... that's just bullcrap. At least, I hope so...

      Thanks for any help...

      -Merlyn

      Comment


        #4
        Remember its still the weekend in many parts of the world, you'll probably get a better response when people get home from work on Monday.

        I've heard its a big no-no to use the default Lambert1 material to assign a texture to your model...did you select the body, assign a new material and then point it to your body texture, and then select the head faces, assign new material, then point that to the face texture file?

        Did the shape of the mesh import correctly?

        I think you need to make sure the tesxtures are fully imported and saved (and then loaded) in UEd before importing the mesh itself.

        Still learning myself though, so I'm just thinking aloud :P

        Comment


          #5
          Thanks for the response, Rick.

          I know it's the weekend... I was just panicking like a little kid.

          I did, however, find a solution on my own.

          I'm new at this, so I may be wrong, but here's how I solved my problem. I noticed the problem was varying whenever I messed with the UVSets in Maya before exporting with ActorX. After reading a couple posts on other message boards, I had the inkling of a thought that perhaps ActorX only allows one UVSet to be exported. That seemed to be true... because I took the face UVSet and then copied those over into the Body UVSet so they just overlayed on top of eachother in the same square. I then made sure I had that UVSet selected before I exported. It worked. I didn't get the weird "noisy" mesh patter on the face or body, and the textures placed perfectly.

          So, in short, if anyone encounters the same problem as me, use 1 UVSet, placing the orignal seperate UVSets into the same one. Make sure it's selected before exporting with ActorX and it should work.

          I didn't find much reference to this problem. I wonder if anyone else has experienced this before. Or am I the only one making a custom model with Maya for use in Unreal Tournament 2003? :P Anyhow, I'm happy the texture works.... now to fix all the OTHER problems I have. Hehehe.

          Comment

          Working...
          X