Announcement

Collapse
No announcement yet.

paths behaving badly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    paths behaving badly

    My assault paths keep defaulting to position 0 after I move on to adjust something else, even though they were set to 0.1 etc, with the same path names and objectives as other paths. Anyone know why?



    Also, I'm still having that problem with teleporters, if anyone can stil remember. I tried putting them beside each other about 4m apart, and they worked perfectly. I then moved them to where I wanted them, they still worked, but when I rebuilt the map, they stopped working properly.
    Anyone got some ideas?


    thanks

    #2
    Can't help you with the pathing mate, I haven't made an assault map.

    As for your teleporters, did you do a Build All? If not, that's your first thing.

    After that, check Map for Errors and Check Paths should give you a pretty good insight ie: if one of them became renamed somehow.

    Failing that, you could always moved them to within 4m of each other again and see if they still work.

    Check your Event=>Tag and everything that's supposed to make them work.

    And good luck.

    Comment


      #3
      It's a CTF map, assault paths tell them which way to enter the base, but they need to be in order, and mine won't go in order.
      But I could really do with knowing what's going on.

      The teleporters were first in a while ago, and I've done loads of build alls since then. I was planning to re-add them just after the lastbuild all, since that's where it went wrong, but then they won't be connected to the paths, so I was thinking of sticking a regular pathnode on top of it and forcing a path to another pathnode on top of the other end of the teleportation.
      Sound good? Not sure myself...

      Comment


        #4
        the position is probably resetting itself because its not a whole number.

        position should be like 0, 1, 2, 3

        priority goes like this. all assault paths of any given position, their priority should add up to 1. if you have 10 assault paths at position 0 and you want them to all be used equally, youd set their proitity to .1. if you had two... .5 and so on.

        Comment


          #5
          willhaven, you're my saviour

          that's what I've done.

          thanks


          Teleporters issue still stands. Is it a known bug or anything?

          Comment


            #6
            try a forced path between the teleporters. force teleporterAs path to teleporterB, and B to A (under the navigation>forcedpath, put the OBJECT NAME)

            when you rebuild them, you should see a yellow line directly connecting them through the world.

            Comment

            Working...
            X