Announcement

Collapse
No announcement yet.

No sound in UnrealEd 3.0 - audio playback (almost) nonexistent

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    No sound in UnrealEd 3.0 - audio playback (almost) nonexistent

    I hear nothing when trying to preview audio in the Sound Browser and the Music Browser. Everything else about the program works really well so I don't know what the problem could be??

    To clarify, I have heard minimum sound playback — totally at random, a sound effect I tried to play five minutes earlier will trigger, usually when I alt-tab to another open window or program. I have not been able to find any help, documentation or troubleshooting for this problem online. I have a SoundBlaster X-Fi and have absolutely zero problems with sound in-game — I also have professional audio production software like Cubase and Reason, but I usually run these through an external Digidesign interface.

    I think the problem lies somewhere in the UnrealEd program settings. I was hoping to find a Program Preferences menu where I can see/configure the audio being passed back and forth between UnrealEd and the sound card(s) of my choice, but apparently there's no such thing... unless I haven't looked in the right place. One more thing; I did download a SoundBlaster patch from GameStop that was supposed to help smooth sound streaming when playing online... I wonder if this is the culprit?? Any help would be tremendously appreciated!!

    EDIT: I was streaming Internet radio through Firefox and thought this could be interfering with my sound resources. I stopped that and now I've got the sample playback in UnrealEd down to playing immediately after I double-click a sound and then switch to another tool, or minimize/maximize the program window. At least I can hear things now!! But it still seems there's a problem somewhere that I need to fix. I thought I could audition sounds directly in the browser windows; if I have to alt-tab or switch to another tool every time I want to hear something, that will become a major PITA really quick...

    #2
    Welcome to the UT2004 community

    Well, GreatEmerald has the same problem. Maybe you should ask him (I don't know if he solved the problem already) Iirc he has Win7 so that might be the cause. Do you have Win7 as well? This can be an useful information

    The music browser is useless since UE2 doesn't use umx files anymore but ogg-vorbis files instead. If you try to load a file it will crash the editor (at least that's what will happen to me when I do that -when I started with mapping in 2k4 I was used to listen to the music in the music browser ). The music browser can only play *.umx. They just didn't remove it. In the earlier versions of the engine and its editor it was useful because you could listen to the files in the editor without having a program like Mod Plug Tracker.

    Comment


      #3
      Thanks for the reply and the welcome, Sly! I will check the forum more thoroughly to see about GreenEmerald's problem. I did notice what you point out about the .umx and .ogg files, though fortunately I didn't try to open them through the browser yet — if the program had crashed I would've become worried. My system is Windows XP/SP3 and I can listen to ogg files in WMP through a patch I installed for it a while back. Right now I'm checking the INI file and every website I can find to help guide me toward the solution... Thanks again!

      Comment


        #4
        No problem.
        But that makes me really wonder why do you have that problem.
        I've WinXP with SP3 as well and I don't have any problems (but my PC is a bit old -games like MW2 won't work. But tbh I don't like CoD anymore and won't buy it since they went "pseudo Sci Fi" with CoD4. 1 and 2 were great games). I guess it would be good to post your PC components here. Did you try reinstalling the sound driver or did you change them? When did this problem appear the first time?

        Comment


          #5
          I've only been playing UT2K4 for a couple of weeks now, and I've been using UnrealEd for even less time — I'm a total n00b!! hehe... I inherited both the game and the PC I'm running it on from my brother—it's a Dell Dimension 4700 but it's had the Audigy card and a gaming video card of some sort added, though it's definitely an older and clunkier machine than the hot rods of today. As I said, I've only been using UnrealEd for a few days, so I just became aware of this "problem" today when I decided to start playing with adding sounds to my maps. I highly doubt it's an actual problem with my machine or the drivers, as everything else works flawlessly (and tbh I really rather not start reinstalling drivers unless absolutely necessary).

          What I have found out so far is a section on the Epic UDN site that talks about the Audio System—the Audio Device seems most relevant, especially where it says:
          Init - Initialises the hardware, allocates channels and does any other work required to hear audio.
          Seems like that might point me to the solution but I don't know how to run commands on the editor yet. I was hoping for something easier than having to crack that nut at this point but oh well...

          Comment


            #6
            Hmm, I have a SoundBlaster X-Fi as well, that might be the problem... I'll try switching to Realtek and see if the problem goes away.
            The article there is about Unreal Engine 3, UT2004 is Unreal Engine 2.

            Comment


              #7
              Thank you; I looked through some of your posts as Sly suggested but I didn't find possible solutions to my problem yet. I did just realize that UnrealEd 3.0 refers to the Unreal Engine 2. To make things more confusing, whenever I try to Google about my problem I get a lot of hits about UT3... sigh

              I'm down to the point where I can actually hear the sound clips in the editor's Sound Browser—I just have to select another tool in the editor or alt-tab to another open window before the sound will be played back. Annoying but at least it kinda works...

              EDIT: That did the trick; I switched from the Audigy card to the onboard sound card and now I can hear clips in the sound browser right off the bat. I wonder, does that mean I can't use the Soundblaster when using UnrealEd? That seems odd; by the time this game/engine came out, gaming sound cards were already prevalent... I haven't figured out how to tell the engine to pass all audio through the Soundblaster card, or if that's even possible...

              Comment

              Working...
              X