Announcement

Collapse
No announcement yet.

Animating custom weapons

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Animating custom weapons

    I've made a mesh and a animation to it. Both can succesfully be imported to UEd and the the weapon move correctly in the Animation Browser. But in the game, the weapon is totaly frozen. It doesn't have any animations at all there. I can shoot and switch weapon but the weapon do not move at all. Then back in the UEd the animation is still there. Why?

    PS. I have add the animation to the Default Anim to the mesh.

    #2
    Are you subclassing any particular weapon? For ease, make sure your animation sequence names match those that the code uses. And check your log incase there are any messages like "idle anim not found" or something else along those lines.

    Comment


      #3
      1) I copied the shock rifle but didn't change any code and keeped Weapon as parent.
      2) There is no "idle anim not found" or anythink likely.

      Comment


        #4
        If your using the ShockRifle code then make sure your animation names match those that the ShockRifle uses. I.e

        Pickup
        Idle
        Fire
        AltFire
        PutDown

        And double check that you correctly linked the animation file to the mesh file in the animation browser.

        Comment


          #5
          I have double checked the anim name, default anim (and it is saved) and the anim names in the code too. Still the animation is freezed in game, but works correctly in editor.

          Comment

          Working...
          X