Announcement

Collapse
No announcement yet.

PowerNode events?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    PowerNode events?

    Is there some way to make a PowerNode set off one event when captured by the blue team and a different one for the red team? There's a property that says BlueActivationEventName (and RedActivationEventName), but when I mess with it and scripted triggers it doesn't do anything. Any ideas?

    #2
    Those events do work in the usual way, but not with powercores.

    I've used them so I know they work, for example:

    • Select a powernode and give it a name in RedActivationEventName
    • Then either:
      • Set up a mover with it's tag set the same as above.
      • Set up a scripted trigger, use 'wait for event' and put the RedActivationEventName in the external event field. Then add whatever you want it to do.
    • Play the map, make sure you are on red and then go build the node.

    This works for me so it should work for you. It also works online.

    Comment


      #3
      Well, it doesn't work for me. I've tried it, and it doesn't do anything. I know the event itself works, because when I test it with the "causeevent" command in the game it's fine. It just doesn't actually work when I build the node.

      Comment


        #4
        Originally posted by Herr General View Post
        Well, it doesn't work for me. I've tried it, and it doesn't do anything. I know the event itself works, because when I test it with the "causeevent" command in the game it's fine. It just doesn't actually work when I build the node.
        Hmm, that's odd, I know it may sound silly but have you made sure that you have not made any silly mistakes (typo's in event names etc...), got all the patches installed and so on?

        This really should work, if you're sure you have not made any mistakes maybe you could try a fresh install (in a different directory so you can keep your old install) and see if that works, because I guess it could be a corrupt file causing the problem. The only problem I ever encountered with it was when I tried to use the events with powercores and found that it will not work like that.

        Could it be custom content causing a problem?

        I'm sorry I can't be of more help, but this seems to be a little used feature and it worked first time for me so I'm clutching at straws here.

        I guess if you want to see this in action you could go to the Titan 32p Onslaught server (when it's empty) and vote for ONS-SnowyCaldera.... then in that map build any primary node, when one builds some doors open and the other a shield activates. This uses the node built events (exactly how I described) and no one ever reported that it failed to work (sorry I don't currently have a download link for the map). Also, if this fails to work for you then I guess that helps narrow down the problem to your UT2004 installation.

        Comment

        Working...
        X