No announcement yet.

disappearing movers

  • Filter
  • Time
  • Show
Clear All
new posts

    disappearing movers

    i searched (some^^) and came up empty handed. hoping someone can either help me or clarify what is going on.

    i have 200 movers that, when i made them, were 'hidden' in negative space and come out of hiding when triggered. built the map; works great. started working on different parts of the map. somewhere along the line, the movers stopped showing up in UnrealEd. but they still come out of hiding when playing the game even after saving the map without being able to find them.

    couple questions :

    does putting movers/meshes in negative space cause UnrealEd to lose them?

    is there a way i can select them through the console? i have even tags and such. i did try to Select -> All Movers and then set Mover -> KeyNum to 1 globally to see if i could find them like that but they did not show up.

    any help would be greatly appreciated ^^

    Have you tried the search button?
    Have you tried the "show all" button (I think it is the one with the eye and the x).


      Originally posted by psy°mnïus View Post
      i searched (some^^) and came up empty handed.
      Originally posted by Gugi View Post
      Have you tried the search button?
      are you trying to flame?

      as far as 'show all', yes, i tried that - thanks for the suggestion.

      the issue is getting stranger :

      note there are 3,888 movers selected. up until i selected the movers all together everything seemed fine (i even saved the map with everything selected the way i wanted just in case). the 3D and top viewports were my current working perspectives so they /did/ have the movers in view (and selected), then as i was moving around in the 3D viewport, they just all disappeared. i did a build all and the movers do cast shadows so they are apparently still there, i just cannot see them. restarted unrealed and they are also still selected when i open the map.

      i need to reboot my machine and playtest the map to see if that makes any difference at all - hoping it does..

      again, any help is much appreciated


        and this is the critical error report i get when i try to load the last known build all map (Auto2) :
        ================================================== =====
        UT2004 Build UT2004_Build_[2005-11-23_16.22]

        OS: Windows XP 5.1 (Build: 2600)
        CPU: GenuineIntel PentiumPro-class processor @ 1831 MHz with 2047MB RAM
        Video: NVIDIA GeForce Go 7600 (8628)

        Mover Auto2.Mover2860 (Function Engine.Mover.PostBeginPlay:004F) Runaway loop detected (over 10000000 iterations)

        History: FFrame::Serialize <- UObject::ProcessEvent <- (Mover Auto2.Mover2860, Function Engine.Mover.PostBeginPlay) <- BeginPlay <- UGameEngine::LoadMap <- LocalMapURL <- UGameEngine::Browse <- ClientTravel <- UGameEngine::Tick <- Level Untitled <- UpdateWorld <- MainLoop <- FMallocWindows::Free <- FMallocWindows::Realloc <- 10910191 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free
        ================================================== =====

        so, from this i'm guessing the problem is (lack of) environment space somewhere? maybe i just have too many movers with the same Events->Tag?...




            I've seen this too, I chalked it up to just too many movers. Did you try going to mover 2860 and just deleting it? Actually a nice error message for a change - runaway loop would indicate trying to do something impossible like have 0 sec for loop time AND stay open time, etc.

            Also there is a hotkey in the edito to make movers disappear - I don't remember what it is. One map with a lot of movers worked fine if I built all, THEN rebuilt everything one step at a time EXCEPT pathing and then saved - this was a problem for attached movers only for me.

            So just out of curiosity, what was framerate like with 3800 movers?? Can you play it multiplayer or only single player?


              lol, well, i had only one chunk that i playtested (1/6th the size, so 648) and unfortunately i didn't even look @ framerate for some reason, just went and tried doing it.. that'll learn me, eh?

              it is meant to be multiplayer - this one is a trial map and still pretty undeveloped but i've been playing it nightly with between 2 and 6 people at a time (most people stay for quite a while, surprisingly enough ^^) - my servers will be back online tomorrow i'll post the ip's when i know what the new one's are and they are up and running (colo-swap..), if you care to check it out.

              so.. i've since reverted to a slightly older version of the map and have developed it much further now - if i could figure out whats up with the /other/ 200 movers that have also disappeared from the map i might consider finishing this one part but i'm just not sure the engine can take it

              ok, question : you say just go to it and delete it - is there a console command to select it? i've been able to pull up the properties of one and edit it but as far as selecting and removing, haven't been able to figure that one out without being able to /see/ it in a viewport somewhere - i'm guessing it is something stupid simple and i'm going to look like a fool again ^^

              tyvm for the response. i still have a copy of the botched attempt map just so i can know what was wrong..


                Originally posted by psy°mnïus View Post
                are you trying to flame?
                Originally posted by psy°mnïus View Post
                ok, question : you say just go to it and delete it - is there a console command to select it? i've been able to pull up the properties of one and edit it but as far as selecting and removing, haven't been able to figure that one out without being able to /see/ it in a viewport somewhere - i'm guessing it is something stupid simple and i'm going to look like a fool again ^^
                Sorry, I meant with "search button" the search button in UEd^^ It lists all objects in the map and selects one if you double click an entry (and the 3d-viewport-camera is transferred to the object).

                The iteration-crash occured because you have too many movers in the map. You can't place more movers if you get it. No workaround for it.

                And I guess the movers disapear because the engine can't handle so many of them.
                To lower the number of movers, try to find groups of movers which you can "group" together. With group I mean creating a new staticmesh from the selected ones and add this one as a mover.


                  Thanks Gugi


                    ahh, tyvm, Gugi ^^ soon as i can get in there and look around i will try that

                    another question, if you don't mind ^^ : i actually set a group name for the initial 200 movers that disappeared - is there a way for me to select them based off this value?


                      hmm good question does the name show up in search? If not I've never been able to figure out how to select more than one cotton picking thing at a time using search.

                      One other last ditch effort worth trying, did you try the box select in say top view and then unselect all the stuff you don't want like bsp and plaine static meshes and lights and see if you have a lot of actors left that you are holding but don't see?


                        ok..... i may help u out....
                        did you save all the custommesh in the documents somewhere....
                        if you did you will have to make the copy of the file and put it in the
                        games directory ..where all of the staticmeshes and all that

                        i had this proplem and when the game starts it uses the meshes i put in the documents folder and other folders further from that....but the editor runs from the oringinal folder
                        ...kk i may write another txt when i have less drink in me lol

                        so the editor may not even loaded up the file where your custom meshes
                        if this is the case.....
                        make a copy of the file where your meshes are kept and put in C:\programfiles\unrealtournament3\published\cooked pc\enviroments
                        this would also exsplain why you see it when you play the may but cant find when in the editor

                        further note.....
                        if you add to the package theres no need to add to the both files.....
                        when you save the package it saves them both and when to upload the file ..just use the normal file