Announcement

Collapse
No announcement yet.

Need help with MODEL IMPORT:

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Need help with MODEL IMPORT:

    I've been working on a model entry for PHASE3 of the unreal contest. I've got it about ready for import, but have run into a snag:

    The model was made using the UT23K_Character.zip files. It is a humanoid model, and as such I didn't feel the need to make custom skeletons/animations for him. I felt the standard UT23k MALE animations would do the job.

    As such, I used the Male model (the egyptians/mercs foundation, NOT the JUGG model) files and anims. I pulled the skeleton from the .zip file, and used it as the base for the model I built.

    I made only ONE alteration: When I first tried to export the model, the area between the NECK and HEAD didn't work properly. I had to add an extra neck bone otherwise bits of the torso and chest would be pulled up over the neck. This was the only change made to the Male skeleton.

    I imported the model to UED without a hitch, and using the MaleC model properties, I pasted the information into my new model. All the anims looked fine in UED. So far, so good.

    But in game, for some reason, the animations aren't blending between the UPPER body and the LOWER body. As such, there is massive dirt skating when the model tries to move and shoot.

    In fact, ANY motions that have the upper body moving/twisting/shooting etc. seem to force the lower body to go into a default standing IDLE pose. Which looks silly when the model is supposed to be running or walking or crouching. Very unprofessional looking.

    I thought maybe the effect SOCKETS might be doing this, but after tweaking the SPINE and PELVIS sockets, I got no changes in my model. It still has the lower body frozen while the upper body is moving.

    I've checked the bones and such in UED, both for my new model, and the MALE UT23k model. The bones on the lower body are a perfect match - starting with the center bone "bip01", then going to Bip01 Pelvis, Bip01 Spine, Bip01 Spine2, (etc) and Rthigh, Lthigh, Rcalf, Lcalf, (etc). In fact, ALL the bones in UED seem to match for both models - the only difference is the extra neck bone on my new model.

    Everything else seems to be working fine - even the ragdoll. I just can't get the lower body to do the appropriate animations for running/walking/crouching while he's doing any shooting.

    Should I try renaming bones in 3DMAX and then re-importing to UED? Anything to get his motions working properly would be much appreciated. The deadline is Feb 15, so I have a month - but once I get on a roll I like to keep going, so the sooner the better - plus the sooner I get this fixed, the sooner I can unleash him for your downloading joy....

    Thanks in advance,
    Slyrr

    #2
    Which actual character did you rig your model to? Remus, Torch, or the Skeleton? Remus gives the effect you're currently getting, but the Torch model works fine, so you could try re-rigging to him instead if you've used Remus. Alternatively, I remember Chipv2 mentioning something about the Framerate setting for the running animations being incorrect, and changing them through the animation browser should fix the problem, but I haven't messed with that myself so can't be more help on that point

    Comment


      #3
      the framerates for the stock UT2K3 models seem OK, i just mentioned that spec in another post as a place to tweak custom anims to prevent skating. i don't think it would help this prob, though, which sounds like a call to a animation blending function may be missing an anim sequence (just a guess).

      any errors logged when the problem occurs?

      Comment


        #4
        It was the MERCMALEA rig - the file in the UT23k_characters.zip. There were no character names for the 3dMAX files, just the basic rig names.

        This rig (supposedly) comprises the egyptian model, the nightmare models, the mercenary models, bascially any MALE model in the MaleA model category in UED.

        Slyrr

        Comment

        Working...
        X