Announcement

Collapse
No announcement yet.

Changing Alpha on imported textures

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Changing Alpha on imported textures

    Since discovering that ticking the alpha box when importing textures has no effect on how my crosshairs look ingame, I now need to know how to basically "retick" the alpha checkbox without having to re-import all the textures

    This is what I currently do when importing



    This is what I want to do without having to reimport the texture



    Any ideas?

    #2
    ticking the alpha box when importing textures has no effect on how my crosshairs look ingame
    if checking the Alpha box doesn't give you transparency, then you need to make sure your file has a proper alpha channel.

    if you meant that the Masked box has no effect, that's because Masked is used for palettized files (256 color-indexed), not alpha-channel files.

    to use an alpha channel without re-importing, you can create a Shader with the texture used in both the Diffuse and Opacity channels.

    but why not re-import?

    Comment


      #3
      You can change the alpha setting on a texture through the rightclick menu. Rightclick texture, properties, surface.

      Comment


        #4
        I feel stupid...
        Forgot what the alpha tickbox was for
        Thought it applied to alpha as in "CustomCrossHairColor=(B=255,G=255,R=255,A=255)"

        Did some experimenting with changing the alpha/masked in the properties and I noticed it helped get rid of this annoying small white outline that occured on the black areas of many of my earlier xhairs(I have masks for each texture saved in the alpha channel)

        Once again, me = stupid :bulb:

        Comment

        Working...
        X