Announcement

Collapse
No announcement yet.

ANOTHER 3DS Max Problem....

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    ANOTHER 3DS Max Problem....

    First off, I'm really starting to HATE these programs. Just on the edge of giving up here.

    I have 3DSMax 9. I can create my models just fine, no problems with the modeling process. I can UV Map the models now (thank you DGUnreal!) BUT, I have another annoying "problem" now. First off the .DDS importer on Nvidia's developer website does NOT work with Max 9. When I try to import the .DDS files I get an Image I/O error. So I have to open the .dds file in photoshop, crop the image, then save it as a .PNG file or other bitmap to get it imported in Max so that I can use it. OK, I can do this just fine. I apply the material with the UV Mapping gizmo, do all my aligning, get everything the way I want it, then I collapse all, select main object & attach, weld all vertices, then export as .ASE.
    The model exports fine EXCEPT that it doesn't export it with the materials on it. When I open the mesh in UnrealEd it is covered in that puke looking default texture. I then have to apply the textures that I used in the Static Mesh viewer in UnrealEd. The good thing is that the UV Mapping is intact when the textures are re-applied and they line up as I had planned them to.
    So....what can I do to make this freakin 3DSMax read the .DDS files, OR, how can I get it to export the models with the stinkin textures on them? I can do it the way I'm doing it since the UV Mapping info stays intact, but it's double the work. Is there any solution for my problem since I can't seem to find a .dds importer for Max version 9?

    #2
    When I open the mesh in UnrealEd it is covered in that puke looking default texture.
    What you are encountering is totally normal.
    The texture itself is not exported with the model.
    The .ase format is a simple ascii text file format that contains object/vertex information and a reference to the texture name, it does not contain the texture itself.

    So be sure to have the correct texture package(s) open in UnrealEd before you import your model. Then UnrealEd will automatically have the textures assigned in the StaticMesh browser.
    Otherwise, you have to go into the StaticMesh browser and re-assign the proper textures to the Materials properties yourself, after you have loaded the packages.

    If you are using custom textures, be sure to import them into the myLevel package before you import your model.


    what can I do to make this freakin 3DSMax read the .DDS files
    Some people have issues with the .dds plugin.

    I simply export the desired textures to my file server, organized by game (UT2004), package (AbaddonArchitecture etc.), and name.
    Then I convert DXT1 files to bmp format and DXT3/5 files to tga format.
    This way they are ready for use with 3DS Max, plus I have standard copies of the textures on my file server so that I can create any required new custom textures that I want with them (now or in the future).

    Comment


      #3
      OK, that's all understandable enough. So now I'm led to believe that what I thought was a problem is actually things functioning normally. That's a relief.

      So..how do you convert the textures? When I export the textures I ONLY get the .dds option, yet when I open the .dds file it is kinda weird. It looks like a huge image (1024 x 2048 to be exact) that contains the texture in different sizes. The way I've been doing it is cropping the largest texture out of the .dds file and creating a new image (.bmp or .png) from that cropping, then making sure the new image size is 1024 x 1024. (Sometimes they're a bit off if my cropping was not right on, like 1022 x 1024) I just do an image size and resize to 1024 x 1024, ignoring the couple of pixels that were lost in the cropping.

      Is that unnecessary work? Is there a better way to convert the .dds to something useable? I use Photoshop 7.0 for my image editing. Should I just convert the .dds without doing the cropping?

      Thanks for all the help on this!

      Comment


        #4
        Originally posted by spectre68 View Post
        So..how do you convert the textures?

        When I export the textures I ONLY get the .dds option, yet when I open the .dds file it is kinda weird. It looks like a huge image (1024 x 2048 to be exact) that contains the texture in different sizes.

        The way I've been doing it is cropping the largest texture out of the .dds file and creating a new image (.bmp or .png) from that cropping
        See my PM to you.

        That is correct. UnrealEd3 only exports DXT textures as .dds.
        Other UnrealEd format textures such as RGBA8 export to other graphics file formats.
        When you look at the .dds in PS you are seeing all of the mipmaps, which is why you get the large image with multiple smaller copies in it, which you do not require for use with Max.

        Cropping will work but there are easier ways.
        See my PM.

        Comment


          #5
          Thank you much!
          PM read, reply sent!

          Comment

          Working...
          X