Announcement

Collapse
No announcement yet.

MP5K for UT2004

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    It doesn't show up. :sour:

    btw, which weapon is replaced? Since the description says: Replace a weapon with... And you can't configure what weapon to choose.

    Comment


      #47
      Originally posted by Daspadger
      It doesn't show up. :sour:

      btw, which weapon is replaced? Since the description says: Replace a weapon with... And you can't configure what weapon to choose.
      Make sure you have placed all the files in their proper locations. .U and .UCL files go into \UT2004\System, .UTX goes in \UT2004\Textures, .USX goes into \UT2004\StaticMeshes, .UKX goes into \UT2004\Animations and .UAX goes into \UT2004\Sounds. The weapon will show up in the mutator list.



      After you add the MP5K to the list, click the Configure Mutators button.



      In this example, the MP5K will replace the Assault Rifle (weapon slot #2) in the game, so long as this mutator is active.

      EDIT: You may have to hold down Alt. Fire for a couple seconds in order for it to reload properly.

      Comment


        #48
        I see the mut but it doesn't show anything in configue, like it doesn't exsit? Don't see the other Silencer stiff either? in game it doesn't replace anything! i tried the umod but all i get is some ****ing U2SkarjjMod by EvilEngine? and worse it says that the computer can't find the UT2004 folder in the C drive?


        PLease Help!

        F*** so many of my favorite Muts are screwing up because of this new patch!

        Comment


          #49
          Originally posted by Mr. uglyPants
          I see the mut but it doesn't show anything in configue, like it doesn't exsit? Don't see the other Silencer stiff either? in game it doesn't replace anything! i tried the umod but all i get is some ****ing U2SkarjjMod by EvilEngine? and worse it says that the computer can't find the UT2004 folder in the C drive?


          PLease Help!

          F*** so many of my favorite Muts are screwing up because of this new patch!
          Try using the UMOD Browser. Just to save you some time I have uploaded it to my site so you can download it directly without having to slog through some pages. Here's the link. The original Web site for the program is here. After the program is installed you can load the .UMOD in the UMOD Browser and install it from there. It also works for previous UT games.

          EDIT: I'll only keep the browser up on my site for a limited time.

          Comment


            #50
            ok i have it and i instlled it but i can't figure iut how to get it to work?

            I have though been able to open the Umod but when i press Install current Umod all it gives me is a blank thing? Do i use this or just highlight the folders and extract them to a folder then copy into UT2004?

            Thanks for your patience Lopar!

            I've always loved playing with that gun but than when Ut2k4 wouldn't load up on me one time every Umod i had was screwed up!


            those guns are crazy for their size!:up: :up: :up: :haha:

            Comment


              #51
              Originally posted by Lopar-XL
              Make sure you have placed all the files in their proper locations. .U and .UCL files go into \UT2004\System, .UTX goes in \UT2004\Textures, .USX goes into \UT2004\StaticMeshes, .UKX goes into \UT2004\Animations and .UAX goes into \UT2004\Sounds. The weapon will show up in the mutator list.



              After you add the MP5K to the list, click the Configure Mutators button.



              In this example, the MP5K will replace the Assault Rifle (weapon slot #2) in the game, so long as this mutator is active.

              EDIT: You may have to hold down Alt. Fire for a couple seconds in order for it to reload properly.
              I'm absolutely sure that i've placed it all in the right places. The mutator shows up in the mutator menu, but not ingame. I'll try again, just to be sure.

              Comment


                #52
                Das i'm having the same problem as you, from what i've found is that the zip file doesn't contain a couple needed files that the Umod has, download Lopar-XL's Umod browser cause from using ut to see all the files, i've found that the zip has missing files!

                Comment


                  #53
                  Thanks Up! Downloading the umod now...

                  Comment


                    #54
                    Just warning you das that when i used it i first ended up with nothing showing at all than when i did it again it gave me that same thing where it shows in the mut list but when you play ingame nothing happens! Worse when i check the server options it said that MP5K wasn't even active? WTF!

                    hope you have better luck than me Das!:up:


                    Can someone tell me WTF is wrong with this mut! Gobi make another release please!:cry: :cry:


                    *edit* I've tried uninstalling UT2k4 and installing it and puting the right patchs and such, then using the Umod Brower and extracting it to Ut2004 folder it still shows up in the mut list but when i config it doesn't appear!


                    I"M RANTING thats ALL!!!

                    Comment


                      #55
                      I'm not sure what else to do. I'm sorry. If anyone is having trouble using the Browser program I mentioned, here's an example operation for you.

                      To use the UMOD Browser...

                      1) Open the program from the Start menu. There's an option to load the browser by right clicking on the .ut4mod file and selecting "Open with UMod Browser" in the little menu that opens but that doesn't work.



                      2) Open the UMOD file in question.



                      3) Click File-->Save-->Extract All to put everything in its proper place.



                      4) Close the Browser.

                      Comment


                        #56
                        D'oh! I forgot something very important! You have to be mindful of where the UMOD Browser installs its files. Open up the options window by clicking File-->Options and then set the extract path to \UT2004, as shown in this picture:



                        Make sure you have the option for "Always extract to folder:" checked. Click the OK button when finished.

                        Oh my goodness, I feel so incredibly, apocalyptically S-T-U-P-I-D for forgetting this deatail! :cry:

                        EDIT: NOW try installing the UMOD and see what happens.

                        Comment


                          #57
                          @Lopar
                          Your way isn't the right way to install an umod correctly with my UMod Browser.
                          Use the "Tools / Install current UMod" feature to install any UMod and don't forget to set up your game paths befor in "File / Options / Games".

                          Comment


                            #58
                            I'm sorry about the problems. But please open your UT2004.ini
                            add EditPackages=SGOMP in the [Editor.EditorEngine] section,
                            open Unrealed an take a look at the Texture- and StaticMesh files if
                            one of it is screwed up, maybe this is the reason.

                            The SGOMP.ucl file should contain this:
                            Mutator=(ClassName=SGOMP.MutSGOMPKArena,GroupName= Arena,IconMaterialName=MutatorArt.nosym,FriendlyNa me=SGOMP.MutSGOMPKArena.FriendlyName,Description=S GOMP.MutSGOMPKArena.Description,FriendlyName=SGOMP .MutSGOMPKArena.FriendlyName,FallbackName="MP5K Arena",FallbackDesc="Replaces all weapons with the MP5K.")
                            Mutator=(ClassName=SGOMP.MutSGOMPKReplace,GroupNam e=Arena,IconMaterialName=MutatorArt.nosym,Friendly Name=SGOMP.MutSGOMPKReplace.FriendlyName,Descripti on=SGOMP.MutSGOMPKReplace.Description,FriendlyName =SGOMP.MutSGOMPKReplace.FriendlyName,FallbackName= "MP5K",FallbackDesc="Replace a weapon by the MP5K.")
                            Mutator=(ClassName=SGOMP.MutSGOMPSArena,GroupName= Arena,IconMaterialName=MutatorArt.nosym,FriendlyNa me=SGOMP.MutSGOMPSArena.FriendlyName,Description=S GOMP.MutSGOMPSArena.Description,FriendlyName=SGOMP .MutSGOMPSArena.FriendlyName,FallbackName="MP5K with Silencer Arena",FallbackDesc="Replaces all weapons with the silenced MP5K.")
                            Mutator=(ClassName=SGOMP.MutSGOMPSReplace,GroupNam e=Arena,IconMaterialName=MutatorArt.nosym,Friendly Name=SGOMP.MutSGOMPSReplace.FriendlyName,Descripti on=SGOMP.MutSGOMPSReplace.Description,FriendlyName =SGOMP.MutSGOMPSReplace.FriendlyName,FallbackName= "MP5K with Silencer",FallbackDesc="Replace a weapon by the silenced MP5K.")
                            Weapon=(ClassName=SGOMP.SGOMPK,PickupClassName=SGO MP.SGOMPKPickup,AttachmentClassName=SGOMP.SGOMPKAt tachment,FriendlyName=SGOMP.SGOMPK.ItemName,Fallba ckName="MP5K",FallbackDesc="MP5K")
                            Weapon=(ClassName=SGOMP.SGOMPS,PickupClassName=SGO MP.SGOMPSPickup,AttachmentClassName=SGOMP.SGOMPSAt tachment,FriendlyName=SGOMP.SGOMPS.ItemName,Fallba ckName="Silenced MP5K",FallbackDesc="Silenced MP5K")

                            The SGOMod.ini file should contain this:
                            [SGOMP.SGOMPK]
                            bUseOldWeaponMesh=False
                            ExchangeFireModes=0
                            Priority=65
                            CustomCrosshair=7
                            CustomCrossHairColor=(B=255,G=255,R=255,A=255)
                            CustomCrossHairScale=1.000000
                            CustomCrossHairTextureName=Crosshairs.Hud.Crosshai r_Cross1

                            [SGOMP.SGOMPS]
                            bUseOldWeaponMesh=False
                            ExchangeFireModes=0
                            Priority=64
                            CustomCrosshair=7
                            CustomCrossHairColor=(B=255,G=255,R=255,A=255)
                            CustomCrossHairScale=1.000000
                            CustomCrossHairTextureName=Crosshairs.HUD.Crosshai r_Cross1

                            [SGOMP.MutSGOMPKReplace]
                            WeaponClassName=XWeapons.BioRifle

                            [SGOMP.MutSGOMPSArena]
                            bUnlimitedAmmo=False
                            bKeepShieldgun=True
                            bKeepLinkgun=False
                            bDualAction=True

                            [SGOMP.MutSGOMPSReplace]
                            WeaponClassName=XWeapons.BioRifle

                            [SGOMP.MutSGOMPKArena]
                            bUnlimitedAmmo=False
                            bKeepShieldgun=True
                            bKeepLinkgun=False
                            bDualAction=False

                            Comment


                              #59
                              @eGo
                              Sorry about that.

                              @Gobi
                              All versions of your weapon that I installed worked just fine when I installed them. Perhaps it's because I deleted the old version first? I wasn't using the UMOD version.

                              Comment


                                #60
                                Hey Gobi since i'm and problably others are crappy and just screw up when editing can you make another release with that editing in it!
                                Please!

                                Comment

                                Working...
                                X