Announcement

Collapse
No announcement yet.

VCTF-RT-TrainCrossing v2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    ah... this happened to me. Most likely you have too many pathnodes, remove some pathnodes and try to leave some space inbetween. I read it somewhere, did this and it worked. i'm downloading your map right now to see what i can do.

    Comment


      The amount of pathnodes doesn't seem to be the cause of the problem. I tried removing different chunks of them and it didn't work. It seems to come from the way it builds the connections. Sometimes it works just fine but then I tweak a few unrealted things and it starts crashing.
      That's frustrating as hell because I have the version of the map without the fog complete but can't save the one with fog to be able to release the whole package :/

      Comment


        yeh,also getting said error here:

        Build UT2004_Build_[2005-11-23_16.22]

        OS: Windows NT 6.1 (Build: 7600)
        CPU: GenuineIntel PentiumPro-class processor @ 3093 MHz with 4095MB RAM
        Video: NVIDIA GeForce GTX 650 (3523)

        General protection fault!

        History: MessagePump <- MainLoop
        dunno if you already tried this, but have you removed all path nodes, then compile, then re-add pathnodes, then recompile?

        edit: well, I removed all of the pathnodes then tried to compile it, and it worked(well, it's kinda expected since there are no pathnodes to build in the first place =/ )

        Comment


          you're actually getting a error?
          for me it just crashes with the window popping up saying editor stopped working
          weird

          Comment


            176 road path nodes and 1219 path nodes. I'd say that's the problem. For one thing, road path nodes are basically the same as regular nodes for foot traffic, except they link up to other nodes at greater distances. So you don't have to have lines of regular nodes next to road nodes.

            I bought a new computer since the last time I checked on this map and I'm sorry to say that it still chugs. I'm getting around 25-30 fps viewing from one corner looking to the other. That's at "max settings" with AA and everything, but still, worse than most maps. A fair chunk of UT2004 players still play on older machines; when poor performing maps come up on servers, they tend to quit or vote for something else.

            As I understand it, the entire idea behind this version is to optimize it enough for public servers. So that means fog. The idea is to set the fog distance short enough so that things in the distance will not be rendered at all. As a test, I set the fog's start distance to -1500.000000 and end distance to 10000. My fps was around 60 from that same corner. Huge improvement. You will need to add a fog ring so that mesh pop-in isn't noticeable, and make the skybox and lighting match the thicker fog.

            Comment


              I've finished up the whole thing months ago, just couldn't save it.
              And I know how pathnodes work, thanks to this article http://www.vgmp3.org/Archives/UT2003...g_Tutorial.htm I even set up some defense points and offense routs.

              Comment


                What I was saying is that you have too many path nodes. That's almost certainly why it's crashing.

                Another big FPS issue on the map are the waterfall emitters. I see that you have them set to turn off on low world detail, but I think you should thin them out quite a bit (fewer sprites total) and put hem on high detail only.

                Comment


                  What I was saying is that I'm done with it and just wanna get it out of the way

                  Comment


                    Just judging from the screenshots, it looks like you are doing UT3-like maps,
                    but yours look more real.

                    Comment


                      FINALLY, got it to save!
                      You can download the RC1 version of the map here (Required files from BP2 ).
                      There are two maps in the archive: standard and foggy.
                      This is the last version before the final release, no more significant changes will be made, only bug fixes.

                      Changelog from beta3:
                      -Flag building is now completely unaccessible by vehicles, added visual signs
                      -Improved bot paths - defense positions, assault paths, jump spots, water paths
                      -Teleporters to the top of lighthouse were moved to the lighthouse itself
                      -Added super adrenaline pickup where teleports were previously
                      -The gates at the ports were removed
                      -Replaced Scorpions with EONS Scorpions
                      -Replaced SPMA with Ion Tank
                      -Added two secrets (not in foggy version). Can you find them?
                      -Added forcefields and improved the positioning of blocking volumes around the map
                      -Improved the sea border of the map - added byuos and it now blends more seaminglesly with the skybox
                      -Textures in the tunnels now fade to black
                      -Added music from UT3 (Mechanism Eight)
                      -Added some ambient sounds
                      -Mine layer now respawns like Redeemer and ammo for it is very hard to find
                      -Fixes in mesh placement and texture alignment
                      -Other bugfixes

                      More information in the first post.

                      Comment


                        nice, downloading this

                        so what was the cause of the issue before?

                        EDIT: When I try to play the maps I get an error:

                        UT2004 Build UT2004_Build_[2005-11-23_16.22]

                        OS: Windows NT 6.1 (Build: 7600)
                        CPU: GenuineIntel PentiumPro-class processor @ 3093 MHz with 4095MB RAM
                        Video: NVIDIA GeForce GTX 650 (3523)

                        Failed to enter C:\UT2004\Maps\VCTF-RT-TrainCrossingRC1-Foggy.ut2: Can't find file for package 'JumpshipTextures'

                        History: UGameEngine::Init <- InitEngine <- FMallocWindows::Free

                        Comment


                          It requires some files from Bonus Pack 2, there's a link to the required files right under the download link
                          http://www.mediafire.com/download/zs...8/BP2Files.zip
                          I find it weird that some people don't have that pack
                          I'll probably import them into mylevel in the final version...
                          so what was the cause of the issue before?
                          It has something to do with pathnodes, I'm still not sure what exactly causes it. I was basically deleting pathnodes here and there and at some point it just worked.

                          Comment


                            I like the new version of the map, the details look great (now only if the thing would run on older computers ). I'm thinking you might have been able to get away with 3 terrain infos at much lower resolution to cover the river bottom, and grassy areas on each side. The tessellation of the river bottom is super high and could probably be 1/3 to 1/4 the resolution and still look great.

                            On a side note, a warning to mappers: don't open this map in UEd, and then save as a "vanilla" version as a CTF map etc. The embedded custom ctf flags (along with the other embedded classes/code) appear to get stuck in the new map. Since the custom flag classes in Train Crossing have the same name as a default ctf flag classes (but with a different parent class) they seem to always get loaded when you open your new map to work, I've not found a way to "delete" the embedded unused classes.

                            UnShame could enlighten us as to how get the NukePainter class out from the map? (pretty please!) I understand the whole "mapper's vision" thing (playing the way the author intended), but I'm not super comfortable with a lot of custom stuff in the maps unless it is included as separate packages (it tends to break compatibility with mutators etc.). Maybe a "vanilla UT2k4" version of the map with the release?

                            Comment


                              I wanted to follow up on this map as I've played it a bit more now. While it may not run on my old machine, it plays fine on my UT3 compatible machine. I gotta say I love the detail you've got in here. The bots seemed to do A-Ok too at trying to grab the flag. I really dig the little touches (detail textures yeah!) like the custom boundary textures, and the jump pad on the middle island that kicks you on to the passing boat, very fun! And although I'm not a huge fan of embedded content, the little hidden easter egg is pretty cool and the custom vehicles do seem more appropriate for the map. I still wish you'd stuck with standard CTF flags though since they are more compatible with flag mutators, but hey these flags work.

                              Also, thank you for the effort in trying to optimize the map! Those custom "culled" static mesh textures for some of the buildings look really good and work well for their purpose.

                              I know you said you were done with this map, but if you are interested, I've made some lower-poly versions of some of the meshes (a few of the lights, the white concrete doorway, a set of black metal handrails to use for the railings, remakes of the tree trunk meshes and stairs), and some lower resolution "specular masks" that can be used to add glass shine to the train and boat textures' windows as part of a shader. If you'd like to consider adding them, let me know.

                              Comment


                                Originally posted by meowcat View Post
                                On a side note, a warning to mappers: don't open this map in UEd, and then save as a "vanilla" version as a CTF map etc. The embedded custom ctf flags (along with the other embedded classes/code) appear to get stuck in the new map. Since the custom flag classes in Train Crossing have the same name as a default ctf flag classes (but with a different parent class) they seem to always get loaded when you open your new map to work, I've not found a way to "delete" the embedded unused classes.
                                Deleting the custom flags (or other embedded custom actors) and then saving and closing unreal ed should completely remove them. Otherwise they are kept in memory as you continue to work (this is what happened on your other map.)

                                Comment

                                Working...
                                X