Announcement

Collapse
No announcement yet.

[SKIN PACK] Unreal 2 Soldiers Part 2: Marines & Liandri Angels

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by LeMoNaDe_ View Post
    If people are interested I'll definitely try re-downloading all the plugins I need .
    Well, count me interested .

    Leave a comment:


  • replied
    Thanks. I'm looking into the Golem Studio right now, trying to write documentation for it, so I'm learning something new about the animation system of Unreal II as well.

    Yeap, Unreal II and UT3 weapons are my projects. It is more difficult in terms of coding, as with models, you just have to port the graphics and set up bones and it works. With weapons, you have to do all that, and then write code so that the weapon behaves like the new weapon. And there are extra graphics, like muzzle flashes, pickup meshes, projectile meshes, particles that have to be ported over as well. But in terms of porting weapon models, it's of the same difficulty as porting player models.

    Leave a comment:


  • replied
    Originally posted by MRSAMPLE View Post
    Wait...What? Is that even possible ? That would be the pinnacle of awesome!! Seeing the Q3 characters dying with UT04 ragdolls is something I allways wanted everytime I went back to it for a quick match...
    Certainly is







    ...but, my laptop unfortunately crashed a few weeks ago, so I'm a bit behind. Some stuff was salvaged, but not all of it. Those shots are of something I just re-complied tonight to show that it works. If people are interested I'll definitely try re-downloading all the plugins I need .

    @GreatEmerald Maybe if you're looking for some help I'll see what I can do. I'm still a 'noob' but I'm picking it up fairly quickly . You've been doing the UT3 weapon conversions right? I'm guessing that's a bit more difficult than doing characters?

    Leave a comment:


  • replied
    Originally posted by LeMoNaDe_ View Post
    Right now I am converting all the Quake 3 characters
    Wait...What? Is that even possible ? That would be the pinnacle of awesome!! Seeing the Q3 characters dying with UT04 ragdolls is something I allways wanted everytime I went back to it for a quick match...

    Leave a comment:


  • replied
    Well, there are two scripts I know of, an older one that requires you to know HEX editing, and a newer one by VendorX that doesn't, but doesn't support animations. I assume you used the former, then. I wonder if that script could do something with the weapons, too, as extracting the animations of the Laser Rifle, Takkra, Singularity Cannon and Mind Claw is something that would help a whole lot with my Unreal II weapons pack. Which, by the way, you could also use for the screenshots for even better immersion!

    Good to hear you enjoy them, too!

    Leave a comment:


  • replied
    Originally posted by GreatEmerald View Post
    Oh man, this is awesome! How did you manage to convert those, anyway?
    So far it seems to be made a lot cleaner than the EvilEngine ones, too, which is again pretty neat. Perhaps both could be merged into one package with all these errors ironed out...
    I'm glad to see people enjoy these . I found a blender plugin on some Unreal fan site (can't remember which one ) and used that to get the object data and UV maps into Maya. Legend's weight paints, which I'm assuming EvilEngine used, weren't very well done so I completely re-did them to work better with UT's animations. As for the naming problem, thanks for the advice! I figured if it worked for me it'd work for everyone, but apparently that's not the case .

    Maybe in the future I can get around to converting the rest and making a complete pack. Right now I am converting all the Quake 3 characters (taking way longer than I thought), but after that I have nothing planned. I might as well finish what I started .

    (btw Great Job with the VCTF-Garden Conversion! That's the map I used for the screenies. That and Alcazar are both awesome )

    Leave a comment:


  • replied
    Oh man, this is awesome! How did you manage to convert those, anyway?
    So far it seems to be made a lot cleaner than the EvilEngine ones, too, which is again pretty neat. Perhaps both could be merged into one package with all these errors ironed out...

    Yea, never have two packages with the same name. There is a very, very good reason why in Unreal II, every package has a letter appended to it - T for textures (UTX), A for audio (UAX), M for meshes (although should be S for Static Meshes (USX) instead, just that Unreal II didn't have animated meshes, they had Golem meshes with the G postfix (UGX)). So keeping with that practise is a good idea - rename U2Marines.ukx to U2MarinesK (UKX), U2Marines.utx to U2MarinesT etc.

    I'll have to try this next time I reinstall the game, that's for sure!

    Leave a comment:


  • replied
    I heard of a similar bug being caused by the same filename for all the different packages, because the game searches for meshes in the tex pack or something like that. Giving the files seperate names like U2Marinestex.utx, U2Marinesmeshes.usx and so forth fixes this problem.

    Leave a comment:


  • replied
    Glad I could help

    Leave a comment:


  • replied
    Originally posted by LeMoNaDe_ View Post
    try renaming the ukx to something new entirely (then making the appropriate upl changes)

    Let me know if you have any success
    It worked!! renamed the U2marine.ukx to U2mariness.ukx, changed the upl accordingly (Mesh=U2Mariness.Light), and the light marines appeared. The funny thing is, I dindn't change the Heavy and Medium marines meshname, they still show with Mesh=U2Marines.Medium and Mesh=U2Marines.Heavy, so if it ain't broke...

    Amazing models, and now that my completist side is happy, even better. Thanks for the conversions and your help!

    Leave a comment:


  • replied
    Weird. Did you try checking the upl?? See where its reading the mesh from.

    It should read:
    "Mesh=U2Marine.Medium" for a Medium Soldier, "Mesh=U2Marine.Light" for a Light Soldier, etc.

    If changing the ukx file to U2Marines works, I would think it reads "Mesh=U2Marines.Medium" instead.
    Since the meshes are working, it could be the upl that's causing your problem... not the ukx.

    EDIT: Hmmm....nvm . Just went back and read your original post. Sounds like your UT is looking in the U2Marine.ukx but finding nothing. What you could try is re-downloading the files and switching/changing the names of the ukx and the utx (i.e. U2Marine.ukx becomes U2Marines.ukx & U2Marines.utx becomes U2Marine.utx). Confusing...I know, but I was having similar problems if the ukx and utx were named the same. Of coarse, after switching the ukx and utx names you need go into the upl and make the appropriate changes .

    ....Or to make things simpler, try renaming the ukx to something new entirely (then making the appropriate upl changes)

    Let me know if you have any success

    Leave a comment:


  • replied
    Yup, I did, they do show in the editor, checked the mesh names and everything seems to be fine, however, same thing happens. The weird thing is, I changed the meshname of the medium and heavy marines to Mesh=U2Marines.Medium and Mesh=U2Marines.Heavy and now those models appear ingame, maybe referencing another ukx? The light ones dont show that way though, the game just refuses to read the u2marine.ukx in my end, I guess.

    Leave a comment:


  • replied
    Hmmmmm....

    I checked the download for myself and the problem doesn't seem to be the link. Anyone else have an issue?

    Only thing I can think of is re-downloading the pack and making sure the files are in the correct folders. If you know how to work UnrealEd you can try loading the U2Marine.ukx into the Animations Editor and see if the Meshes appear there.

    Let me know if you have any luck.

    Leave a comment:


  • replied
    Do the models work for everybody? For some reason the Marine models wont appear in my end, only the portraits. The log keeps saying it didn't find the meshes. The Angels are fine though.

    This is what I got:

    Code:
    Log: Allocating 65536 byte dynamic vertex buffer.
    Warning: Failed to load 'NULL': Can't resolve package name
    Warning: Failed to load 'Mesh None.': Can't resolve package name
    ScriptLog: Could not load mesh:  For player: 
    Warning: Failed to load 'Mesh U2Marine.Light': Failed to find object 'Mesh U2Marine.Light'
    ScriptLog: Could not load mesh: U2Marine.Light For player: U2MarineL-Red
    Error: GUIVertImageList Package.GUIVertImageList (Function XInterface.GUIVertImageList.SetIndex:0014) Accessed array 'Elements' out of bounds (-1/0)
    Warning: Failed to load 'Mesh U2Marine.Light': Failed to find object 'Mesh U2Marine.Light'
    ScriptLog: Could not load mesh: U2Marine.Light For player: U2MarineL-Red
    Warning: Failed to load 'Mesh U2Marine.Light': Failed to find object 'Mesh U2Marine.Light'
    ScriptLog: Could not load mesh: U2Marine.Light For player: U2MarineL-Red
    Warning: Failed to load 'Mesh U2Marine.Medium': Failed to find object 'Mesh U2Marine.Medium'
    ScriptLog: Could not load mesh: U2Marine.Medium For player: U2MarineM-Default
    Warning: Failed to load 'Mesh U2Marine.Medium': Failed to find object 'Mesh U2Marine.Medium'
    ScriptLog: Could not load mesh: U2Marine.Medium For player: U2MarineM-Gold
    Warning: Failed to load 'Mesh U2Marine.Medium': Failed to find object 'Mesh U2Marine.Medium'
    ScriptLog: Could not load mesh: U2Marine.Medium For player: U2MarineM-Green
    Warning: Failed to load 'Mesh U2Marine.Medium': Failed to find object 'Mesh U2Marine.Medium'
    ScriptLog: Could not load mesh: U2Marine.Medium For player: U2MarineM-Red
    Warning: Failed to load 'Mesh U2Marine.Medium': Failed to find object 'Mesh U2Marine.Medium'
    ScriptLog: Could not load mesh: U2Marine.Medium For player: U2MarineM-Blue
    Warning: Failed to load 'Mesh U2Marine.Medium': Failed to find object 'Mesh U2Marine.Medium'
    ScriptLog: Could not load mesh: U2Marine.Medium For player: U2MarineM-Arctic
    Warning: Failed to load 'Mesh U2Marine.Heavy': Failed to find object 'Mesh U2Marine.Heavy'
    ScriptLog: Could not load mesh: U2Marine.Heavy For player: U2MarineH-Default
    Warning: Failed to load 'Mesh U2Marine.Heavy': Failed to find object 'Mesh U2Marine.Heavy'
    ScriptLog: Could not load mesh: U2Marine.Heavy For player: U2MarineH-Default
    Warning: Failed to load 'Mesh U2Marine.Heavy': Failed to find object 'Mesh U2Marine.Heavy'
    ScriptLog: Could not load mesh: U2Marine.Heavy For player: U2MarineH-Blue
    Warning: Failed to load 'Mesh U2Marine.Heavy': Failed to find object 'Mesh U2Marine.Heavy'
    ScriptLog: Could not load mesh: U2Marine.Heavy For player: U2MarineH-Red
    Warning: Failed to load 'Mesh U2Marine.Light': Failed to find object 'Mesh U2Marine.Light'
    ScriptLog: Could not load mesh: U2Marine.Light For player: U2MarineL-Blue
    Warning: Failed to load 'Mesh U2Marine.Light': Failed to find object 'Mesh U2Marine.Light'
    ScriptLog: Could not load mesh: U2Marine.Light For player: U2MarineL-Default
    Warning: Failed to load 'Mesh U2Marine.Heavy': Failed to find object 'Mesh U2Marine.Heavy'
    ScriptLog: Could not load mesh: U2Marine.Heavy For player: U2MarineH-Gold
    Warning: Failed to load 'Mesh U2Marine.Heavy': Failed to find object 'Mesh U2Marine.Heavy'
    ScriptLog: Could not load mesh: U2Marine.Heavy For player: U2MarineH-Green
    Warning: Failed to load 'Mesh U2Marine.Light': Failed to find object 'Mesh U2Marine.Light'
    ScriptLog: Could not load mesh: U2Marine.Light For player: U2MarineL-Red
    Warning: Failed to load 'Mesh U2Marine.Light': Failed to find object 'Mesh U2Marine.Light'
    ScriptLog: Could not load mesh: U2Marine.Light For player: U2MarineL-Green
    Warning: Failed to load 'Mesh U2Marine.Light': Failed to find object 'Mesh U2Marine.Light'
    ScriptLog: Could not load mesh: U2Marine.Light For player: U2MarineL-Gold

    Leave a comment:


  • replied
    thanks for porting these, well done!

    Leave a comment:

Working...
X