Announcement

Collapse
No announcement yet.

Why My hidden weapons always show up?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Why My hidden weapons always show up?

    .
    .
    I always play with weapons hidden...

    What is the weaponhand command in the user.ini if one?

    This line allows me to bind a key to screenshot without the hud in the user.ini:

    [key]=ToggleScreenshotMode|OnRelease shot|OnRelease ToggleScreenshotMode

    - Once key is released, it brings back my **** weapons. I want to have them always hidden.

    What is the correct entry in the 'user.ini' to make the weapons always hidden?
    What is the 'weaponhand' command in the user.ini?

    Thx.

    #2
    The reason that they come back is because using togglescreenshotmode to turn back on the HUD will cause it to bring back the weapon model for some reason.

    Comment


      #3
      Originally posted by SvL
      The reason that they come back is because using togglescreenshotmode to turn back on the HUD will cause it to bring back the weapon model for some reason.
      It returns to default setting, which means the setting is not remembered when turning on the screenshot mode.

      Comment


        #4
        No one know the answer to this? Some leet dood must know

        Comment


          #5
          Originally posted by Sm@ck
          No one know the answer to this? Some leet dood must know
          Get used with the default settings

          Comment


            #6
            make sure the weapon is set to hidden in the player menu, not the HUD options. (if there is)

            Comment


              #7
              I have my weapons set to hidden in the player menu & same thing happens to me.

              My fix for it...........

              I dont use that bind anymore.

              Comment


                #8
                I have the same problem with togglescreenshotmode :bored:

                Comment


                  #9
                  I can provide a work around for this issue "IF" we can find a bind for pressing "esc" to bring up menu, then clicking on "settings" then "esc" "esc". This will do the following:

                  1. Toggle + screenshot bind.

                  2. There is an alternate to some of the toggleshot binds that will do what we need but then the crosshairs are missing. The way to bring back the crosshairs is to press esc ( menu ) press settings then esc back out to the game.

                  3. If I can find a bind to do that with the settings or find a way to bring the crosshairs back on we have this issue resolved ( worked around ).

                  Let me know.......I'm still looking into this. I'll carry on troubleshooting when i get home later.

                  Comment


                    #10
                    You could also do a bind for running a text file, couldn't you? Honestly, it didn't seem worth the trouble to me - I just gave up on using screenshotmode since it's so stupidly bugged. :down:

                    Comment


                      #11
                      Well, there isnt a command for any of it, but Ill look VERY hard tonight in the x[whatever].int files, and see if I can find anything.

                      Comment


                        #12
                        Sorry for double post, but Ive found something. In the xinterface.int files search for: [Tab_PlayerSettings]

                        And you can find a bit called "handnames" , I beleive if someone can look into the commands for Handnames, you might find something. Ive tried the handnames command, and no , it doesnt work. I BET I will find something in user.ini. Nope.

                        Comment


                          #13
                          erm, you're all gonna kick yourself for this.....

                          2 versions of the screenshotmode toggle

                          1st will leave u with gun showing after the shot is taken, 2nd will get rid of it. Simple as....




                          key=ToggleScreenshotMode|OnRelease shot|OnRelease ToggleScreenshotMode

                          key=ToggleScreenshotMode|OnRelease shot|OnRelease ToggleScreenshotMode|OnRelease showgun





                          Problem solved DDDD

                          Comment


                            #14
                            Awesome ......many people have been looking for this fix. GJ .....two thumbs up

                            Comment


                              #15
                              You, good sir, are a golden god. I look forward to testing this tonight.

                              Comment

                              Working...
                              X