Announcement

Collapse
No announcement yet.

Remap ~ or ` (tilda) to not be the console

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Remap ~ or ` (tilda) to not be the console

    How can I change the tilda (~/`) key to not pop up the console?

    I'm using a laptop and the ~/` key is below the "c" key and I hit it by mistake alot. I've tried remaping the ~ & `keys to no function (= blank in the ini file), some other functions, and changed the console key to another key but the tilda (aka `) aways pops up the console?

    Is this hard coded in UT2004?

    Hawkwindeb

    #2
    In ..\UT2004\User.ini there's a line like this:

    Tilde=ConsoleToggle

    Just delete the part ConsoleToggle. Next time you press it nothing happens. Modify it in the file or open the console in game and type this:

    set input Tilde=

    If I remember correctly, it should do the same as manually changing it in the file.

    Comment


      #3
      Originally posted by Abilio_KID
      set input Tilde=

      If I remember correctly, it should do the same as manually changing it in the file.
      that wont work i think, maybe set input tilde will do

      Comment


        #4
        Originally posted by Maegrim
        that wont work i think, maybe set input tilde will do
        Set input should have the same result as editing the ini.

        Comment


          #5
          i know, i was commenting on his second solution, the set input tilde=

          Comment


            #6
            The 3rd thing I did was to remove the ConsoleToggle from the Tilda= and set the ConsoleToggle to another key. This does not work to stop the console from popping up using the tilda key.

            I think it must be hard coded or configured somewhere else. Try this, from the GUI try to map anything to the tilda. You won't be able to because the console will pop up in side the Input config screen. (this was the 2nd thing I tried - 1st was just assigning another key to the console in the GUI)

            So, that's when I edited the ini file. My experience with Unreal goes back to the original and modifing the INI was the only way to do somethings, then UT, now UT2004. (Quake & Quake II config files before that) However, I have never had the need to remap the console not to be the Tilda.

            Keep in mind that maping the console (ConsoleToggle) to another key DOES work but then BOTH the new key and the tilda pop up the console.

            Hawkwindeb

            Comment


              #7
              Slightly off topic, but not a huge amount - Am I the only one who's console key was never the tilde? From a fresh purchase and install it was always the apostrophe key. My apos key has @ and ', my tilde key has ~ and #, and it has always been mapped to the ' key. At first looking for tech support anybody telling me to press ~ to open the console confused the hell out of me.

              Comment


                #8
                That is pretty irritating. But why are you remapping the tilde key anyway? Doesn't seem very useful with WASD keys. I can get my pinky up there without moving off the movement keys, but it's kind of at an akward angle.
                Originally posted by danstringer
                Slightly off topic, but not a huge amount - Am I the only one who's console key was never the tilde? From a fresh purchase and install it was always the apostrophe key. My apos key has @ and ', my tilde key has ~ and #, and it has always been mapped to the ' key. At first looking for tech support anybody telling me to press ~ to open the console confused the hell out of me.
                That's it then! It's mapped to the apostrophe ` key not the tilde. So remap the apostrophe `key and viola. (tilde and apostrophe are on the same key on most keyboards)

                Comment


                  #9
                  Originally posted by hawkwindeb
                  The 3rd thing I did was to remove the ConsoleToggle from the Tilda= and set the ConsoleToggle to another key. This does not work to stop the console from popping up using the tilda key.

                  I think it must be hard coded or configured somewhere else. Try this, from the GUI try to map anything to the tilda. You won't be able to because the console will pop up in side the Input config screen. (this was the 2nd thing I tried - 1st was just assigning another key to the console in the GUI)

                  So, that's when I edited the ini file. My experience with Unreal goes back to the original and modifing the INI was the only way to do somethings, then UT, now UT2004. (Quake & Quake II config files before that) However, I have never had the need to remap the console not to be the Tilda.

                  Keep in mind that maping the console (ConsoleToggle) to another key DOES work but then BOTH the new key and the tilda pop up the console.

                  Hawkwindeb
                  Keep in mind tilde is spelled with an e. Are you trying to use tilda instead of tilde?

                  Comment


                    #10
                    Originally posted by Turbidity
                    Keep in mind tilde is spelled with an e. Are you trying to use tilda instead of tilde?
                    I can't see how using a popular brand of long-grain rice is going to bring the console up.

                    I reckon the function is hardcoded somewhere though.

                    BTW: @/' is UK keyboard ~ is US (I think) on my keyboard they're seperate keys and it's the ' key for console, tilde does nothing.

                    Comment


                      #11
                      Originally posted by Deadsheep
                      That's it then! It's mapped to the apostrophe ` key not the tilde. So remap the apostrophe `key and viola. (tilde and apostrophe are on the same key on most keyboards)
                      I have no problem with the console mapped to the apostrophe, was just curious as to why. Now I know that most keyboards have them on the same key, that solves the mystery! I havn't used another keyboard in aaaagggeeesss so I hadn't realised. UK Keyboard, UK Player.

                      Comment


                        #12
                        Originally posted by danstringer
                        Slightly off topic, but not a huge amount - Am I the only one who's console key was never the tilde? From a fresh purchase and install it was always the apostrophe key. My apos key has @ and ', my tilde key has ~ and #, and it has always been mapped to the ' key. At first looking for tech support anybody telling me to press ~ to open the console confused the hell out of me.
                        1st a question, is the apostrophe key you mentioning starts at the top right and points to the lower left (or vertical pointing down): ' this is the apostrophe) or just the opposite: `? I forgot the name of the accent but in the standard US keyboard layout, the double quote is with the apostrophe key and the Tilde is with the accent ??? key AKA backwards apostrophe key. Remember that all this is really just keyboard scan codes that the software interprets. .... scan codes ..... Arrrg.... (I have a Thrustmaster FLCS stick & TQS throttle that requires configuration/programming using scan codes ... not fun to program) What keyboard & locale are you using?

                        Hawkwindeb

                        Comment


                          #13
                          Originally posted by Deadsheep
                          But why are you remapping the tilde key anyway? Doesn't seem very useful with WASD keys.
                          Originally posted by hawkwindeb
                          I'm using a laptop and the ~/` key is below the "c" key and I hit it by mistake alot.

                          Comment


                            #14
                            Originally posted by hawkwindeb
                            1st a question, is the apostrophe key you mentioning starts at the top right and points to the lower left (or vertical pointing down): ' this is the apostrophe) or just the opposite: `? I forgot the name of the accent but in the standard US keyboard layout, the double quote is with the apostrophe key and the Tilde is with the accent ??? key AKA backwards apostrophe key. Remember that all this is really just keyboard scan codes that the software interprets. .... scan codes ..... Arrrg.... (I have a Thrustmaster FLCS stick & TQS throttle that requires configuration/programming using scan codes ... not fun to program) What keyboard & locale are you using?

                            Hawkwindeb

                            That One.


                            Not that one.

                            UK Keyboard settings.

                            Comment


                              #15
                              To danstringer: I figured that it must be a different locale and/or a different type of keyboard layout. So, I was just checking.

                              Comment

                              Working...
                              X