Announcement

Collapse
No announcement yet.

Swap weapon mutators working wrong

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Swap weapon mutators working wrong

    Hello,
    recently i was trying to switch some weapons from original to custom ones. A have a lot of mutators installed and i tried all of them
    to switch a weapon i have:

    swap tool v1.1
    ballistic weapons

    some muts that switch only one weapon like ripjack replacer

    all of them works bad... really bad.
    for example - i try to switch biogun to ripjack with swap tool - it replaces flac, but the biogun is gone,
    when i'm trying to switch more weapons with swap tool or ballistic weapons everything goes crazy and i start with one weapon in wrong place in last man standing ;/
    in other game modes there's a mess too ;/

    my ut2004 directory is like 28gb and i really dont want to install customs all over again so i need a solution to repair the problem

    #2
    I'm using swaptool myself, it's working perfectly fine. So I cannot relate to your problem...

    Comment


      #3
      It might be conflicting with other mutators you have activated. Do you have any?

      Comment


        #4
        Hmm, that might be the case. For example swap tool always stands back behind other active weapon mutators. So it will only work when you have no others activated.
        But that does not apply to the whole mutator, for example if you have your vehicles changed with swaptool you can use ballistic loadout and it will use the loadout plus the swaptool changed vehicles.

        Comment


          #5
          i'm usually using monkey matrix moves, sometimes funtators like gibalicious/ut3 slow time kills and barely vehicle mutators like ut3 manta. I don't use any weapon mutator.

          Comment


            #6
            I would try using the weapon swap tool alone with no other mutators to decide how well it works. Then you can add a mutator or 2 to find out which one is conflicting.
            I use the mutator WORM, it works in the same way.

            Comment


              #7
              i just tried... i closed all mutators and with single swap tool mutator and WORM after that. It's the just the same. for example the weapon that's sposed to be at lightning gun place comes to shield gun and i cannot use it.

              Comment


                #8
                I'm sure you have the game patched to v3369, or if someone maybe has some way to delete maybe the ut2004.ini or something along that to some type of conflict. Also check your log file in the system folder which will indicate errors while running the game. Also that the mutators have advanced options in the mutator menu to fool with, just trying to cover everything in case.
                You can always do a fresh install then update your patch, I always backup my user.ini before. A fresh install won't overwrite any of your mods, and you can put your user.ini back in the system folder, maybe a fresh install will work if nothing else works.

                Comment


                  #9
                  i have a 3369 patch ;]

                  i have like 30gb of custom stuff in my ut2004 folder - my log file shows errors with missing packages, but most of them are hard to find.

                  i did a fresh install - nothing changed

                  tomorrow i'll check the whole ut2004.ini maybe this file couses the trouble ( i kept it during fresh install ), i have a lot of mutators and of i change the file i will loose my Server packages list

                  Comment

                  Working...
                  X