Announcement

Collapse
No announcement yet.

Sky too bright problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Finally, over bright sky is gone after unticking fakebackdrop and unlit. Thanks for all the help.

    Leave a comment:


  • replied
    My blind guess is this could have to do with unlit textures (I think jefe might have been pointing into the right direction here).
    If you don't mind, I suggest this check:
    Delete the SkyzoneInfo, go into the map's subtractive space and select all surfaces of the cube and open the surface properties, untick the option bFakeBackdrop. This option tends to set the surface to unlit per default (even though no tickbox is checked - which makes sense. Why compute lightmaps on surfaces that are replaced by the view of the skybox anyway?).
    Of course you will have to rebuild for it to take effect.
    If the bloom effect still stays, it might be the HoM effect caused by culling due to the fog, to fix that, go into the ZoneInfo properties of the "main map" and tick the "bClearToFogColour" option. That will put the fog's colour everywhere, where something gets culled instead of the HoM effect.
    If I recall, Blackhawk is a static mesh map with just a subtracted cube for playable area and sky. Depending on how those level meshes were designed, it is not unlikely they don't get culled by the fog but the brush's surfaces are (iirc a static mesh gets culled once its pivot is hidden).

    EDIT: Mind you, a sunlight actor only works when there are surfaces that are set to bFakeBackdrop (not sure, but I'd guess that the "sun rays" are cast from those surfaces with that setting, but then again, I'm not a coder ), if the sunlight was the main light source of the map, it might turn pitch black. But what interests me here is the sky and subtracted cube of the playable area anyway, the sunlight shouldn't make any difference then if my theory is right.

    Leave a comment:


  • replied
    I didn't see any unusual actors in the search list. There's a subtractive box that contains the map, if I delete that box, it removes the over bright sky, however, that gets rid of the terrain as well . What settings can I adjust on this subtract box/terrain, to dim the brightness?

    Leave a comment:


  • replied
    It's a custom UnrealScript actor (probably a mutator), not the actual lights.

    Leave a comment:


  • replied
    I'm confused now, I tested by removing entire skybox and sunlight, did a full rebuild, and sky is still extremely bright, like image 2 above. Where is the light coming from? I know its not the light actors, I've scaled them and makes the buildings and maps darker. Its like the distance fog is glowing.

    Leave a comment:


  • replied
    Looks like you're converting DM-Blackhawk for Killing Floor. I'm not familiar with mapping for KF, but it has a bloom effect that increases contrast, making light colors very light. I think the effect is configurable, but I don't know the details. Or you could darken the sky box a bit - Skybox textures are usually unlit, so changing your lighting inside the sky box won't do any good if it is. You could change the skybox or darken the textures, but with a different skybox you'd also need to change the lighting in the level too, especially if you were to make it night time.

    Leave a comment:


  • started a topic Sky too bright problem

    Sky too bright problem


    in game


    I've tried
    -made sure all zoneinfo/skybox info ambient brightness is 0
    -setting sunlight light brightness to 1
    -scale light by -200% brightness

    However, none of the settings can darken the sky. What other settings can fix the brightness?
Working...
X