Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

[OT] Need some Linux advice urgently!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by XxX|Bossman
    sigh* ****inA
    i typed startx at the root prompt and got an error . like a whole page of ****. it didnt boot into any gui or linux windows or nothing.
    The X Windows system must be mis-configured. What's your video card?

    Comment


      I'm going to install Mandrake 10.0 Community tonight. Dual-Boot sweetness!

      Comment


        Originally posted by Logy
        The X Windows system must be mis-configured. What's your video card?
        Vistiontek Geforce 4 ti4600 128mb gpu

        I installed RedHat 9 as a desktop which Im sure X windows was in the installed packages.

        Comment


          Originally posted by Airjrdn
          I assume I'm going to need two partitions, one for the OS, one for swap correct?
          Yes. I also made a separate partition for my /home directory (where all the user files are stored) so if I ever want to upgrade or re-format the OS, I don't have to touch my user data.


          Also, with regards to the OS partition, what filesystem should I use? Aren't there a couple of them that Linux typically uses (ext2 & ext3 or something like that)?
          ext or reiserFS are both good. I use reiserFS. Some distros don't support it by default, though.

          I guess a 3rd note is, I do have an ATI card (9700 Pro). Should I even bother since it's not an Nvidia card?
          You can bother, but you probably won't be thrilled with the results. ATI's Linux drivers have been lagging behind their Windows counterparts for a long time now. By all reports, they are now mostly visually correct, but their performance is relatively crappy. Their updates have been few and far between.

          Nvidia's Linux drivers have been stable and as good as their Windows drivers for years now.

          Comment


            Airjrdn:
            If you're going to install UT2k4, you'll need more than 5-7 GB to install on. *grin*

            200-500MB swap should indeed do you just fine. Fast machines with lots o' RAM shouldn't be hitting disk much anyways.

            If you're not looking to keep it long term, I'd just go with two partitions: / and swap. If you plan on keeping it longer, do at least 3: /, swap and /home. Keeping /home in a separate partition means you don't have to worry about backing up your personal data when you go to upgrade the system.

            As to your ATI card, Radeon 9200's and lower are supported out of the box. The higher end ones (one of which you obviously have) can be run on ATI's binary drivers, available here.

            If you have any more difficulties, I'll be trolling^H^H^H^H^H^H^H^Hwatching this forum tonight to see if I can offer any assistance.

            Comment


              Originally posted by XxX|Bossman
              Vistiontek Geforce 4 ti4600 128mb gpu

              I installed RedHat 9 as a desktop which Im sure X windows was in the installed packages.
              Okay, I'm pretty sure that card should have been detected properly.

              RedHat probably has some utility for configuring Xwindows, but I don't know what it is anymore.

              Here's what you can do, though, to help me figure out the problem.

              type:

              grep EE /var/log/XFree86.0.log > xerrors.txt



              This will search through the X Windows log file and copy the errors to a file called "xerrors.txt"

              If you can find a way to post that here (like copy it to a windows partition, and post it from Windows) I can help find the problem.

              I understand this may seem like a huge pain in the ***, and I can understand why this would turn you off to Linux, but it's up to you to decide if it's worth it.

              I might have been ****** if I encountered this kind of problem when I started out, but strangely, I've never had a problem on a standard install from any distro I've used, especially RedHat.

              Comment


                XxX:
                Do this:

                As root, type:

                less /etc/X11/XF86config

                Look for a section that starts with:

                Section "Device"

                What does it say next to Driver ?

                If it's a GeForce, RH9 should have picked it up and used the "nv" driver, so your line should be:

                Driver "nv"

                Also, make sure if you have a line that starts with VideoRam in that section, that it's commented out (Put a # before the line to comment it out).

                We'll get to editing the file once you post your results.

                Comment


                  Logy:
                  I did that copy thing but since I cant see my hard drive in windows i cant read the file

                  zamoose:
                  I did that and nothing really happened. Just couldnt find the file.

                  Anywho. The error I got when typing startx was
                  Fatal Server Error:
                  No screens found

                  That was just in the midst of the text on my screen. Only thing that looked important.

                  Comment


                    If you have any more difficulties,
                    I appreciate it. If you checked out my website (linked earlier) you'll notice that I have two little ones (23mo & 7mo) so I won't have time to dive into this until later, but we'll see.

                    Comment


                      XxX:
                      Next step:

                      Type

                      rpm -qa | grep -i xfree

                      Post the results here. I get the sneaking suspicion that maybe X wasn't installed correctly.

                      Also, type:

                      redhat-config-xfree86

                      and let me know what the output is.

                      (All of this as root, of course).

                      Thanks.

                      Comment


                        First: (you put -ixfree instead of -i xfree)

                        rpm -qa | grep -i xfree

                        That line returned this: (Ill use *'s to replace repetative stuff)

                        XFree86-mesa-libGL-4.3.0-2
                        * -xfs- -4.3.0-2
                        * -mesa-libGLU-4.3.0-2
                        * -libs-data -4.3.0-2
                        * -font-utils -4.3.0-2
                        * -truetype-fonts-4.3.0-2
                        * -100dpi-fonts-4.3.0-2
                        * -base-fonts-4.3.0-2
                        * -xauth-4.3.0-2
                        XFree86-4.3.0-2
                        * -tools-4.3.0-2
                        * -xdm-4.3.0-2
                        * -libs-4.3.0-2
                        * -75dpi-fonts-4.3.0-2
                        * -twm-4.3.0-2
                        redhat-config-xfree86-0.7.3-2

                        Next:

                        redhat-config-xfree86

                        That returned-

                        ddcpobe returned bogus values
                        Id: None
                        Name:None
                        HorizSync:None
                        VertSync:None

                        BUT It did go into a graphical gui that let me setup some values.
                        So I set my resolution, video card name was already set right. And I changed colors to millions and set my montior to a DellP991. And hit OK. Then it took me back to the root# prompt. Where I had hoped I could type startx. So I did and it gave me the same error.Fatal Server Error: No Screens Found.

                        Comment


                          Take another look at /etc/X11/XF86config. It should exist now. Tell me what it says in the Device section.

                          Comment


                            Taking off for home. I'll be there in ~45 minutes and will be checking this thread then.

                            Comment


                              Well if anybody remembers why this thread was made in the first place I have finally got a Nvidia graphics card working with 3D support!!

                              woo hoo for me, its 00.30 but I did it.

                              Unfortunately its my old MX440 But at the moment its better than nothing. I tired the FX5600 256mb that came with the machine and nothing. I also tried my FX5600 128mb from my Windows machine and nothing, so Iam guessing Suse doesnt like the FX5600 at all!

                              Anyways, I am a happy bunny now. Off to install Quake 3 and Teh Demo with very low settings but still, n'mind.

                              At least I can play Tux Racer all day!

                              Kudos for Linux!

                              Comment


                                Youll never belive it but after two days and tons of note taking and reading and all that mess Im making this post in my mozilla browser in Red Hat 9!!! Thanks guys. Im doing an auto update right now.

                                Im sure there are many things I have yet to overcome. And will be using this thread most likely to keep in touch and ask more questions.

                                For starters. I still have to manually edit my kernel in grub to turn apm=off in order to boot correctly. Plus I am very interested in how Mod got his 3D to work.

                                So far my only problem is that my screen is just a tiny bit blurry. But after I install (find out how to) my linux nvidia drivers, everything should brighten and clear up.

                                So thanks tons yall. Lets see how this goes. I still need to recover my lost space on my seagate 160gig hard drive that I used trying to install RH9 on. I need a good partition program to do that. It was about 75gigs I cant access right now. But im just glad I got this up and running on my Wd 40gig HD all by its lonesome.

                                Ill be back.
                                thanks again.

                                Comment

                                Working...
                                X