Announcement

Collapse
No announcement yet.

UT2004: The FPS in the demo is BAD.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #61
    actually im really impressed with the demo FPS wise.
    I own an average system (1800xp@2000xp, geforce3 oc'd, 512ddr) and this demo runs A LOT better than ut2003 does. (at high detail)
    Also runs a lot better than U2 XMP.
    I really hope all of the retail maps will run this smooth.
    The assault map is the only map in the demo that takes my FPS down a bit, but nothing that wont stop me from fragging them. =)

    I'm quite happy, if retail runs this good i can save up for some future l33t gfx card instead of going for the 9800. thanks epic

    around 45-50 on ONS, 30-35 Assault, 60-80 DM/CTF.
    1024*768, most stuff normal/high where possible, no AA/AF obviously. Not too shabby for a GF3 i'd say

    Comment


      #62
      You can download dx9.0 from microsoft site.
      also i think it`s on cd3 of ut2003.

      Comment


        #63
        Originally posted by Taf
        You can download dx9.0 from microsoft site.
        also i think it`s on cd3 of ut2003.
        so, I don't need to do anything before-hand? just run the installer? (it's not a bad thing to overwrite a previous DX install is it?)

        Comment


          #64
          anyone?


          (this is the last thing I need to know./)

          Comment


            #65
            it should be ok,if there newer dx files on your hd.then dx wont overwrite them anyway.

            Comment


              #66
              Originally posted by dethmanrulz
              anyone?


              (this is the last thing I need to know./)
              You can over-install DX with no problems.

              Comment


                #67
                thanks guys :up:

                Comment


                  #68
                  Re: UT2004: The FPS in the demo is BAD.

                  Originally posted by Derisor
                  AMD Athlon64 3200
                  Asus K8V Mainboard
                  1.5 Gig. DRAM (400)
                  Club3d Radeon 9800XT 256
                  Maxtor 7200RPM 160 Gig drive.
                  P4 3GHz
                  i865 motherboard
                  1GB RAM
                  Radeon 9000 Pro
                  120GB 7200rpm drive

                  I have worse stats than you all around and I get much higher framerates even though I have thoroughly tweaked the game to be UltraHigh all the way around, trilinear filtering and triple buffering enabled, with detail textures on. I don't know what else to say.

                  Have you updated your system with Windows Update all the way? Maybe installed the lastest Catalyst drivers? Just asking.

                  Comment


                    #69
                    Re: Re: UT2004: The FPS in the demo is BAD.

                    Originally posted by Ultron
                    P4 3GHz
                    i865 motherboard
                    1GB RAM
                    Radeon 9000 Pro
                    120GB 7200rpm drive

                    I have worse stats than you all around and I get much higher framerates even though I have thoroughly tweaked the game to be UltraHigh all the way around, trilinear filtering and triple buffering enabled, with detail textures on. I don't know what else to say.

                    Have you updated your system with Windows Update all the way? Maybe installed the lastest Catalyst drivers? Just asking.

                    whoa....... your CPU is being choked by that gfx card.......

                    Comment


                      #70
                      i think you have other problems,i am at 1280x1024 4x aa and 8x af and am getting 60 to 80 fps which pretty good i think, as with no aa or af at 1280x1024 i am over 100 fps


                      p4 2.8
                      9800 xt
                      1gb 400 ram
                      4.2 driver

                      Comment


                        #71
                        I thought it was just me!!

                        In Assault I get about 20-30's FPS and in Convoy I got in the teens!!! THIS SUPER-BLOWS folks. At first I thought it was something wrong with my PC, but not the case. So I lowered the AA & AF settings in the Catalyst control panel to 2X, and nothing changed, still crappy performance, before I had it at 4X/8X.

                        So then I changed the game rez from 1280X1024 to 1024X768 and the FPS rate stayed the SAME!!!!

                        What's the Deal Epic/Atari?? I hope this is just due to it being a Beta Demo?

                        Here's what I got

                        P4 3.0c
                        ABIT IC7 w/ 800Mhz FSB
                        1GB PC3500 Kingston Hyper X @ 2-2-2-5
                        Radeon 9700 non-pro w/ CAT 4.2
                        Audigy 2 ZS
                        XP Pro

                        In the other levels I get very good performance, like around 70-110FPS, but not these two levels; I don't get it. Anyone have any ideas??

                        Comment


                          #72
                          Originally posted by dethmanrulz
                          yes, I am going to get a 3.0 or 3.2 ghz P4 in the spring.... so no more CPU bottleneck......



                          ..........anyways, could someone do me a big favor and give me a link for intel P4 chipset drivers?
                          .......oh yeah, my mobo is a ASUS P4P8X.....

                          thanks,..
                          dude goto asus.com

                          Comment


                            #73
                            Re: Re: Re: UT2004: The FPS in the demo is BAD.

                            Originally posted by dethmanrulz
                            whoa....... your CPU is being choked by that gfx card.......
                            Yeah. I'm still getting better FPS than when I was on my Athlon 1.33GHz PC. But by Summer I'll be getting a new video card. I wanna see how the cards shape up after the next wave of video games come out.

                            Comment


                              #74
                              Convoy is a very badly made map, Feugerstef and Teddie looked over it and they said there coulda been a lot of improvment on Epic's part.

                              See for yourself: http://forum.skill-club.com/showthre...threadid=11610

                              Comment


                                #75
                                Re: UT2004: The FPS in the demo is BAD.

                                Originally posted by Derisor
                                They must have some seriously unoptimized maps in the demo. That or the engine has gone down hill. The reason I say this is because the demo is giving me really bad FPS (28 to 35). This makes it almost impossible to hit people that are dodging in convoy because they warp from one sode of the dodge to the other or merely warp while running.

                                Now I know some people are goign to flame that I should turn down the settings and I tell them now that I have all details on low and screen size on 800x600.

                                Then they will say, "You need to upgrade n00b." To which I will reply that I have a brand new self built computer with the following specs:

                                AMD Athlon64 3200
                                Asus K8V Mainboard
                                1.5 Gig. DRAM (400)
                                Club3d Radeon 9800XT 256
                                Maxtor 7200RPM 160 Gig drive.

                                Well those are only the relevant specs. Its not my system boys. Either the enginge needs to be optimized o the maps do. A system with the horsepower that I have should be able to handle 80 to 100 FPS in this game.
                                I got same problem, but i get pretty low fps in ONS too. I have tried catalyst versions 4.1 and 4.2, same thing both. I also have installed mobo drivers and direcx few times, but no help. And i have tried with full details, lowest details and all between em, and with various different resolutions, allways exactly same fps. But in dm & ctf i got pretty good fps. :bulb:

                                I got Radeon 9800xt card too, is there any1 around who get proper fps with 9800xt?

                                My rig:
                                xp2700+
                                512MB RAM
                                Hercules 9800xt
                                ASRock K7S8XE

                                Edit: At first i was running it with ASUS A7V8X mobo, and tought it was the problem, but it wasnt..

                                Comment

                                Working...
                                X