Announcement

Collapse
No announcement yet.

ut2k4 & Vista performance?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    ut2k4 & Vista performance?

    I have done several tests in both vista x32 and x64, and i always get around 42-43 fps with the infamous utbench (read: http://www.ataricommunity.com/forums...ighlight=demos)
    However, i did a test today with the 64bit patch and here i got as high as 49 fps, which surprises me.

    In xp64 (and xp) i get 62 fps and abit lower with the 64bit patch.
    I have to admit i find it odd that 32bit ut2k4 only gets 43 fps and actually wins some fps with 64bit, in vista.

    Any chance it has something to do with vista not supporting sound through hardware anymore?
    I know it has some link to graphics drivers.. in vista x64 i did put res down to 800x600, and in 32bit ut2k4 i got 45fps but in 64bit patch i got whole 55fps.

    Incase anyone is wondering, im normally running at max quality and 1600x1200 res, 7800GT without AA and AF, and 4200+ X2 at 2650mhz.

    Basically, id like to know:
    Has Epic done some tests or do you know what is causing the huge drawback from xp?

    #2
    What graphic drivers are you using on Vista? Have you tried the latest 158.18 or 158.22 drivers?

    Comment


      #3
      I'm still on 100.65 since the rest break HDTV support.

      Comment


        #4
        When I installed the x64 Patch and ran it, it GPF'd that very second. That's when I decided to keep my x32 version.

        Comment


          #5
          Im using the 101.09 driver, but i havent noticedany changes since Vista was officially released, with ut2004.
          In fact, i dont even see changes from the WDM.

          Comment


            #6
            For the short time I was using Vista x64 (last week ), I noticed the older 93.71 drivers gave the best performance on my Asus GeForce 7300GS.

            Comment


              #7
              i've been disappointed with the performance with both UT and UT2004 in vista 32 and 64 bit. stock maps run fine in UT but with some custom maps my fps will drop into the 40's and 50's where in xp i get a steady 85. with ut2004 i get about the same fps i got on my old athlon64 3000+ geforce 5900se system and now i'm running a athlon fx-57/geforce 7900gt. i've tried most of the driver releases and none have helped performance.

              Comment


                #8
                Yes, Vista performance is notably lower in general for UT2k4. I am on the ATi(AMD now) side of the field and performance is a bit lower. Instead of an absolutely smooth and glassy 85fps, I get some studdering on occasion in some areas of some maps.

                The only thing we can really do is just wait for new driver releases and see if they improve the performance. If some of you may recall, Windows XP game performance was not as good as Windows 98SE performance back when Windows XP first launched. However, if you look at it now, it is no contest. I would be willing to bet that Vista performance will be brought back up to the levels that it should be at eventually, it will just take some time.

                Comment


                  #9
                  hmm

                  im using vista and UT2004 runs awesome......i have an AMD athalon 64x2 processor, 1 gig ram, i did have problems with call of duty (the first one) and halo tho

                  Comment


                    #10
                    I have Vista ultimate sitting on top of my desk uninstalled for that very reason.
                    It was free because I was a beta tester and my brother works for Microsoft and I ran the betas on my notebook but I'm hesitant to put it on my desktop/ut rig. I love free and new things but I don't know if it's worth losing performance...
                    dell 8250
                    p4-2.4 gig
                    5950 ge force ultra
                    1 gig rdram
                    120 gig hard drive....

                    I added the other 512 of ram to run vista but now I just wait....

                    Comment


                      #11
                      Since the nivida drivers on the 02/05 mine is running fantastic.

                      AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ (2 CPUs), ~2.2GHz
                      2046MB RAM
                      Hard Drive:240 GB
                      NVIDIA GeForce 7800 GT
                      Operating System:
                      Windows Vistaâ„¢ Home Premium (6.0, Build 6000) (6000.vista_rtm.061101-2205)

                      Comment


                        #12
                        Ram is so cheap now, about $50 for 1GB, and it's the most important component in a PC.

                        I upgraded my XP PC's from 1GB to 2GB and I noticed a speed improvement in alot of programs.
                        Vista is about 5 times larger than XP, so it requires more memory.
                        Now that memory is so cheap i'm going to upgrade both my PC's to 4GB.

                        I have 2 identical PC's, on one I have XP and the other I just recently installed Vista Ultimate.
                        I installed the latest nVidia Xp and Vista drivers and tried a few graphics benchmark tests, and overall the XP PC ran about 2 to 3 times faster.

                        Like StanMan2K wrote, we just have to wait until better vista drivers are made.


                        My 2 PC's I bought about 3 years ago and have upgraded the ram, video and HD:

                        AMD athlon 3000+
                        2 x 1GB DDR ram (max 4GB)
                        nVidia 6600GT AGP
                        250GB IDE HD

                        Comment


                          #13
                          ram is cheap for some rigs--but not mine! My dell used that rdram rambus type and I paid over $100 for 512 used on ebay--new stick can be three times that from dell or the memory venders....

                          Comment

                          Working...
                          X