Announcement

Collapse
No announcement yet.

Console or Bind To Open Settings Screen?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Console or Bind To Open Settings Screen?

    Anyone know is there a way to open the settings screen ( press esc then click on settings or just click on settings from main menu ) from a bind / console / alias command? Or is there a way to specify show / hide crosshairs through a console command / bind / alias??

    Thank you.

    I am trying to find a workaround to fix an issue with something else.

    #2
    Read this.

    Comment


      #3
      Originally posted by Scam
      Read this.
      Are you answering the question " how do I key bind?" because that thread does not specify how to bring up the settings screen ( ie gui ). It does however bring up the advanced settings yes. I know how to do that through console with "preferences".

      Comment


        #4
        oh,
        Well sorry!

        Comment


          #5
          Try binding a key to:

          set HUD ShowCrosshair True | set HUD CrosshairStyle <number>

          Replace <number> by your crosshair style
          If you are having issue with the bind, try adding "Engine." before HUD. Usually UT2004 assumes that the parent class is Engine (reason why you do set Input and not set Engine.Input, but both works)

          also for a third safety net:

          set XInterface.HudBase bUseCustomWeaponCrosshairs False

          Comment


            #6
            Originally posted by Sm@ck
            Are you answering the question " how do I key bind?" because that thread does not specify how to bring up the settings screen ( ie gui ). It does however bring up the advanced settings yes. I know how to do that through console with "preferences".
            Well, if the console command "preferences" still works (jeez, I haven't used that since UT99 days), then simply bind your key in the user.ini like so:

            [NameOfKey] = preferences


            Done deal.

            Comment


              #7
              Originally posted by Discord
              Well, if the console command "preferences" still works (jeez, I haven't used that since UT99 days), then simply bind your key in the user.ini like so:

              [NameOfKey] = preferences


              Done deal.
              This doesn't open the settings screens but opens the advances preferences options (which is not in the GUI of the game anyway)

              Comment


                #8
                Thank you to all those who answered this question. The fix is:


                key=ToggleScreenshotMode|OnRelease shot|OnRelease ToggleScreenshotMode|OnRelease showgun

                Comment


                  #9
                  You could also use

                  Key=ShowHUD|set HUD ShowCrosshair False|OnRelease Shot|OnRelease ShowHUD|OnRelease set HUD ShowCrosshair False

                  Or simply

                  Key=Key=ShowHUD|OnRelease Shot|OnRelease ShowHUD

                  Comment

                  Working...
                  X