No announcement yet.

Little help on a confusing problem?

  • Filter
  • Time
  • Show
Clear All
new posts

    Little help on a confusing problem?

    I recently aquired a new router, made by D-Link. For my multiple PCs it does its job admirably. Only problem is, online gaming. I get a decent ping (28-44) on most nearby servers on this router/ISP. However, unlike the old router, as soon as I installed this one I began having one problem.

    When I play online, I suffer from what appears to be packet loss. Despite my low ping, about every 30 seconds, and only for a second or less, any actions seem to have about a 150 ping reaction time. This may only be noticeable for one shock rifle primary shot in that 30 second time period. Also, frequently enemy projectiles/my own projectiles go missing, and when people pick up any of the items, they always appear to still be there...

    For example some bloke picks up the amp, his weapon turns purple, and the amp is still there. This is incredibly frustrating, as it often leads to my downfall as I leap to retrieve a non-existent item

    In case anyone is interested, the F6 (by default) net stats show packet loss as being 0 constantly, even whether I notice something is wrong). Also, pinging servers manually through DOS shows no PL. Pinging my router from PC shows no PL.

    In terms of trying to fix it, I have tried to do the following:

    - Port forwarded 7777,7778 and 7787 (UDP/TCP, cant remember which) and the other port which is in the 28000~ range. (I have setup whether it is TCP/UDP or not correctly).

    - Ensured any firewalls (I only have one on the router itself) are not to blame.

    - Checked netspeed and tried different values in the slightest hope it may help.

    The worst thing about my router and ISP though is that I do not have a static IP address. I am sure that I have enabled the range correctly to accept the ports, but it does not seem to remedy the problem.

    Any ohter suggestions? I'm going crazy here! :bored:

    Make sure that you download the latest version of the router's firmware from the manufacturer's website... The loaded firmware upon purchase is usually a step behind current.

    I had maddening router problems myself, and a firmware update fixed them for me.


      Sorry forgot to mention I updated the firmware recently to no avail, and in case anyone thinks theres any remote possibility of graphics cards going amok (I have, sadly, a GeForce4 MX 440 ) I have the latest nVidia drivers installed. (Well you know, I had to cover all the possibilities I could conceive of )