Announcement

Collapse
No announcement yet.

[Solved] Visual C++ error on load.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [Solved] Visual C++ error on load.

    I recently got back into playing UT2k4 after several years and found that my copy of UT didn't work. It crashed with a generic Virtual C++ error on load after the splash screen. Going to outline my post as if it were someone looking for help and may save someone a reinstall.

    * Already patched to 3369 (ECE & CBP installed), Worked fine before on a quick test run MONTHS ago (I periodically check games i don't play often for functionality especially after configuration changes).
    * Latest DX9 (I'm on XP 32bit). Gimmie a couple grand for getting Win/vista/7/8 capable apps to use the pretty Win7 interface and I'll upgrade. That also includes downtime from having to learn and become comfortable with a new workflow...
    * Latest video drivers (though the latest game I've played was Mass Effect 3).
    * All the other popular troubleshooting tip thats originated in the 90s (defragging, virus scan, replace blinker fluid).

    Configutation changes between when UT2k4 worked and suddenly didnt work:
    * Windows User-Mode Drivers (for plugging my android device into USB)
    * .NET 4
    * Unrelated drive failure (Drive N:, Games are stored on D: )

    Additional Steps.
    * Googled the problem... Bwahahahaahhahahahahahaaa... a lot of "me too" & "did you fix it". A few suggestions were even funnier. One suggestion, reinstall UT2004.
    * Restored UT2004 from my primary backup. Crash.
    * Re-imaged the OS from a previous known UT2004 working state. Still crashes. (windows lives by itself on its own tiny 13GB partition, everything else is installed on separate partitions & disks)
    * Renamed by Bad copy of "UT2004" directory to "UT2004 X"
    * Reinstalled UT2004. Works
    * Reinstalled ECE. Works
    * Reinstalled CBP. Works... Cool, but I want my addons and maps. Cant find most of this stuff anymore!
    * Backed up my "bad" UT .ini files. Replaced the "bad" copies with copies from new install. Works. Good, but that means i'll have to hand edit my settings and ServerPackages info back, and all that other jazz.. fun. Fun!. FUN!!

    Hmm... Got me thinking because I remember ... Something similar with UT99 a decade ago, when I changed video cards (Corsair Forums)... Let me try this again but with UT2k4.

    So one by one, I copied my "bad" ini files back into my original install. One at a time, working good.. Until CRASH!
    Seems the crash was caused by "UPlaylists.ini"... So I look in it, and see my mp3 playlist. Then thought, yes I did reorganize most of my music collection recently. But could this cause UT2004 to crash on start?
    CRASH!

    Seriously, UT2004 will issue a Visual C++ crash if it cant find files from an optional feature? So I cleared out the contents of my "UPlaylists.ini", and UT2004 worked wonderfully...
    * Exited, and restored the rest of my "bad" ini files. UT2k4 Works! Awesome!
    * Deleted the newly installed "UT2004", then renamed "UT2004 X" back to UT2004. Game works still...
    * Updated my backup copy of UT2004 with the new ini file.

    Cool...


    TL;DR
    UT2004 issues a generic Visual C++ crash if you have a playlist set "UPlaylists.ini" and move the music files.

    #2
    Huh, good to know that. Yea, the music player seems to be coded in native code (it looks like it was less native in UT2003, actually), and thus if they didn't hook it up to the General Protection system, you'll get that vague "the program crashed and I'm not telling you anything else" message.

    Comment


      #3
      Whenever I've gotten one of the C++ errors it has always been a bad ini, but usually it's the UT2004.ini corrupted on a bad shutdown. I've also transferred my UT install several times over the years (with different drive letter/install path layouts) but I've never had that issue with Uplaylists. It may have just been corrupted.

      Comment

      Working...
      X