Announcement

Collapse
No announcement yet.

Dedicated Server Hosting from Game issues.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Dedicated Server Hosting from Game issues.

    Hi, I've been trying to host a dedicated server for Unreal Tournament 2004 from my computer for a few days now. I'm launching the dedicated server from the game. I've made sure to forward all of the appropriate ports on both TCP and UDP. It's a vanilla UT server, so I'm not running an mods or custom mutators. I also have made it so I've enabled the ServerBehindNAT option in the User.ini. When I launch the dedicated server, the console seems to come up with a successful connection, stating that the Master Server has set Match ID: 0, but when I look for my server to play on it, it shows a "?" where the ping should be, and upon trying to connect, it shows the connection screen for a long while, showing it's trying to connect to my IP, and then fails and doesn't work. I've even tried the same thing while disabling Windows Firewall and Avast! Web and File shield, with no positive result.

    I don't know what other problems could be keeping me from hosting. I'm at a loss, and I realy need assistance. Any ideas are welcome.

    #2
    What port numbers do you forward to the IP address of the dedicated server?

    Comment


      #3
      I forwarded 7777 - 7788, 27900 - 27902, and 42292 (my router allows for forwarding a range of ports).

      Comment


        #4
        If you're sure you've done forwarding correctly, then I'd check the NAT router for quirks. I remember one that required you to reserve the IP address for the destination device in DHCP for NAT to kick in.

        NAT Router:
        [X] Forwarded UDP 7777 -> Dedicated Server IP Address
        [X] Forwarded UDP 7778 -> Dedicated Server IP Address
        [X] Forwarded UDP 28902 -> Dedicated Server IP Address

        Host Firewall:
        [X] Allow Inbound UDP 7777
        [X] Allow Inbound UDP 7778
        [X] Allow Inbound UDP 28902

        Assuming Windows 7
        One method to check the actual listening ports:
        1. Start the dedicated server.
        2. Start: Task Manager (Ctrl+Shift+Esc)
        3a. Select: Performance
        3b. Select: Resource Monitor
        4. Select: Network
        5. Put a checkmark on UT2004.exe.
        6. See the Listening Ports section.

        I know you disabled the firewall, but:
        (UT2004 should have added its own firewall rules, opening UT2004.exe to the world on both UDP and TCP. The rule name is UT2004 under Inbound.)
        1. Start: Windows Firewall with Advanced Security
        2a. Inbound
        2b. New Rule...
        3a. Port
        3b. UDP
        3c. Specific local ports:
        7777, 7778, 28902
        3d. Allow the connection
        3e. Make sure all profiles are checked (simplified).
        3f. Name:
        UT2004 Dedicated Server (Internet)

        (There's a different port if you host a dedicated server on the LAN.)

        If your NAT router is seeing a private IP address on its WAN/Internet port, you're probably behind another NAT router.

        Also:
        http://wiki.unrealadmin.org/Server_Setup_%28UT2004%29

        Comment


          #5
          I believe that adding the Inbound Rule for UT2004 solved my problem.

          I changed that and started a server and I not only was able to connect to mine but got several others to connect. Thank you for your help.

          Comment

          Working...
          X