Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Tips for Improved Video Performance

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tips for Improved Video Performance

    Hey folks,

    I just thought I would put in this forum some tips that have worked for me in order to make the game smoother. My systen is a P4, 2 GhZ, 512MB RAM, and a Geforce FX5900.

    First, make sure (obvious) you have the latest Nvidia (or other graphics) drivers. They just put the new ones up on 3/15

    Second, make sure your audio drivers are up to date too. An old audio driver can actually hang your system as well.

    Third, defrag your hard disk after the install. Many have reported a significant improvement in game play after they do this.

    I won't go into how you can change your video settings, b/c that is pretty obvious that can enhance smoothness by lowering detail levels, and by most counts, these issues happen regardless of what detail settings you have.

    Open your x:\UT2004\system\UT2004.ini file and do these edits

    In every instance there is a x/y screen coordinate (screen resolution) set your screen resolution. Example:

    MenuViewportX=1280
    MenuViewportY=1024
    WindowedViewportX=1280
    WindowedViewportY=1024
    FullscreenViewportX=1280
    FullscreenViewportY=1024

    etc...

    In every instance you see "vsync," set it to yes.

    UseVSync=True

    In every instance you see anisotropic filtering, set that to "0."

    LevelOfAnisotropy=0

    Also, for Nvidia users, turn this off on your card in your settings (should be located in system tray).

    Set your minimum desired frame rate to 50 (again, every place you see it)

    MinDesiredFrameRate=50.000000

    Set your desired frame rate to whatever your monitor is at (my flatscreen is 72)

    DesiredRefreshRate=72

    Set these to true everywhere you see them...

    UseTrilinear=True
    UseTripleBuffering=True

    Also, in the settings, disable the "preload skins" option.

    One more (added 3/19/04)

    For Nvidia users, turn Anisotropic OFF in the performance preferences, and set Anti Aliasing to "Application Controlled." This is another biggie that will take that "feels like I am drunk" vibe off the motion, and make your movements much crisper. You will barely notice the difference in the details, but will notice a huge difference in performance.

    I performed the above and it worked for me...it may not work for you, so save the UT2004.ini to UT2004_OLD.ini so you can go back if needed.

  • #2
    overall good tips...Ive done that on mine as well. But the anisotropy and triple buffering I didnt do. Ill check those when I get home. The key ones I think are min desired FPS, but I think that has been removed in the D3D settings. :weird: Thought they were there before, but I didn't see them now. But your desired refresh should definately be what your monitor is. That will make it seem smoother.

    Comment


    • #3
      Yeah, with the "default" detail settings, things are pretty smooth now.

      Comment


      • #4
        How does the minimum desired framerate work? What does it affect and cause?

        Comment


        • #5
          Thanks Echo you da man :up: :up: :up:
          Running my p4 1.6 this morning I was clocking in a 35-40 fps for assault and ONS
          I used your framerate, reset my refreshrate, vsynch, etc. and now I'm looking at an fps 45-60, which is what I had roughly for the demo.
          Thx dude, I owe you one :up:

          Only thing that caused me some trouble was deselecting auto internet speed adjustment. It caused me to have longer loading times on the splash screen.

          Comment


          • #6
            Thanks for the tips, the one about the anisotropic setting helped me alot. Good stuff for Nvidia and ATI users alike.

            I get the same results with that dynamic netspeed setting, where turning it off results in longer load time for the initial splash screen right after clicking the icon to play.

            Thanks again.

            ----------------------------------------------------
            Pentium 4 CPU 3.01GHz Hyperthreading Enabled
            Abit VI7 - VIA PT800/VT8237
            512MB DDR400/PC3200 Crucial RAM @ 2.5-3-3-7
            120GB Western Digital SATA HDD
            40GB Western Digital IDE HDD
            Hercules 3D Prophet 9800 Pro 128DDR (4.3 Catalysts)
            Coolermaster Aero 4 CPU fan @ 2800rpm
            Aspire X-Dreamer II Case
            Enlight 360W PSU
            Viewsonic G90fb 19" CRT
            Klipsch Promedia GMX A-2.1 Speakers
            Logitech MX Duo Wireless Mouse/Keyboard
            Avg CPU temp range - 70F/21C idle - 100F/38C peak
            Windows XP Pro-(tweaked to use less ram)
            ----------------------------------------------------

            Comment


            • #7
              Awesome tips man, helped me get rid of some mysterious slowdowns I was having, sorry for bumping, but it's worthy

              Comment


              • #8
                i have to try this as soon as possible...but i'm not having much trouble as of now. the game is running pretty good, but i need to test it more i only played a few maps before going to sleep. good job man.

                Comment


                • #9
                  Great tips!

                  How ever do you come with those things?

                  I never understand s*h*i*t from those ini files...

                  Before my game was crummy as hell... and now... plays as smooth as I wanted... Thanks mate! Hope to frag you some online sometime...

                  GreetZ, XyPe

                  Comment


                  • #10
                    by enablind TriLinear filtering and upping the basic resolution, dont you make the game run worse?

                    Id say the only thing making it run better is the mindesiredframerate option, which lowers settings like world detail etc to hang around the desired framerate...

                    Id like to know if all these people would have a good game without the mindesiredframerate option.

                    Comment


                    • #11
                      Originally posted by |XyPe|
                      Great tips!

                      How ever do you come with those things?

                      I never understand s*h*i*t from those ini files...

                      Before my game was crummy as hell... and now... plays as smooth as I wanted... Thanks mate! Hope to frag you some online sometime...

                      GreetZ, XyPe
                      Thanks!

                      Another one I forgot to mention is for Nvidia users, turn Anisotropic OFF in the performance preferences, and set anti aliasing to "Application Controlled." This is another biggie that will take that "feels like I am drunk" vibe off the motion, and make your movements much crisper.

                      Comment


                      • #12
                        Originally posted by Jognt
                        by enablind TriLinear filtering and upping the basic resolution, dont you make the game run worse?

                        Id say the only thing making it run better is the mindesiredframerate option, which lowers settings like world detail etc to hang around the desired framerate...

                        Id like to know if all these people would have a good game without the mindesiredframerate option.
                        You don't have to up the resolution, those are just the ones I am using. I actually found though that with a lower res, you notice the slower framerate more. If you disable trilinear in your graphics options, I think that will make the game run even smoother, but I reached a point where it was working fine for me, so I didn't kill that option.

                        I don't fault Epic for not having the game run smoothly on every platform, but it would have been nice if they included vsync (and other standard video options) in the settings interface...I remember that the demo had at least vsync options as a choice.

                        Comment


                        • #13
                          bump

                          Comment


                          • #14
                            OMFG! This was working perfectly and then suddenly it just STOPS working! I only changed the minimum desired framerates at first, and that worked like a dream. Now, it has no effect; works just the same crappy way. Please, is there any way to reset my .INI, fix it, or make the minimum fps work again? It was working SOOOOOO well, I'm so upset!

                            Also, is there anything like this in other games?

                            Comment


                            • #15
                              bump

                              Comment

                              Working...
                              X