In the last few days i've come across a problem with the unreal editor. Almost everytime I click the Terrain Editing tool to open the terrain editing window, it opens but the buttons are randomly placed around the window, on the layers and decoration tabs the delete, move up, move down etc.. are almost always removed completely.

Here is a screeny to illlustrate the problem.



As you can see in the screeny, the New terrain button is also completely missing this time. It happened once today to the window that pops up when you right click a surface and go into surface properties. When it happens, it happens for good and I have to restart the editor and hope that it doesn't happen when I open these windows. I've noticed that if I configure the viewports in the editor before opening anything, it sometimes helps to minimize the disruption, although this could just be a coincidence.

I've tried deleting the unrealed.ini file but it doesn't help. I've also tried going into the ATI video settings and disabling/enabling things like Catalyst ATI but it doesn't seem to be helping either.

Everytime I open the editor it seems to happen at different degrees, sometimes the buttons might be all in the wrong places, but just on screen enough for me to make sense of them and use them, other times they are completely lost making it impossible for me to use the editor.

I recently upgraded to Windows 7 64bit and I have an Intel Core 2 Quad Q6600, 4GB RAM and a Radeon HD 3800 graphics card.

I think I might need to adjust a setting somewhere but I don't know what. It's strange this has only just started happening. I wonder if one of the updates I downloaded for windows has caused this.

Thanks for any assistance.