Announcement

Collapse
No announcement yet.

Screenshots are Black

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Screenshots are Black

    Does anyone know why I can't take screenshots. When I go to my
    Screenshots folder they are all there, but they are black, no image.

    This just started about a month ago. They used to work. I reinstalled
    the game...didn't fix it. I reinstalled windows on a brand new HD, and
    reinstalled the game... didn't fix it.

    I can't brag to my friends anymore. I need help.

    #2
    So I figured out that I have to switch the renderer to OpenGL
    inorder to take screenshots. My 8800GTX wont do it under Direct3d.

    Problem is OpenGL isn't even half as fast as D3d. The fps is lower and
    the game studders a bit.

    Anyone have another solution to run D3d and still get screenies?

    Comment


      #3
      I am also suffering this problem and have the same graphics card.

      I would love to see a solution to this too, as I do some map making and need the screenshots for these forums, but the software renderer is terrible quality.

      Comment


        #4
        Try other drivers, try updating them or rolling back to older ones ?

        Comment


          #5
          Have this problem with 8800GTX with nVidia latest 97.94

          Teg, in your case - switching to OpenGL is the best immediate solution, as for all others who invested in UT3-capable videocard, I suggest moving onto nVidia forums, as this is clearly their problem, and that way they'll know (if not yet, but that's unlikely) about it for sure.

          P.S. ****, and I hate that new Control Panel!

          Comment


            #6
            Confirmed with an 8800GTS with 97.92 drivers.

            Out of the three screenshots I have from when I had that card, two were black and the third was at a lower resolution, suggesting I was playing windowed, but not black.

            I suspect, then, that taking a screenshot while windowed would produce screenshots normally.

            Comment


              #7
              Ok, I'm going to sound like an idiot now, but how do I (or anyone else) change from D3d to openGL?

              Comment


                #8
                Open UT2004/System/UT2004.ini, find section [Engine.Engine], then put a semicolon in front of the line RenderDevice=D3DDrv.D3DRenderDevice and add another line: RenderDevice=OpenGLDrv.OpenGLRenderDevice

                Also, created a thread on nVidia forums. Hope that'll draw their attention to the problem.

                Comment


                  #9
                  Do you still get the same problem if UT2004 is windowed?

                  Comment


                    #10
                    at _Lynx: I went to the UT2004.ini file, but the line is already there.
                    [Engine.Engine]
                    RenderDevice=D3DDrv.D3DRenderDevice
                    ;RenderDevice=D3D9Drv.D3D9RenderDevice
                    ;RenderDevice=Engine.NullRenderDevice
                    ;RenderDevice=OpenGLDrv.OpenGLRenderDevice
                    ;RenderDevice=PixoDrv.PixoRenderDevice
                    AudioDevice=ALAudio.ALAudioSubsystem
                    ...
                    So it's already there, but now how do I tell UT to use openGL?

                    ########

                    at anyone who said 'windowed': I ran UT windowed, the screenshots have colour again, but I've now got a bit of the UT menus at the bottom of the pic.

                    Comment


                      #11
                      semicolon in front of the line tells the game it should ignore this line, so for your UT, ini looks like that:

                      RenderDevice=D3DDrv.D3DRenderDevice
                      AudioDevice=ALAudio.ALAudioSubsystem


                      Just remove semicolon in front of RenderDevice=OpenGLDrv.OpenGLRenderDevice and put one in front of RenderDevice=D3DDrv.D3DRenderDevice

                      Comment


                        #12
                        Originally posted by {WBK}Viper View Post
                        When I go to my
                        Screenshots folder they are all there, but they are black, no image.
                        Does this also happen if you press your Print Screen button and paste the shot into paint or Photoshop rather than using the inbuilt screenshot buttons?

                        It will probably do exactly the same thing but you never know it may work

                        Comment


                          #13
                          Also, **** thing works on Vista on 101.?? beta drivers. But not in WinXP. nVidia's really having problems....

                          Comment


                            #14
                            I'm also having the black screenshot problem. Seems to happen since I changed drivers to the more recent 1xx.xx versions. Definently a driver issue. I tried with Fraps and it works well. However it seems that, when I try to stop Fraps, XP goes nuts. I bet it's the nVidia drivers causing this.

                            Originally posted by _Lynx View Post
                            P.S. ****, and I hate that new Control Panel!
                            Code:
                            Windows Registry Editor Version 5.00
                            
                            [HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\NvCplApi\Policies]
                            "DevPolicies"=dword:00000000
                            "ModePolicies"=dword:00000000
                            "ModePersist_GPU:0_Mode:0"=hex:00,00,00,00,40, 00,0 0,00,00,00,00,00,00,00,00,00,\
                            05,00,00,00,00,00,00,00,05,00,00,00,00,00,00,00,00 ,00,00,00
                            "LutPersistDesktop_GPU:0_Head:0"=hex:00,00,00, 00,6 4,00,00,00,64,00,00,00,64,00,\
                            00,00,64,00,00,00,64,00,00,00,64,00,00,00,64,00,00 ,00,64,00,00,00,64,00,00,\
                            00
                            "LutPersistFSVM_GPU:0"=hex:00,00,00,00,64,00,0 0,00 ,47,00,00,00,47,00,00,00,5a,\
                            00,00,00,45,00,00,00,45,00,00,00,00,00,00,00,00,00 ,00,00,00,00,00,00
                            "ContextUIPolicy"=dword:00000001
                            "CplGroupUIPolicy"=dword:00000001
                            "TaskbarUIPolicy"=dword:00000001
                            "SedonaDisable"=dword:00000002
                            That should give you the option to switch between old and new control panel style. Be aware that many times if you change a profile option and click "Apply" it will just close the control panel and not save the change. Also in the AA options it doesn't save it if you choose "Aplication controlled". I had to use RivaTuner to "fix" it.

                            Comment


                              #15
                              Just realized last nite I have the same problem with my new 8800GTS. Also effects the dumpframes command.

                              Running UT in windowed mode without changing any other settings solved the problem for me.

                              I haven't tried any of the other suggestions yet to see if if can get it to work in full screen mode.

                              Comment

                              Working...
                              X