No announcement yet.

UT2004 Multi Player & Windows Firewall - Please Help

  • Filter
  • Time
  • Show
Clear All
new posts

    UT2004 Multi Player & Windows Firewall - Please Help

    I am running XP Home with user accounts setup. I have my son setup with a limited account and when he runs the game and clicks on join game it comes up with the following:

    It has been determined that the Windows Firewall is enabled and that UT2004 is not yet authorized to connect to the internet. Authorization is required in order to use the online components of the game. Please refer to the README.TXT for more information

    1. I can run it under the administrator account and it works fine.
    I can also turn off the firewall and it runs fine under his account.
    I did this by logging in as him and using the run as function to turn off
    the firewall.

    2. I can not find this read me file anywhere. :bulb:

    3. I did find this on the forums:

    Multi-player: Open ports necessary for firewalls or routers
    Make sure your firewall, NAT or router has the proper ports open
    For the game to work correctly you need ports 7777, 7787, 7788, 27900, and 42292 to be open in your firewall or router.

    If you are unsure how do to this, contact your hardware or software manufacturer.
    Did this information help you?

    Yes, this fixed the issue.

    No, this did not help...continue troubleshooting.
    __________________________________________________ _______________

    So to the best of my knowledge I did this to open up the ports but it still did not work.

    Please help this is very

    Try clicking on the UT2004 enty (ie the top one) in the list and click the Edit button. Then click the Change Scope button. Make sure the "Any Computer" radio button is selected and click OK.
    Strange it doesn't work, as I just have the ut2004.exe file set up in Windows Firewall as being allowed permission and it works fine, but then again, I'm running an Administrators account.
    Have you also tried going into the Advanced tab and adding the ports to each of the connections listed there?
    One of my games (Hidden and Dangerous 2) has got its ports listed in the Advanced section, not under the general Execptions tab.

    It is of course entirely possible that the account your son has will limit it no matter what. Maybe switch him to a Power User account? I'm not sure of the limits on the Limited User account.


      Still no luck. Here are the screen shots.


        Is your son set up with a limited internet connection? ie parental controls?

        If so its possible that this is what is causing you problems, you will have to allow connection to specific sites if so or it will block him, just a thought


          He is setup with a limited user account. It has something specific to do with the firewall because I can turn it off and he can play. But when it is on it give me the error:

          It has been determined that the Windows Firewall is enabled and that UT2004 is not yet authorized to connect to the internet. Authorization is required in order to use the online components of the game. Please refer to the README.TXT for more information
          Any and all help is greatly appreciated. Thanks in advance.


            hey bud!! No what i meant is, is he set up wth limited access via your ISP?
            its possible that the firewall adjusts for each type of account and also the settings on the server for content, you will have to adjust the firewall to allow required servers to play UT Which Firewall Software are you using? post back soon and i'll have a look to see what the setup is! Ta. :up:


              No limit on ISP side. He has complete access just like I do. Like I said it is something specific with the windows xp firewall. If I turn off the firewall he can play but if it is on... it will not let him. Sorry it took so long to get back to you... I have basically given up hope on a fix for it and have give him an admin account so he can play.


                I'm having the same problem. I reformated my computer tonight and decided to play around with the user accounts. I set up a admin account and a limited user account for myself. I can play fine with as the admin, but not with the other account. I get the same message as Superman.

                I know it is set up right because if I use xfire to locate a server using the limited account, I can join a server fine.

                I also noticed my settings were not being saved. I fixed that by giving the limited account admin privilages long enough to change the settings. The in game browser worked then as well. It stopped when I changed the account back to a limited user. Hope that's not too confusing.

                Also I've test quake 4 multiplayer with the limited account and it works fine.


                  I know this is an old thread, but I just ran across this problem and have come up with a workaround. I believe the problem stems from UT2004 checking if it has write permission to the firewall registry settings - and failing if it doesn't, regardless of whether there is an exception or not.

                  Note, this workaround involves mucking about in the registry and using regedit, so be careful, caveat emptor, and all that good stuff.
                  Note also, that this workaround allows unprivileged user programs to modify the firewall settings, so this opens up a bit of a security hole - but nothing worse than running as Administrator all the time.

                  1) Log into an admin account and click Start->Run and type in regedit.exe.
                  2) Navigate to the \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servi ces\SharedAccess\Parameters\FirewallPolicy\Standar dProfile\AuthorizedApplications\List key
                  3) Click on the "List" key, and choose Edit->Permissions. Either add the unprivileged user to the user list, or choose the USERS group and click the "Full Control" check box below.