Announcement

Collapse
No announcement yet.

UAdmin Mod 095b

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UAdmin Mod 095b

    Hey Gurus,

    Does anyone recall any kind of clash or mutator/patch incompatibility that affect UAdmin Mod? None of my server commands work properly except ReservedNicks, ReservedSlots and AutoAdmin Login even though my ini file is fine, I've redone the ini several times and copied fresh files from the zip files over and over again. Problem started just by itself, I'm not sure what I've done to cause this. I've once recreated a server from scratch with no success, and redone my server ini yesterday with the same results.

    Mutators I'm running are AntiTCC 1.18 Beta5, UAdmin Mod 095b, UT2Vote43, Zound, Excessive (kicks in only in INV). Problem started before I started using UT2Vote43 and Zound, so consider AntiTCC as the only mutator running on the server.

    I've included a my ini settings here. I have Autoadmin login, reserved nicks and reserved slots configured but did not include the info here

    Appreciate your comments,
    QettoE

    Oh by the way, UAdmin Mod 095 did not work fine as well when I downgraded the version to 095 from 095b!

    [UAdminModV095b.UAMAccessControlIni]
    bMakeRoomByKicking=True
    bUsePassword=True
    bAutoAdminLogin=True
    bEnableReservedSlots=True
    bEnableSilentAdmin=True
    iMaxExpansion=5
    sReservedSlotPW=
    sOldReservedSlotPW=
    ReservedHashes=1234567890
    PrivClasses=Class'XAdmin.xKickPrivs'
    PrivClasses=Class'XAdmin.xGamePrivs'
    PrivClasses=Class'XAdmin.xUserGroupPrivs'
    PrivClasses=Class'XAdmin.xExtraPrivs'

    [UAdminModV095b.UAdminMod]
    bNotifyOfUAM=False
    iNotifyInterval=300

    [UAdminModV095b.UAMGameRules]
    bAllowFFAgainstFrozen=True
    bAllowFrozenSuicide=False

    [UAdminModV095b.UAMUtils]
    bDebug=False

    [UAdminModV095b.UAMNickFilter]
    bEnabled=False
    bBanBadNicks=False
    BlockedNicks=[ELF]
    BlockedNicks=[Elf]

    [UAdminModV095b.UAMReservedNicks]
    bEnabled=True
    iWarnings=1
    iScanFrequency=60
    ReservedNicks=

    [UAdminModV095b.UAMPingWatch]
    bEnabled=True
    bAdminsImmune=True
    bCheckForServerLag=True
    bIgnoreHighAndLow=True
    iMaxPing=250
    iMinPing=0
    iScanFrequency=15
    iMinScansForAction=5
    iMinPlayers=12
    iWarnings=1
    iScanDelay=60

    [UAdminModV095b.UAMCustomMessages]
    bEnabled=True
    bDspInChat=False
    bMsgBeep=True
    iMsgInterval=120
    fMsgDuration=15.000000
    MsgColor=(B=0,G=255,R=255,A=255)
    CustomMessages=Today's Omnip)o(tentS Server map count: 973 Maps, 10.30 GB.


    [UAdminModV095b.UAMBalanceTeams]
    bBalanceOnPlayerExit=False
    bMonitorTeamSwitches=False
    bReportOnTeamSwitches=False
    bUndoBadSwitches=False
    bEnabled=True
    bAdminCmdOnly=False
    bAdminsImmune=False

    [UAdminModV095b.UAMChangeTeam]
    bEnabled=True
    bAdminsImmune=False
    bUseAdminName=False

    [UAdminModV095b.UAMFreeze]
    iMaxFreezeTime=20
    bDeathAfterFreeze=True
    bEnabled=True
    bAdminsImmune=True
    bUseAdminName=False

    [UAdminModV095b.UAMHelp]
    bEnabled=True
    bAdminCmdOnly=True
    bAdminsImmune=True

    [UAdminModV095b.UAMList]
    bEnabled=True
    bAdminCmdOnly=True
    bAdminsImmune=True

    [UAdminModV095b.UAMLlama]
    bEnabled=True
    bAdminsImmune=False
    bUseAdminName=False

    [UAdminModV095b.UAMMute]
    bEnabled=True
    bAdminsImmune=True
    bUseAdminName=False

    [UAdminModV095b.UAMResetScore]
    bEnabled=True
    bAdminsImmune=True
    bUseAdminName=False

    [UAdminModV095b.UAMSlap]
    iSlapDamage=25
    fSlapMomentum=500000.000000
    bEnabled=True
    bAdminsImmune=True
    bUseAdminName=True

    [UAdminModV095b.UAMSlay]
    bEnabled=True
    bAdminsImmune=True
    bUseAdminName=False

    [UAdminModV095b.UAMVomit]
    bEnabled=True
    bAdminsImmune=False
    bUseAdminName=False

    [UAdminModV095b.UAMBroadcastHandler]
    bFilterChat=False
    bLogChat=False
    BadWords=You can add up to 50 of these.

    #2
    Re: UAdmin Mod 095b

    Originally posted by QettoE

    Mutators I'm running are AntiTCC 1.18 Beta5, UAdmin Mod 095b, UT2Vote43, Zound, Excessive (kicks in only in INV). Problem started before I started using UT2Vote43 and Zound, so consider AntiTCC as the only mutator running on the server.
    i currently have running with ut2vote43/44, zound, talking Icon, waitlimit, and many more...i have never had it stop working..with current and previous patch level...your uadmin entries look okay. did you replace the accesscontrol entry in your ut2004.ini? also, if you are using ut2vote, can you post it's ini?

    Comment


      #3
      Sure, here is my UT2Vote. Remember that problem started before I switched to UT2Vote 10 days ago. I did not include game configs to avoice a long message. All other muts are in mut list in UT2Vote.


      [UT2Vote43.UT2VoteConfigs]
      VoteAdminPass=None
      ClanAdminPass=None
      GamePassword=
      DefaultGame=UT2k4Assault.ASGameInfo
      ;DefaultGame=Onslaught.ONSOnslaughtGame
      DefServerName=QettoE'z -Omnip)o(tentS- Public UT2k4 Server
      ServerMuts=UAdminModV095b.UAdminMod,Zound45.Zound
      ServerLine=
      bAllowArena=True
      bAllowMuts=True
      bAllowKick=True
      bAllowGames=True
      bNoVotePopup=False
      bDoGamePopup=False
      bColorSkins=False
      bNoWeapShake=True
      bAllowBehind=True
      bTallyOverlay=True
      bShowBotsKick=True
      bAdrenDisable=False
      bNoComboAdren=False
      bVoteWhenDead=False
      bWebadmin=False
      bArenaAlone=True
      bMutAlone=True
      bNoRestart=True
      bHideNames=True
      bAlwaysKick=True
      bAltSwitch=True
      bMinMaxMaps=False
      bDisAllVoting=False
      bNoWeapStats=True
      bDisServAdmin=False
      bDisOpinion=False
      bDisAdminMesg=False
      bClanServName=False
      bDisDemoRec=False
      bUseChatLog=False
      bUseChatMap=False
      bUseChatIDs=False
      bSwitchDefMap=True
      bUseRandomMap=True
      bUseUniqueID=True
      bDMSkinBright=True
      MesgTypeTime=30
      SkinBright=250
      bArena=False
      bArenaAST=False
      bArenaBIO=False
      bArenaFLK=False
      bArenaLNK=False
      bArenaMIN=False
      bArenaRED=False
      bArenaROC=False
      bArenaSHK=False
      bArenaLIT=False
      bArenaAVR=False
      bArenaGRN=False
      bArenaMLY=False
      bArenaSNP=False
      LevelEndTime=36958720
      Nounce=1

      [UT2Vote43.UT2VoteVoting]
      bChangeVote=True
      VoteMinTime=30
      VoteMaxTime=60
      VoteStepTime=7
      VoteIdleTime=5
      GameVoteTime=3
      VotePercent=51
      GameVoteLimit=3

      [UT2Vote43.UT2VoteIniOnly]
      bStandardServer=True
      ;bNoDisconnect=True
      bSortOpinion=True
      bDisplayRec=False
      bCheckMaps=False
      bDisMapCon=False
      bUseGameName=True
      bDetectUTComp=True
      bAdminAtEnd=False
      bSortMutsList=True
      bSortGameList=False
      BanMinLevs=0
      BanMaxLevs=99
      DefaultSwitch=7
      NumHitSound=5
      MapListSort=0
      WaitForLevel=120
      OtherDMPrefix=

      Comment


        #4
        did you make the accesscontrol change to your ut2004.ini?

        Comment


          #5
          I did. Otherwise I could not use ReservedSlots.

          Thanks,
          Q.

          Comment


            #6
            what functions are not working? the slap/slay etc?

            Comment


              #7
              Here budd. Everything works just "Paritally".

              Slap works fine.
              Slay works fine.
              Llama doesn't work. Only changes names.
              Mute doesn't work. Only changes names.
              Balance Teams set to false but it auto balances (very annyoing for players in trial AS games and it's my main concern. It's off in UT ini).

              That partial thing that I mentioned is because I can't do anything with admins even though AdminsImmune is set to false. Sometimes I need to slay an admin who's away from the computer for long.

              Thanks,
              Q.

              Comment


                #8
                well..if you are getting all of that to work i would chalk it up to just the flakiness of the mod...it has been unsupported for months now and it is very fragile in its stability. I have had stuff that doesn't work like i thin it should..so i have resorted to simply using it for custom messages and silent adminlogin...the other stuff i have given up on.. hopefully someone can help with this, but the author has been MIA for months.

                good luck.. sorry i can't help.

                Comment


                  #9
                  You da man!

                  QettoE

                  Comment


                    #10
                    Frogger,

                    Could you be kind to look at your System folder to see if you have "XAdmin.ini" file?

                    I kinda suspect that the old XAdmin kicks in when AccessControl is set to UAdminMod095b. The file is being created even though XAdmin is not active.

                    Thanks,
                    QettoE

                    Comment


                      #11
                      I seem to recall that when you use those features XAdmin is automatically enabled...

                      Comment


                        #12
                        Originally posted by AcidReflux
                        I seem to recall that when you use those features XAdmin is automatically enabled...
                        yes..you need to use advanced admin with uadmin. I do have xadmin.ini and it is where my username/pass are set.

                        Comment


                          #13
                          Cool, I can't think of anything else... no success so far. I'm POOPED! Forget it, if players don't like it then they can find other servers!

                          Q.

                          Comment


                            #14
                            Originally posted by QettoE

                            Balance Teams set to false but it auto balances (very annyoing for players in trial AS games and it's my main concern. It's off in UT ini).
                            Yep..thats annoying.

                            Even though benabled=False , it still auto balances the teams.

                            I did try what you said frogger, but Uadmin seems to turn it back on.

                            I really like this mod, the commands are great. I only need the teams to be changed when I type the command to do so.

                            Comment


                              #15
                              Yep. This mod is just one of those things you can't live without like AntiTCC. I emailed TBone a few times, no answer yet. I think players are going to have to live with it, or find another server! I just can't disable it!

                              I've also added a custom message showing the problem on the screen. Seems like now player don't b*tch as before, but still it's weird that Frogger don't have this problem with his server.

                              QettoE,

                              Comment

                              Working...
                              X