Announcement

Collapse
No announcement yet.

Getting a dedicated server behind router to work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Getting a dedicated server behind router to work

    I've tried everything to get my dedicated server up and running, but to no avail. I've read every resource, and looked on many forums for answers, but even though similar questions to mine have been posted, no answers have been given that help me out.

    Here is my computer setup, 3 computers behind a DI-624 router that is connected to the internet.

    Here's the deal, I can connect to my server on the lan through the ut2k4 lan tab, and everything is hunky dory, the browser will tell me the settings and ping of the server. On the main server browser tab, however, I can see my server, but no stats come up for it, and no ping is given. I can't connect to it. My friend with a computer outside this lan, can't connect to it either.

    I've opened ports 7777,7787,28902, I've set serverbehindNAT to true, I have tried setting this computer in the DMZ so that there is no firewall protecting it. Either way my server when starting up, pumps out the following:

    Init: Name subsystem initialized
    Init: Detected: Microsoft Windows XP 5.1 (Build: 2600)
    Init: Version: 3186 (127.29)
    Init: Compiled: Mar 3 2004 02:43:29
    Init: Command line: CTF-GrassyKnoll?game=XGame.xCTFGame?mutator=XGame.MutI nstaGib ini=UT2004.ini log=server.log
    Init: Character set: Unicode
    Init: Base directory: C:\Games\UT2004Server\System\
    Init: Ini:UT2004.ini UserIni:User.ini
    Init: Build label: Build UT2004_Build_[2004-03-03_02.42]
    Init: Object subsystem initialized
    Log: Executing Class Engine.ServerCommandlet
    Log: Global MD5: [3986c4774f86cab155ff9f5432b89282]
    Log: Browse: CTF-GrassyKnoll?Name=Player?Class=Engine.Pawn?Characte r=Jakob?team=255?game=XGame.xCTFGame?mutator=XGame .MutInstaGib
    Log: ProcMesh 0 shared verts.
    Log: ProcMesh 0 shared verts.
    Log: ProcMesh 0 shared verts.
    Log: ProcMesh 0 shared verts.
    Log: Collecting garbage
    Log: Purging garbage
    Log: Garbage: objects: 31158->31154; refs: 426255
    Log: Game class is 'xCTFGame'
    Log: Bringing Level CTF-GrassyKnoll.myLevel up for play (20) appSeconds: 10.288000...
    Log: (Karma): Autodetecting CPU for SSE
    Log: (Karma): Using SSE Optimizations
    ScriptLog: Mutators XGame.MutInstaGib
    ScriptLog: GameInfo::InitGame : bEnableStatLogging True
    ScriptLog: MasterServerGameStats initializing
    ScriptLog: UdpServerQuery(crt): Port 7787 successfully bound.
    Log: Resolving master0.gamespy.com...
    Log: Resolving ut2004master2.epicgames.com...
    WebAdmin: Loading Game Types
    WebAdmin: xWebAdmin.UTServerAdmin Initialized on Port 80
    Log: MasterServerUplink: Resolved ut2004master2.epicgames.com as 207.135.145.7.
    Log: Resolved master0.gamespy.com (207.38.8.34)
    ScriptLog: UdpGameSpyUplink: Master Server is master0.gamespy.com:27900
    ScriptLog: UdpGameSpyUplink: Port 7788 successfully bound.
    Log: MasterServerUplink: Connection to ut2004master2.epicgames.com established.
    Log: Master server requests heartbeat 0 with code 43888
    Log: Master server requests heartbeat 1 with code 43888
    Log: Master server requests heartbeat 2 with code 43888
    Log: Master server requests heartbeat 0 with code 43888
    Log: Master server requests heartbeat 1 with code 43888
    Log: Master server requests heartbeat 2 with code 43888
    Log: Master server assigned our MatchID: 0


    Is there something wrong there? Something I'm missing? Any suggestions? The heartbeat code is always a different number, usually in the 20,000 to 50,000 range.

    Any help would really be appreciated. Thanks.

    #2
    have you tried with NAT=false?

    Comment


      #3
      Looks like you opened 7777,7787

      Try opening the range 7777 - 7787. That is what worked for me.

      Comment


        #4
        Also make sure DMZ is off.

        Comment


          #5
          I tried NAT=False and that didn't work. DMZ is off, and I think I've tried the whole range 7777-7787 but I will try that again. Thanks

          Comment


            #6
            I also have port 28900 open and I think 7788. Also you won't be able to connect except on LAN from your own network. It has to be tested from outside the router if you don't want to use the LAN tab. My NAT is set to false. I use a D-Link router.

            Comment


              #7
              this is all i did to get mine working.....
              # Service Name Start Port End Port Server IP Address
              1 ut 7777 7777 192.000.000.000
              2 ut 7778 7778 192.000.000.000
              3 ut 7787 7787 192.000.000.000
              4 ut 7788 7788 192.000.000.000
              5 ut 28900 28902 192.000.000.000
              6 ut 80 80 192.000.000.000

              Comment


                #8
                These are the ports which the game wants open.

                UDP IN/OUT 7777 - UT Server
                UDP IN/OUT 7778 - UT Server (query port)
                UDP IN/OUT 7787 - GameSpy
                UDP IN/OUT 7788 - GameSpy
                UDP OUT 11777 - UT Master Server Game Stats
                TCP/UDP OUT 28902 - UT Master Server
                TCP IN xxxx - UT Web Admin port

                Don't open/forward a range - open/forward the ports needed.

                Comment


                  #9
                  I opened all those ports, and still nothing, and yes, I'm trying to access it through an outside machine that isn't on the network or going through that router. I have opened all those ports and made them point to the IP of the server on the network, and it's not working. I have a DLINK router, a 624 or something, its a wireless one. I have specified all these ports in the virtual server option, but no luck.

                  Comment


                    #10
                    You need to have NAT set to true.

                    Like So:

                    [IpDrv.MasterServerUplink]
                    DoUplink=True
                    UplinkToGamespy=True
                    SendStats=True
                    ServerBehindNAT=True
                    DoLANBroadcast=False


                    I had (changed to a different firewall for grins) a Dlink 604. Same as yours except it does not have wireless.

                    I had my UDP ranged ports (7777-7778, 7787-7788) set in the actual firewall rules tab as a range of ports. Why you may ask did I do it this way? umm.. laziness is one reason. I did not feel like making a single entry for the each port in the Virtual Server tab. More factual is that the DLink's have a limit to the amount of rules you can have. I found that out when I was attempting to have a Ut2003, JA, CoD and HL server all running.

                    I then had my UT port (28902) set as a virtual server. I did not use the DMZ option and never did.

                    I also run Black Ice on my game server. If you are running a personal firewall on your server, and I hope you are. You need to also open the same ports on that firewall.

                    Since I scanned this thread I did not see what OS your game server is running. If its XP you need to make sure that the builtin XP firewall is not enabled and if it is you need to choose to disable it or add these ports to pass through. Personally I would disable it and at least pickup ZoneAlarm if you can not afford Black Ice.

                    I hope that helps.

                    Comment


                      #11
                      Originally posted by PsychoChihuahua
                      These are the ports which the game wants open.

                      UDP IN/OUT 7777 - UT Server
                      UDP IN/OUT 7778 - UT Server (query port)
                      UDP IN/OUT 7787 - GameSpy
                      UDP IN/OUT 7788 - GameSpy
                      UDP OUT 11777 - UT Master Server Game Stats
                      TCP/UDP OUT 28902 - UT Master Server
                      TCP IN xxxx - UT Web Admin port

                      Don't open/forward a range - open/forward the ports needed.
                      I agree. This is what I have open and I have NAT set to false and it works fine. I don't think that matters much.

                      Comment


                        #12
                        I got it working, huzzah! It turns out Zone Alarm was stopping people from getting in, but I fixed that. Thanks everybody for your help!

                        Comment


                          #13
                          Originally posted by hellfirexq
                          I got it working, huzzah! It turns out Zone Alarm was stopping people from getting in, but I fixed that. Thanks everybody for your help!
                          zone alarm is evil.

                          Comment


                            #14
                            ZA is great (well at least ZA Pro is)
                            ZA 5.0 sucks! don;t update until the next patch. you;ve been warned!

                            Comment

                            Working...
                            X