Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

classic case.. myserver can be seen but people can't join...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • classic case.. myserver can be seen but people can't join...

    People can't join my server from internet..!!
    I already do all of the tweaks at .ini and already do all of the how to suggest ( from unrealadmin.com...).. .what next?

    FYI I'm using linux demo package. My server is behind a firewall that is a linux box running iptables..

    so what I did was to forward the tcp and udp ports to my unreal server that is using local ip

    my iptables command :... 7777 and all other required ports.....

    iptables -t nat -A PREROUTING -i eth1 -d <myfilewall live ip> -p tcp --dport 7777 -j DNAT <my internal unreal server ip>

  • #2
    If you're behind NAT you're probably bitten by this bug: --> http://www.ina-community.com/forums/...hreadid=234947

    Try to connect from Gamespy or ASE, they work correctly with servers behind NAT.

    Comment


    • #3
      Originally posted by Naked Ape
      If you're behind NAT you're probably bitten by this bug: --> http://www.ina-community.com/forums/...hreadid=234947

      Try to connect from Gamespy or ASE, they work correctly with servers behind NAT.
      Thanks. After I read the posts form your given thread, I'm wondering whats wrong with my setup.? Some of the people in there claims that
      after change to iptable or flashing their router the server behind NAT works... I still don't understand what is the bugs ... are they saying that unreal master server is changin ports dynamically so our UT server won't work behind a NATed gateway or firewall?

      Comment


      • #4
        Originally posted by linuxlah
        Thanks. After I read the posts form your given thread, I'm wondering whats wrong with my setup.? Some of the people in there claims that
        after change to iptable or flashing their router the server behind NAT works... I still don't understand what is the bugs ... are they saying that unreal master server is changin ports dynamically so our UT server won't work behind a NATed gateway or firewall?
        As for explaining the bug, I don't think I can do it better than it was done by UT2003Turner in his first post. The problem is that the master server doesn't use the port communicated in the heartbeat but uses the source of the initial connection.

        It works for some people because they have a router whose NAT implementation preserves the source number on the outgoing packets.

        If you router cannot do this, you can't connect to the server from the built-in browser. ASE and Gamespy works because they do take the port from the heartbeat messages.

        Comment

        Working...
        X