Announcement

Collapse
No announcement yet.

Updates on Security, Master Server, Stats and Email

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #91
    Originally posted by DrSiN
    There is a blocking problem with the master server that at seemingly random times causes the database access to slow to a crawl. When this happens, everone's access to the master server goes to hell.

    Stat's will probably remain offline until we find the problem or 100% verify it's not stats (things have been better since we took it offline, but not much) We are working really hard to track it down, but random problems like this are hell.
    thank you.

    Comment


      #92
      Originally posted by frogger187
      thank you.
      It's nice to see how hard they are trying hard to curb all the cheating. :up: (I know they can't stop it all, but at least they are making it a PITA to keep doing it).

      Still, I don't understand why DrSin and Wormbo don't just team up (share code and resources and ideas) and make ONE great security mut instead of trying to one-up eachother by making two seperate ones and forcing server admins to choose between them?

      Either that or somehow make them compatible so admins don't have to worry that the latest version of Anti-TCC is better than UTsecure at the moment so they need to switch until - 4days later - a new version of UTsecure is released that is better than Anti-TCC and so back to it they go.

      Bleh, maybe I just don't understand it? Wormbo has said Anti-TCC is "inspired by" utsecure and that it basically does the same thing + extra stuff... so I guess they are the same mut really... sortof... :bulb: :cry:

      Comment


        #93
        Originally posted by DrSiN

        Also, I do not ever publish or give out these ids until I have proof they are cheating. I don't agree with public black lists and I think they are bad for the community so sorry Wes.
        np. I asked because it was offered. Besides, I would use them just because I trust your judgement as well.

        Comment


          #94
          Do the master server problems effect everyone? Because I'm having trouble getting any servers in my browser.

          Thread

          Comment


            #95
            Originally posted by Ph0b0s
            Do the master server problems effect everyone? Because I'm having trouble getting any servers in my browser.

            Thread
            As Xipher said in the other thread, check your filters and make sure standard servers box is (or is not) checked.

            Comment


              #96
              Get the stats working please...

              Comment


                #97
                I hate this new software allready........

                There is a way to enable all skins for multiplayer with out beating the game.

                Now you get kick banned, and you are not cheating, IMO this is really, really, retarded....


                SP (Wich is allways LAME) mabe it's fun for skilless noobs who need to lean how to play. But I allways go MP i rarely ever play any single player games...I think it retarded you make play and beat the lame single player just to enable the skins that should be enabled anyways? WTF?


                ALSO, I have "never" gotten any ut2003 stats, and now still no ut2004 stats.. please fix this some day....

                Comment


                  #98
                  It's been discussed many times on this thread, but there is a way to "hack" the single player skins and get them without UTSecure registering as "cheating". WIth that in mind, I'd simply recommend reading this thread through -- don't bother with the SP if you don't want to, I find it kinda theraputic...

                  (tho Off-topic, I beat every ladder match and switched ladder match from qualification to championship and didn't unlock anything, like CliffyB suggested.. I haven't cleaned out the 1 on 1's / bloodrites, though, so perhaps my error lies in that)

                  Anyways. Sucks to hear the MS is having troubles (no, not the company). I know the obvious things are the first places checked, and obviously I have no clue how it operates ^_^ but I really hope it is fixed. Unusual problems with slowdown and such occured in 2k4 as well, but those were cases of the game thinking something was residing in memory that wasn't, and it panicked going for the HDD to retrieve them (the pre-caching issue).. Perhaps the MS is experiencing something similar to this, relatd to user queries or buddy list searches?

                  ... who knows.. perhaps someone thought it was cute to add "*" to their buddy list, and it is crashing the whole thing...

                  (but again, ignore me as a complete idiot who has no clue what he's talking about... =) I'm sure you don't need unsolicited help, so I promise to stay on-topic in the future)


                  OH! Which reminds me, before I bug out --

                  I know they aren't "official" maps.. but are there any plans to add the Ownage maps to the stat-tracking program in some capacity? Quite a bit of my online onslaught time has been spent in ONS_Icarus, so all my records show up as me fighting in "Unknown" maps.. it kinda looks suspicious... -_- Considering how widely available such maps will be...

                  Athenor

                  Comment


                    #99
                    Hi Neon_Cowboy,

                    Most servers, like mine, are only kicking for UTSecure positives.

                    When you get kicked out for any reason, including idling too long, the message at the top of that screen says you have been "permanently banned", but that is not true.

                    If you got kicked out of a server, like mine, for having the hacked skin files, just replace them with the ones from the CD and try to connect again to the server you like.

                    Take care,

                    -- Cain

                    Comment


                      Dr. S,

                      Is there any way that add-on Voice Packs or skin packs will cause the player to test positive with UTSecure, and get booted ??

                      -- Cain

                      Comment


                        Re: Updates on Security, Master Server, Stats and Email

                        Originally posted by DrSiN
                        UTSecure2K4 1.10 is now available. This version should close all known uscript holes in the game. If anyone out there finds a way to bypass it feel free to email me how. I have also published an update to the master server that should accept UTSecure and Anti-TCC as part of the default packages.

                        Click on this download link to download it.

                        Great! Does this fix the vulnerability posted to bugtraq about all unreal-based games? Will this work on non-ut2004 games?

                        The bugtraq article can be found at http://www.securityfocus.com/archive...8/2004-03-14/0

                        Comment


                          This bug has never been an issue in UT2004.

                          Comment


                            Hey DrSin, could you clear up ths issue of GUID`s in server logs and whether they are global or not?

                            I`m really interested to know, and I`d like to be corrected if I have misunderstood the system -- Thanks!

                            Comment


                              I've ran into a problem which appears to be caused by UTSecure 1.10. With 1.10 running, people can connect to our server, but after about 30 seconds to a minute, they get disconnected with a "Connection Lost" message. The server remains up, and they can reconnect, but the same thing happens.

                              When I was trying to figure out what was going on, I switched the mutator back to UTSecure 1.00. The problem went away. I there any reason why the server is doing this? This was tested with a fresh installation of UT2k4, with no mods, maps, or anything downloaded.

                              The server is a Linux Server, and the mutator was changed through the web-admin.

                              Comment


                                [QUOTE]Originally posted by Schitso[1g-s]
                                I've ran into a problem which appears to be caused by UTSecure 1.10. With 1.10 running, people can connect to our server, but after about 30 seconds to a minute, they get disconnected with a "Connection Lost" message. The server remains up, and they can reconnect, but the same thing happens.

                                Make sure your ServerXXXX lines are right.

                                Comment

                                Working...
                                X