Announcement

Collapse
No announcement yet.

Updates on Security, Master Server, Stats and Email

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Can I load this mut in the demo?

    [EDIT]

    Not to be a pest -- but out of about 20 public servers that we run, at least 4 are the demo. I have been asked repeatedly about the feasibility of using this mutator on the demo, or whether another solution is being developed. Thanks!

    Leave a comment:


  • replied
    Originally posted by fallen_fk
    DrSIN
    Did you get my e-mail regarding that UT Optimizer and it's possibility of being a CD Key stealer? Lotsa people used it. I mean, LOTS. Just wondering what measure's can be taken to ensure people's key's are protected.
    if you are talking about my ini editor i can tell you that it is 100% no key stealer, some stupid german brought up this rumor.

    Leave a comment:


  • replied
    Originally posted by Cainslair
    Thx Dr. Sin,

    I can confirm that it is using VERY little CPU cycles.. And it is a tiny download, with no noticeable in-game effects, thank you again.

    One problem. I know it is working, I see it at server start-up and I see it popping folks at the server's console, BUT it is not logging people it catches anywhere.. that I can find.

    I used the default .ini and made only one change and that was to allow a longer timeout period.

    Where is the log going?? Was I supposed to make a different log name??

    Thx again,

    - Cain
    You might enable the custom logging.

    Leave a comment:


  • replied
    Thx Dr. Sin,

    I can confirm that it is using VERY little CPU cycles..

    And it is a tiny download, with no noticeable in-game effects, thank you again.

    Thx again,

    - Cain

    Leave a comment:


  • replied
    Official lists

    Dr. Sin,

    Where are these mailing lists that you talk about? I've been wondering how to get on them as I run a server and I was wondering how to keep up to date on stuff.

    Can anyone clue me in on this, i've looked high and low for information?

    Leave a comment:


  • replied
    Thanks for keeping us up to date Dr. Sin. Sending word out now.

    Leave a comment:


  • replied
    I'd say there is a good chance it did something on the matter, seeing as how when I checked the ip it actually outbounds to a telus hostname, even though all it 'says' its doing is changing settings on your computer. Not to mention the 'site' that had it up (ut2k4something.tk) is now completely gone.

    Leave a comment:


  • replied
    Originally posted by DrSiN
    I'm pretty sure there is a proper way to hack the game to get all the models.. not adjust the upls (which is always a bad idea).
    I didn't adjust the upls, just added the TotalUnlockedCharater lines in the User.ini and the server would disconnect me, but without a ban message at all. I added the same line to the User.ini on the servers side and it had no problems. If some one else could confirm this, I would appreciate it though.

    Leave a comment:


  • replied
    I reset the three models "menu's" back to original and was able to connect. Anyone know of another way to do it. The Xan model is teh shiz, part of the reason I was so amped for this game.

    Anyways, let me know SiN what you guys come up with about that .exe I sent you. I know I'm hoping it didn't steal the keys properly, as a ton of people on www.teamwarfare.com downloaded it.

    Leave a comment:


  • replied
    Does this include the speed hacks I hope?

    No, speed hacks require a native server side fix and that will be included in the first patch.

    1) Does UTSecure still remove our servers from the "Standard Servers List ??? I'm guessing you fixed that ??

    That should be fixed. Same for Anti-TCC provided I got his mutator name right.

    2) Does UT Secure take noticeable server CPU cycles to run??

    It shouldn't. It does run a 10second time per player but that shouldn't be noticable.

    3) Why does the zip contain a zip, within the Zip?? What is in that other Zip, it looks like the same files <scratching head> ??

    Oops.. was wondering where it went. Funny story. I zipped it and was like shoot.. where did I put it.. so I rezipped it. Sorry. Just delete the one in the \system dir.

    Did you get my e-mail regarding that UT Optimizer and it's possibility of being a CD Key stealer? Lotsa people used it. I mean, LOTS. Just wondering what measure's can be taken to ensure people's key's are protected.

    Yes, but with all the mail server problems, I haven't had time to get a secured PC setup (in case of viruses,etc). Hopefully I'll be able to examine it tomorrow.

    If you use the default install of UTSecure, the following things (among others) will trigger an insecure client:

    - client-side brightskins
    - hacked clients that unlocked the hidden characters


    Yep.. don't cheat.

    And before everyone in the brightskins camp gets up in a tiff.. (A) bring the discussion here and I'll ban you and (B) Brightskins when made available by a server-side mod like TTM are not cheating (they are just lame). Brightskins you hack in to your game ARE cheating.

    But in the end, it's an option that admins can just disable.

    I also have reports of people restoring their default xplayersx.upl files and STILL not being able to reconnect. Dr. SiN - why is this and how can someone "restore" their client?

    They aren't restore it right I guess. Tell them to just copy the original file from the CD.

    If you want (or need) to allow client-side brightskins and clients that unlocked the hidden characters, remove these two lines from the UTSecure2k4.ini file (** WARNING - this may open your server to allow malicious skins such as black skins, triggerbot skins, and aimbot skins **):

    Yes, it will but it's the admin's choice.

    Oh - and I hope the Server Admin list comes back soon. Withdrawl sucks.

    Working on it. And yes, it really sucks. But at least I have email back so I'm giving thanks hourly.

    Do we copy and paste the contents of this file into our server's ut2004.ini, or does this exist as a stand-alone file residing in the \system folder that somehow gets read automatically ???

    Stand alone.

    Which makes me wonder if UTSecure-110 will also label those who unlocked the characters legitimately as insecure. No idea. Not that anyone actually did this.

    That's a good point. I should probably check that tomorrow

    Personally, I think this sucks. I didn't buy the game for the single player aspect. I bought it for the multiplayer and feel I should have access to all the models online. I don't use the brightskins hacks, the only thing I've edited aside of graphics stuff is the three lines in the ini regarding these characters. How the heck can that make it "unsecure"? So I have to beat the **** game to get them to work right? Grrr.

    I'm pretty sure there is a proper way to hack the game to get all the models.. not adjust the upls (which is always a bad idea).

    Leave a comment:


  • replied
    I MAY have found a fix for it not allowing the locked characters online if you didnt complete the SP, although I wasn't getting the ban message like above so it might have been a different problem.
    Try adding the same lines into the User.ini at the server that you had to add for your personal game, its working for me, but I also have a little problem when I am the only user on the server and the initial count down is stuck, but if I leave and reconnect it completes the count down. Might just be that its waiting for other players.

    Leave a comment:


  • replied
    Originally posted by Dubious
    There was a method floating around that unlocked the hidden characters in the game without having the user complete the single player missions. If someone used this method to unlock the characters and joins a server using a default UTSecure-110 install, they will be labeled as an insecure client.

    Which makes me wonder if UTSecure-110 will also label those who unlocked the characters legitimately as insecure. No idea. Not that anyone actually did this.
    I assume this is why I am now getting this...

    [screenshot]http://www.crossoveresports.com/screenshots/md5check.jpg[/screenshot]

    Personally, I think this sucks. I didn't buy the game for the single player aspect. I bought it for the multiplayer and feel I should have access to all the models online. I don't use the brightskins hacks, the only thing I've edited aside of graphics stuff is the three lines in the ini regarding these characters. How the heck can that make it "unsecure"? So I have to beat the **** game to get them to work right? Grrr.

    As for my previous post, any word on that DrSiN? I e-mailed you some more info, let me know if you're getting it or not.

    -Josh

    Leave a comment:


  • replied
    Originally posted by Dubious
    There was a method floating around that unlocked the hidden characters in the game without having the user complete the single player missions. If someone used this method to unlock the characters and joins a server using a default UTSecure-110 install, they will be labeled as an insecure client.

    Which makes me wonder if UTSecure-110 will also label those who unlocked the characters legitimately as insecure. No idea. Not that anyone actually did this.
    Doh I did this myself.
    And your correct, my lan box boots me after about a minute of play, with no warning or any thing. I am going to try something quick, see if I can fix it.

    Leave a comment:


  • replied
    Sweet !!

    Thanks Dubious, Thx Dr. S. for that feature.

    One more question from an "old skool" UT99 Admin.

    Where exactly do the bans go now?? Are they still in the Ut20o4.ini (if so, where), or are they contained elsewhere in a diffeent file ??

    I want UTSecure to log for now, then I plan to manually go back and ban the ones that look like outright hacks, so I need to know where to place the UIDs I want to ban.

    Thanks for the help!!

    -- Cain

    Leave a comment:


  • replied
    Do we copy and paste the contents of this file into our server's ut2004.ini, or does this exist as a stand-alone file residing in the \system folder that somehow gets read automatically ???
    Its stand-alone this time around. No pasting needed.

    Leave a comment:

Working...
X