Announcement

Collapse
No announcement yet.

Bots are ruining my good times on my LAN

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    You can have one or the other, but not both, eh? Good thing there's still ways to set up what I want

    Leave a comment:


  • replied
    I agree. I also find it rather strange that when using the "Players vs Bots" option, the number of bots can't be changed, but it still takes effect.

    Leave a comment:


  • replied
    Yeah, that's what I ran into. Doesn't make any sense to have the option if it doesn't pit the players against the bots you want... but at least there's other ways.

    Leave a comment:


  • replied
    I have tried using the "Players vs Bots" option too, but for some reason the number of bots will always match the number of players. So if one player would play there would be one bot, for two players there would be two bots, etc.

    Leave a comment:


  • replied
    ahh, that number is currently 7... I'll finagle with it tonight and see what happens, thanks. I'm pretty sure that will fix it.

    Although like I said I am near certain both balance options are turned off, and that "players vs bots" should work the way I want it to... but doesn't seem to, so I have to use the roster.

    Leave a comment:


  • replied
    Like Sly said, both "Players balance teams" and "Bots balance teams" need to be disabled.

    Then, go to the 'Game Settings' tab (if I remember correctly), and set the Bots to "Specify Number". There, enter the total number of players and bots that will join the game. So if you and your brother want to play against 4 bots, set this number to 6.

    After you've done this, set the Bots back to "Use bot roster". Now simply drag the bots to the desired teams and it should work.
    Also make sure that both you and your brother have the same team set at "Preferred team" at the 'Settings ยป Player' menu.

    (Note: Even though you set Bots to "Use bot roster", the total number of bots will depend on the value set at "Specify Number")

    (Another note: Keep in mind that every time you want to add more bots or remove bots, you also need to change the value at "Specify Number".)

    Hope this helps!

    Leave a comment:


  • replied
    Or you try...THIS

    Once you get it installed, look at the ServerBots2.ini file under the heading,

    "[ServerBots2.Configs]"
    and find
    PlayBotTeam=False

    change it to:
    PlayBotTeam=True

    After that save and exit the .ini file, start your server and when the match starts all Human Players will play an all Blue Bot Team.

    Leave a comment:


  • replied
    Try .... THIS

    Gives you total control over exactly what bots appear on what teams, even what difficulties each one has. And yes, you can put yourself vs 16 bots if you want...

    Leave a comment:


  • replied
    Then I can't use the roster I want to use. I like to play with specific bots, as sometimes I use UT2004RPG.

    I know, it's kind of a pain in the ***.

    Leave a comment:


  • replied
    You could always try adding the bots with a console command. After an adminlogin password command it would be admin addbots 04 or w/e number you want to use. That may be the simplest and most reliable thing for your lans. So I'd set it so zero bots, and just add say 4 or 2 bots to the mix once the match starts.

    Leave a comment:


  • replied
    It is, that's the problem. It's doing it anyway.

    BTW I realize I should have put this in Server Administration, I reported it and asked for it moved. Sorry about that.

    Leave a comment:


  • replied
    There should be something like "player balance team" and/or "bot balance team" in the server settings when you host a server.

    Disable this

    Leave a comment:


  • started a topic Bots are ruining my good times on my LAN

    Bots are ruining my good times on my LAN

    Hey guys, I'm wondering if someone knows what I'm missing here.

    My brother hosts a server that I join (he can't connect to me for whatever reason, I have to connect to him. No big deal.)

    Well, we want to play against bots, so the first thing I tried was set up Players vs Bots in the Rules tab. Unfortunately, it gives us an equal number of bots-players ratio (that is, two bots for two players.) I want to play 4 or 6 vs us 2. We tried Onslaught and CTF and it still gives us just two random bots.

    So the next thing I tried was to "Use Bot Roster" figuring it would use the bots I tell it to use. It halfways works... we put 4 bots on red and no bots on blue, and when we get into the game, we have the 4 red bots I specifically chose, and us two on blue, but we always have a random bot partner we don't need or want. We can't seem to kick it from the server either, even with admin privileges.

    Am I missing a "team balance" option somewhere? I have all that unchecked in the options menus.
Working...
X