Announcement

Collapse
No announcement yet.

Can't get TAM-server on masterlist

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Can't get TAM-server on masterlist

    Hi guys,

    been trying for 2 weeks to get a TAM-server listed on the masterlist without any luck.. so I'm turning to you smart guys:
    The server works in every way, except it WON'T show on the masterlist - regardless of what I do. External people can connect & play just fine going directly on the IP/port.

    Relevant ut2004.ini entries:
    [Engine.Engine]
    DefaultGame=3spnv3141.TeamArenaMaster
    DefaultServerGame=3spnv3141.TeamArenaMaster

    [Engine.GameEngine]
    ServerPackages=3SPNv3141

    [xVoting.xVotingHandler]
    GameConfig=(GameClass="3SPNv3141.TeamArenaMaster", Prefix="DM",Acronym=,GameName="AM",Mutators="None" ,Options=)

    Log from startup:
    -----------------------------------
    ./ucc-bin server Dm-Rankin?Game=3SPNv3141.TeamArenaMaster?GameStats=Tr ue log=/home/ut1/ut1_server.log ini=ut2004.ini --nohomedir
    Executing Class Engine.ServerCommandlet
    Browse: Dm-Rankin?Name=Player?Class=Engine.Pawn?Character=Jak ob?team=255?Game=3SPNv3141.TeamArenaMaster?GameSta ts=True
    Collecting garbage
    Purging garbage
    Garbage: objects: 36757->36752; refs: 463382
    Game class is 'TeamArenaMaster'
    Bringing Level Dm-Rankin.myLevel up for play (35) appSeconds: 3.754257...
    center pointLoading Admins & Groups
    Kick and Ban Privileges Loaded
    Maps & Game Privileges Loaded
    Admins & Groups Management Loaded
    Extra Privileges Loaded
    GameInfo::InitGame : bEnableStatLogging True
    MasterServerGameStats initializing
    UdpServerQuery(crt): Port 7017 successfully bound.
    Resolving master0.gamespy.com...
    Defaulting to false
    Defaulting to false
    Resolving ut2004master1.epicgames.com...
    Loading Available Maps
    Loading Game Types
    xWebAdmin.UTServerAdmin Initialized on port 8181
    MasterServerUplink: Resolved ut2004master1.epicgames.com as 216.27.56.6.
    Resolved master0.gamespy.com (207.38.11.34)
    UdpGameSpyUplink: Master Server is master0.gamespy.com:27900
    UdpGameSpyUplink: Port 7018 successfully bound.
    MasterServerUplink: Connection to ut2004master1.epicgames.com established.
    Approval APPROVED
    Master server requests heartbeat 0 with code 20840
    Master server requests heartbeat 1 with code 20840
    Master server requests heartbeat 2 with code 20840
    Master server assigned our MatchID: 39174300

    -----------------------------------

    While troubleshooting I've tried pretty much anything I can think of:
    -I've set up UT2K4 from scratch (meaning everything) 3 times, on 2 different boxes / 2 different ISPs
    -Changed ports a billion times
    -Left the server on for days without it appearing. I can start any new non-TAM server on the same box, and have it registered on the masterlist a few seconds later
    -Disabled all kinds of mutators. On my last installation I got ut running and only installed the 3SPN-files & added the ut2004.ini entries
    -This is the only server running on the latest box I've tried setting up a TAM-server on

    Other info:
    -Running on latest version of Ubuntu
    -Installed all the latest ut-patches


    Hopefully someone can point me in the right direction. From what I can tell logfiles are not giving me any relevant info, and the server appears to be in dialogue with the masterservers.

    Thanks,
    P

    #2
    The uplink-part is naturally okay:

    [IpDrv.MasterServerUplink]
    DoUplink=true
    UplinkToGamespy=true
    SendStats=true
    ServerBehindNAT=false
    DoLANBroadcast=false
    bIgnoreUTANBans=False

    Comment


      #3
      Any suggestions guys?

      Comment


        #4
        No... No idea, if it says "Master server assigned our MatchID: 39174300" then it should be OK...

        Comment


          #5
          Yeah that's the thing.. I have basically nothing to troubleshoot from :-S

          I've left the server on 3 days straight, so it has nothing to do with waiting. I tried setting up a normal CTF-server on the same box, just to check - and it was on the masterlist seconds after I started it.

          Anyone else have suggestions on how to approach a problem like this ? This is driving me nuts.. I've set up the TAM-server from scratch sooo many times now :-S

          Comment


            #6
            what's strange to me is once its a favourite it also appears in internet tab, remove it from fav's and it doesn't appear in there again

            Comment


              #7
              Yeah this is weird

              I am now trying to run the same TAM-server from 2 different boxes, on 2 different ISPs. Both have been completely set up from scratch twice, including re-downloading _all_ files.. And I still have the same issue on both boxes :-S

              Comment


                #8
                hmmm are you downloading tam from same place? maybe its corrupt somehow 0-o but still works fine :S :P , if its even a different version then it would explain it.. as there's 2 versions of tam v3, but i think your using latest one 3141..

                Comment


                  #9
                  Nah, believe I've used different sources earlier. Regardless, downloaded it again, this time from utzone.de. Know for sure it wasn't my previous source. Server was restarted with the new files 2-3 hours ago, still nothing :-/

                  Comment


                    #10
                    hmm i just thought of 1 possible reason.. dunno if it is it tho, what files of ut did you install? i cannot recall which.. but one of the official files changes the ut patch version number.. think it was the editors choice..maybe , but i had to install the latest patch twice, because my ut wasn't set to the latest patch.. depends what files you installed tho.. i cannot be sure which file it is, but if your server is running an older patch number it might not appear for others who have different patch number... just an idea.. i think it will tell you in ut2004 ini which version your running... i only know that cus i tryed installing a umod and it told me to install the latest patch which i had done not 10 mins before i tryed to install that file! worth a look... :P

                    Comment


                      #11
                      Hi,

                      I have installed the same files as I'm using on several working CTF-servers.. so unless there's a particular patch not working with 3SPN v3141, they should be fine:

                      dedicatedserver3339-bonuspack
                      ut2004-lnxpatch3369-2
                      3spn v.3141

                      Looking at other TAM-servers on the masterlist the versions seems to be the same.

                      -P

                      Comment


                        #12
                        Trying to bump this, hoping someone might help me troubleshoot or give me some ideas.
                        I put this on hold for a while, re-setup things again, but I'm still struggeling getting a listing on the masterserver.

                        I still get a MatchID from masterserver, the server still works fine when connecting on IP - but no listing :/

                        Comment


                          #13
                          If I start the same server with commandline ?game=XGame.XDeathMatch, instead of ?game=3SPNv3141.TeamArenaMaster, the server is listed instantly on the masterlist :S

                          There has to be some minor config error I keep doing over and over again, as I've been having the same problem on different installations/physical servers? Any ideas would be much appreciated.

                          Best regards,
                          P

                          Comment


                            #14
                            It may be that its showing up in another gametype list, just becuase its tam doesnt mean it has to show up in that list.

                            Comment


                              #15
                              also im getting the exact same problem as you except it still wont appear when i change the gametype to DM.

                              EDIT: also the strange thing is that this only started after i attempted to change the server port.

                              Comment

                              Working...
                              X