Announcement

Collapse
No announcement yet.

Creating UT2004 User Profiles

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Creating UT2004 User Profiles

    This will tell you how to create differen't Profiles for UT2004.

    I took it from the Advanced Movies Tutorial, and modified it a bit. This inspired me to do it. Read on!


    Creating a new Profile
    Yes, it IS possible to create profiles in UT2004, but it's complicated. This is what you do:
    1. Go to your "c://UT2004/System" folder
    2. Make a copy of each "Default.ini" and "DefUser.ini"
    3. Rename the copy of "Default.ini" to "<name>_ut.ini"
    4. Rename the copy of "DefUser.ini" to "<name>_user.ini"
    5. Create a new shortcut for "UT2004.exe" on your Desktop
    6. Right Click on that shortcut and select "Properties"
    7. Change the Target to "C:\UT2004\System\UT2004.exe -userini=<name>_user.ini -ini=<name>_ut.ini"
    8. (Optional) Rename the Shortcut to "<name> UT2004"


    <name> would be the name of the player / profile, of course.
    When you click that shortcut, it will be like a fresh install, and you'll have to configure it. But that should be no problem.

    Hope it was helpfull!


    eviL<3

    #2
    That's awesome! Thank you!

    Comment


      #3
      Thanks a bunch. That's exactly what I was looking for.

      Chris

      Comment


        #4
        Originally posted by kanuuker
        Thanks a bunch. That's exactly what I was looking for.

        Chris
        Hehe, i created it just for you, but for all to read

        Comment


          #5
          There is a simple freeware that do that for you.
          It is called "UT profiles manager".

          Go here for more informations : http://forum.skill-club.com/showthre...threadid=13266

          Comment


            #6
            just feedback

            good stuff, I have had to do something very similar in Diablo II

            But only one problem.

            I get

            when I try and load a profile.

            I installed using the dvd edition of the game ( hate cd swapping )

            But my normal shortcut to the game runs fine.

            Thx for the TUT, just giving feedback.

            Btw, if you install using DVD edition, you must install patch in order for the cdkey error message to go away. It's a known problem, had a fit when I first bought it untill I googled it and found that other users had the same problem. May be different with other versions of the install with the profiles and all.. gl

            Comment


              #7
              Tip:

              As a base for the new ini's, copy the allready configured ones (UT2004.ini / user.ini) instead of the default ones.

              I renamed them to UT2004myname.ini and Usermyname.ini, for keeping them alphabetically close to the originals.

              Change shortcut properties to execute:
              blablabla\UT2004.exe -ini=UT2004myname.ini -userini=Usermyname.ini

              I have this workin' since a long time, one set up for FPS, one set up for max. details.

              Comment


                #8
                nice work evil!

                Comment


                  #9
                  Good tipp fftunes, thanks!

                  Comment


                    #10
                    Is there any way to load an INI ingame with set input or something?

                    I think Elaphe wonders too.

                    Comment


                      #11
                      I think this answers your Question... here's the Ultimate Keybind Guide, wich also explains using exec commands.

                      You can't change the ini, but you can change all ini settings, using a command. The exec works like a .bat file, just that it's UT2004 commands. You could have a file called "Blah.txt"
                      Originally posted by blah.txt
                      switchweapon 1
                      The command would be "exec blah.txt". It would be the same like the command "switchweapon 1".

                      "set input" is used to change keybinds ingame. So "set input [key] [command]" would be the same as opening user.ini and changing it manually.

                      Hope that helps you understand it

                      Comment


                        #12
                        i tried this but when i got to the properties of the shortcut, the target couldnt be found.

                        i then tried on the demo and still couldnt get it to work. i changed the names to

                        tj_ut.ini and tj_user.ini , then the target of shortcut to

                        "C:\Documents and Settings\Tod\My Documents\My Games\UT2004Demo\UT2004Demo\System-userini=tj_user.ini -ini=tj_ut.ini"

                        what am i doing wrong?

                        Comment


                          #13
                          It must be "C:\Documents and Settings\Tod\My Documents\My Games\UT2004Demo\UT2004Demo\System\UT2004.exe -userini=tj_user.ini -ini=tj_ut.ini"

                          Comment


                            #14
                            i tried that and it didnt work. the target worked when i selected

                            "C:\Documents and Settings\Tod\My Documents\My Games\UT2004Demo\UT2004Demo\System"

                            but wouldnt work when i added anything on after that.

                            Comment


                              #15
                              I think it has to be that way:

                              "C:\Documents and Settings\Tod\My Documents\My Games\UT2004Demo\UT2004Demo\System\UT2004.exe" -userini=tj_user.ini -ini=tj_ut.ini

                              Comment

                              Working...
                              X