Announcement

Collapse
No announcement yet.

UDK DirectX11: bSelfShadowOnly=true not working?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UDK DirectX11: bSelfShadowOnly=true not working?

    Could somebody please show me how to stop a first person arm from dropping its shadow on other primitives?

    Code:
    Begin Object Class=SkeletalMeshComponent Name=smc
    		SkeletalMesh=SkeletalMesh'game_upk.colt45_2011'
            
    		Animations=MeshSequenceA
    		LightEnvironment=MyLightEnvironment
    		 
    		CastShadow=true
    		bCastDynamicShadow=true
    		
    		bSelfShadowOnly=true
    End Object

    bSelfShadowOnly=true works well on UDK DirectX9, but does not work on UDK DirectX11 (this feature does not work with a skeletal mesh in UDK Editor as well).


    Is there a way to stop a first person shooter arm from dropping its shadow on other primitives on UDK DirectX11? (I don't want to turn off "Cast Shadow", "Cast Dynamic/Static Shadow" on the fist person arm).

    #2

    Comment

    Working...
    X