No announcement yet.

UDK gets stuck in an endless loop while building maps

  • Filter
  • Time
  • Show
Clear All
new posts

    UDK gets stuck in an endless loop while building maps

    I have a problem with UDK and building maps. Every time I ask to build the map, build the lighting (or likely anything of the sorts), the program ends up in some sort of endless loop. It will get stuck on the first or second task, and the time it is taking will just keep going up without anything happening. I cannot even stop the build at that time, since the endless loop will just continue, with only the task name getting changed. The only option I have then is to just kill it through task manager. Everything else works. I can play the stages I made without any problems and the code compiles just fine as well. It is only calculating anything in the editor that causes it to end up in an endless loop.

    Obviously, this is majorly annoying, since I already lost more than enough time with a broken down notebook and having to migrate everything to a new machine.


    I should note that at the time of writing, the counter has already gone up to 12 minutes without any change in what it's "calculating."

    I am using a fairly old build of UDK, namely the 2012 July beta. My current operating system is Windows 8.1. The specs of the machine are intel i7 4710MQ, Geforce GTX 860M and 24GB RAM. It should have more than enough strength to deal with the stage in this particular screenshot, as the machine I had before this (that is now about 5 years old) would have finished by now.

    Edit: I have now tried the latest UDK Beta as well (the May 2014 one) and the problem is exactly the same. It just gets stuck on the first task. We are not talking about difficult maps here either; this is just calculating a single brush with a single point light and after clicking the "build all" command, it has been stuck on "Applying Structural Brush 1 of 1" for 11 minutes already and counting.

    go to your UDK directory >> open Binaries >> open SwarmAgent.exe
    then Build your Lighting
    it worked for me