Announcement

Collapse
No announcement yet.

Can't create landscape

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Can't create landscape

    Hi All,

    I'm just trying to create a landscape using the landscape mode having only ever made terrains previously. I am falling at the first step...it just won't seem to work.

    I create a new level with midday lighting. Click landscape mode, enter a heightmap size (505 pixels), component size (63) and 4 components per section. Click create Landscape and.... several flickering strips appears in the editor, together with the icon for the landscape. The flickering strip seems to extend away to infinity from the origin in the x and y direction. If I try add the landscape to an empty level, nothing appears at all.

    Either there is some critical setup step that isn't covered by the tutorials, or I am suffering a strange hardware issue (which would be strange, I am using an Alienware x17 which has a DX11 compliant graphics card.

    Any suggestions would be appreciated, everyone else seems to be able to make it work.

    Many thanks,
    Matt

    #2
    This sounds strange. Try to setup a landscape like im showing in my tutorial: http://www.youtube.com/watch?v=bCH1Ciy05_A

    Comment


      #3
      I tried the same 127x127 as in your tutorial, and removed my exponential fog. However, I still get the same, two flickering strips extending away to infinity. The effect looks like a rendering problem, such as when there are two planes too close together.

      Comment


        #4
        could you post a picture?

        Comment


          #5
          Yep, here you go. It is very uninspiring...

          Comment


            #6
            Which UDK Build?
            Can you select the polys? When you do, does the Actor Properties window state that it is a Landscape actor?

            Comment


              #7
              I've tried two builds UDK-2012-10 and UDK-2013-02. Neither work.

              The actor properties window recognises it is a landscape, but it doesn't allow the landscape (strips) to be changed by brushes.

              Strangely I have UDK on an older computer (5 years old) and landscape works on that, so this may be a hardware issue. I am using a GeoForce GTX 675M on windows 7 64-bit. It is a bit disturbing if landscape doesn't display on some modern graphics cards. I wonder if there is some graphics card setting I can change that will enable landscape to be displayed. I've not had any other issues with the graphics card with any other games.

              I'll try reinstalling UDK from scratch.

              Comment


                #8
                I've managed to create a landscape by setting the renderer to DX9. Should it work on DX11?

                Comment


                  #9
                  it should work in DX11, yes.
                  then again everything should work in DX11 but a lot of things don't work properly, don't work for everyone, or don't work at all :/

                  Comment


                    #10
                    Originally posted by hptware View Post
                    Should it work on DX11?
                    I just tried creating a landscape using the dimensions from your first post in DX11 and it worked fine.

                    Comment


                      #11
                      The GeForce 675M is a laptop graphics set.
                      If your laptop requires proprietary drivers you are probably out of luck.
                      If it can use the NVidia drivers, then try the latest full (non beta) version.
                      If still no go then you are out of luck. A reason to not try using laptops for production work.

                      Comment

                      Working...
                      X