Announcement

Collapse
No announcement yet.

Epic Citadel - No Collision - Strategies?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Epic Citadel - No Collision - Strategies?

    So yeah, I am a newbie to the UDK. I have been exploring the new features, which I am a ancient Unreal Editor I content designer. I just now came out from under the rocks of the original Unreal because I found interesting ideas for why I would use the UDK. I've learned most of the UDK over the last two weeks, plenty of tutorials involved. But today, I opened up the Epic Citadel showcase for iOS... and was puzzled by the amazing static mesh geometry involved. It was SOLID, but as I thought to my self. The land is too good to be true, where is the terrain brush at. Where is the BSP Brushes at, no subtraction or additives anywhere? They must had been smoking something really good to make such a badass map with only the single use of Static Meshes. So I began to decode the map, sort of by pulling pieces and parts away from each other. Well, I noticed that the map hasn't got any collision... yet I am able to walk around. None of the static meshes used for the ground contain collision, nor is there a single volume or object blocking me from falling. So I decided to hide the static meshes and stuff, and enable the collision and bounds in wireframe. Yet, nothing pops up... so I am left with a really weird feeling like Epic Games is hiding something from us. I've come here to simply ask, how the heck did they make Epic Citadel without collision boundaries.

    I have made a video to further more demonstrate my question...

    Click here for the video

    #2
    There is collision geometry. It is in a layer that is hidden in the editor. you can toggle the visibility on the layer and see the collision.

    Comment


      #3
      Originally posted by ffejnosliw View Post
      There is collision geometry. It is in a layer that is hidden in the editor. you can toggle the visibility on the layer and see the collision.
      Hmm, I expanded the Show Layers tab... and selected Collision. But it didn't seem like it exposed anything, I disabled the visibility of static meshes after to see if anything changed but nothing there either. It's very weird :|

      When you get a chance, open up the map and take a look around... if you haven't already it should leave you questioned too :|

      Comment


        #4
        I had that problem also follow this;

        https://www.youtube.com/watch?v=eW3io1_3r48

        Comment


          #5
          Originally posted by McTune View Post
          I had that problem also follow this;

          https://www.youtube.com/watch?v=eW3io1_3r48
          OH!!! LOL!!!

          This is most helpful, thanks for the help guys. You know what, I think I rolled over this video once but didn't click on it. So, the technique they used to make these maps was to have a High Poly Surface model without collision and then import a Low Poly Surface model with collision. Is there a tutorial on how to make this collision model and put it in a map?

          I am really satisfied with your help, this will help my special oldschool Zelda project I am making

          Comment

          Working...
          X